Re: Error 212/130 creating index on a temp table
Posted in 1998
In article <34E0956B.BEE15535@garpac.com>, Jacob Salomon
<jake@garpac.com> writes
>Hi Family.
>
>I have a case with Informix but the person handling it is now in class
>so I reach out to y'all, hoping for a person who as experienced this and
>solved it.
>
>HP-UX 10.10
>DSA 7.13.UC5
>I recently reloaded a moderate-sized database (for defragging) and some
>4GL applications are suffering a wierd problem. They create a few temp
>tables (with no log). A judicious query against sysmaster establishes
>that the table is, indeed, spread across the 4 temp dbspaces. Now the
>app creates a unique index againse one of those temp tables. It gets
>error 212 (Unable to add index) and ISAM error 130 (No such DBSpace).
>
It may be a problem with DBSPACETEMP.
>Clearly, this is ridiculous - The app does not specify a dbspace in any
>of the create table/index statements. (Actually, the temps are created
>via SELECT INTO TEMP statements.)
>
Does the app have the DBSPACETEMP environment variable set?
I believe it overrides the onconfig setting.
Or does the user have a $HOME/.informixrc file?
>When I run these statements in dbaccess or a 5-line 4gl program, I
>cannot replicate this problem. It happens only in the app.
>
>There is no problem of space - there are over 800 mb of temp space
>available. And that would be the wrong error message anyway.
>
>Using onmode -I 130 (not recommended until Informix documents it better
>in Appendix B) I managed to get a stack trace when someone incurred this
>error and mailed that to the tech support guy. I reluctantly include it
>here - maybe someone will recognize something and tell me what's going
>on. IMO it's a bug that allowed some tiny corruption to happen.
>
>Any ideas?
>
>Thanks.
>
>08:50:27 Assert Failed: found errno 130 in session 2853
>08:50:27 Who:Session(2853, sramjatt@bacchus, 23491, -897313956)
> Thread(8202, sqlexec, ca82b8dc, 3)
>08:50:27 Action: Use onmode -i to allow OnLine server to continue.
>08:50:27 See Also: /usr/archive/informix.DUMPDIR/af.200a1523,
>shmem.200a1523.0
>08:50:27 Stack for thread: 8202 sqlexec>
> base: 0xcc5c5270
> len: 36864
> pc: 0x00000000
> tos: 0xcc5c6370
>
>( 0) 0x002ae438 afstack + 0xf0 [/usr/informix/bin/oninit]
>( 1) 0x002adc94 mt_affail + 0x2ec [/usr/informix/bin/oninit]
>( 2) 0x001bb3a0 rsam_affail + 0x18 [/usr/informix/bin/oninit]
>( 3) 0x001bb788 check_traperror + 0x150 [/usr/informix/bin/oninit]
>( 4) 0x00199fa4 setiserrno + 0x34 [/usr/informix/bin/oninit]
Set ISAM Errno?
>( 5) 0x001a0140 rsdbspace + 0xb8 [/usr/informix/bin/oninit]
Something dbspace?
>( 6) 0x00226cc0 rspnbuild + 0x208 [/usr/informix/bin/oninit]
Partition build?
>( 7) 0x002ff52c fmaddindex + 0x4bc [/usr/informix/bin/oninit]
Add index?
>( 8) 0x00085ab8 sqisaddindex + 0x50 [/usr/informix/bin/oninit]
>( 9) 0x0004a120 sqmgm_isaddindex + 0x188 [/usr/informix/bin/oninit]
>(10) 0x000d1940 creaidx + 0x348 [/usr/informix/bin/oninit]
create index?
>(11) 0x0002039c aud_creaidx + 0x24 [/usr/informix/bin/oninit]
>(12) 0x00044e18 excommand + 0xf38 [/usr/informix/bin/oninit]
Execute command?
>(13) 0x0013a914 sq_execute + 0xfc [/usr/informix/bin/oninit]
Execute an sql command?
>(14) 0x000fbab0 sqmain + 0x170 [/usr/informix/bin/oninit]
>(15) 0x002b217c startup + 0x9c [/usr/informix/bin/oninit]
>(16) 0x002aa69c resume + 0xd4 [/usr/informix/bin/oninit]
Looks like a dbspace problem.
Remember that index builds can involve parallel sorts
Is the enviroment variable PSORT_DBTEMP set?
--
David Williams
Maintainer of the Informix FAQ
Primary site (Beta Version) http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html
I see you standin', Standin' on your own, It's such a lonely place for you, For
you to be If you need a shoulder, Or if you need a friend, I'll be here
standing, Until the bitter end...
So don't chastise me Or think I, I mean you harm...
All I ever wanted Was for you To know that I care