Problems since upgrade to IDS 11.10.UC1
Posted in 2008
Topics: Installation, Setup & Upgrades, Stored Procedures & SPL, Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion, Versions, Editions & End-of-Life
I've got an IBM x3650 that ran SLES9/IDS10 for a very long time without
so much as a hiccup. However, since the update to SLES10sp1/11.10.UC1
there have been a couple of issues including one crash of the IDS server
(the box didn't crash, Informix just went down).
The crash was
---------------------
10:42:03 Assert Failed: Memory block header corruption detected in
mt_shm_free 1
10:42:03 IBM Informix Dynamic Server Version 11.10.UC1
10:42:03 Who: Session(251383, fklott@DRILL.morrison.iserv.net, 183302,
0x57ef86b0)
Thread(252614, sqlexec, 57ed1d20, 3)
File: mtshpool.c Line: 3349
10:42:03 Results: Unable to repair pool
10:42:03 Action: Please notify IBM Informix Technical Support.
10:42:03 stack trace for pid 18222 written
to /var/log/informix/dump/af.deae484b
10:42:03 See Also: /var/log/informix/dump/af.deae484b,
shmem.deae484b.0
10:42:03 Unable to create output file
'/var/log/informix/dump/shmem.deae484b.0' errno = 13
10:42:03 Memory block header corruption detected in mt_shm_free 1
10:42:03 stack trace for pid 18222 written
to /var/log/informix/dump/af.deae484b
10:42:03 Assert Failed: No Exception Handler
10:42:03 IBM Informix Dynamic Server Version 11.10.UC1
10:42:03 Who: Session(251383, fklott@DRILL.morrison.iserv.net, 183302,
0x57ef86b0)
Thread(252614, sqlexec, 57ed1d20, 3)
File: mtex.c Line: 489
10:42:03 Results: Exception Caught. Type: MT_EX_OS, Context: mem
10:42:03 Action: Please notify IBM Informix Technical Support.
10:42:03 See Also: /var/log/informix/dump/af.deae484b
10:42:03 mtex.c, line 489, thread 252614, proc id 18222, No Exception
Handler.
10:42:04 Fatal error in ADM VP at mt.c:13315
10:42:04 Unexpected virtual processor termination, pid = 18222, exit =
0x100
10:42:04 PANIC: Attempting to bring system down
10:42:04 semctl: errno = 22
-----------------
Only there was no dump in /var/log/informix/dump/ :(
The server came back up and seemed to work fine; except now we have a
stored procedure which worked before but now fails with a -661 (Number
of variables does not match number of values returned). No change was
made to the procedure; dropping and recreating didn't help.
I've been able to dbexport the database after the crash, except for one
table which I restored from a backup.
Anyone else had issues with IDS 11.10UC1 on SLES10?
HI,
Although not in production I had similar issues with FC1 -- however
since upgrading to 11.10.FC2 the engine has been rock solid.
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
Adam Tauno Williams
Sent: 08 January 2008 11:19
To: ids@iiug.org
Subject: Problems since upgrade to IDS 11.10.UC1 [10875]
I've got an IBM x3650 that ran SLES9/IDS10 for a very long time without
so much as a hiccup. However, since the update to SLES10sp1/11.10.UC1
there have been a couple of issues including one crash of the IDS server
(the box didn't crash, Informix just went down).
The crash was
---------------------
10:42:03 Assert Failed: Memory block header corruption detected in
mt_shm_free 1
10:42:03 IBM Informix Dynamic Server Version 11.10.UC1
10:42:03 Who: Session(251383, fklott@DRILL.morrison.iserv.net, 183302,
0x57ef86b0)
Thread(252614, sqlexec, 57ed1d20, 3)
File: mtshpool.c Line: 3349
10:42:03 Results: Unable to repair pool
10:42:03 Action: Please notify IBM Informix Technical Support.
10:42:03 stack trace for pid 18222 written
to /var/log/informix/dump/af.deae484b
10:42:03 See Also: /var/log/informix/dump/af.deae484b,
shmem.deae484b.0
10:42:03 Unable to create output file
'/var/log/informix/dump/shmem.deae484b.0' errno = 13
10:42:03 Memory block header corruption detected in mt_shm_free 1
10:42:03 stack trace for pid 18222 written
to /var/log/informix/dump/af.deae484b
10:42:03 Assert Failed: No Exception Handler
10:42:03 IBM Informix Dynamic Server Version 11.10.UC1
10:42:03 Who: Session(251383, fklott@DRILL.morrison.iserv.net, 183302,
0x57ef86b0)
Thread(252614, sqlexec, 57ed1d20, 3)
File: mtex.c Line: 489
10:42:03 Results: Exception Caught. Type: MT_EX_OS, Context: mem
10:42:03 Action: Please notify IBM Informix Technical Support.
10:42:03 See Also: /var/log/informix/dump/af.deae484b
10:42:03 mtex.c, line 489, thread 252614, proc id 18222, No Exception
Handler.
10:42:04 Fatal error in ADM VP at mt.c:13315
10:42:04 Unexpected virtual processor termination, pid = 18222, exit =
0x100
10:42:04 PANIC: Attempting to bring system down
10:42:04 semctl: errno = 22
-----------------
Only there was no dump in /var/log/informix/dump/ :(
The server came back up and seemed to work fine; except now we have a
stored procedure which worked before but now fails with a -661 (Number
of variables does not match number of values returned). No change was
made to the procedure; dropping and recreating didn't help.
I've been able to dbexport the database after the crash, except for one
table which I restored from a backup.
Anyone else had issues with IDS 11.10UC1 on SLES10?
************************************************************************
*******
Forum Note: Use "Reply" to post a response in the discussion forum.
See you at the IIUG Informix 2008 Conference
The Power Conference for Informix Professionals
April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas
http://www.iiug.org/conf
Registration Now Open!!