Assert Failed: pthdrpage:rsgetptname
Posted in 2009
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi all,
IDS 11.10.FC3 on Solaris 10
I'm getting the following error in my message.log file:
09:21:36 pthdrpage:rsgetptname:bad partn page
09:21:40 Assert Failed: pthdrpage:rsgetptname:bad partn page
09:21:40 IBM Informix Dynamic Server Version 11.10.FC3
09:21:40 Who: Session(13, root@testdb05, 0, 17c034eb8)
Thread(55, btscanner_0, 17bfff358, 8)
File: rspartn.c Line: 7102
09:21:40 Results: Cannot use TBLSpace page for TBLSpace 1048854
09:21:40 Action: Run 'oncheck -pt 1048854'
'oncheck -pt 1048854' does not solve the issue.
I then tried other oncheck options & got the following:
Validating extents for Space 'rootdbs' ...
Chunk Pathname Pagesize(k) Size(p) Used(p) Free(p)
1 /db1/informix/dbs/rootdbs 2 500000 12361 487639
ERROR: Missing pages 1305 through 1309 inclusive
ERROR: Missing pages 1773 through 1777 inclusive
..
..
ERROR:
Extent Description Start Length
------------------ ----- ------
FREE 8513 16740
overlaps ...
sysadmin:'informix'.ix_ph_alert_02 19665 4
ERROR: Missing pages 19677 through 24757 inclusive
ERROR: Missing pages 24765 through 25221 inclusive
..
..
Few more line here with similar error on ix_ph_alert_01
Could any one suggest me if this could be resolved with oncheck or better i
move on with level 0 restore?
There is chance that the reboot might fail and I will be left with no choice
but to restore.
Atleast I would like to know if this error is Only due to bad index/data pages
in "sysadmin" database?
Twice i have experienced an issue with sysadmin database only, any i am not
even using it yet.
There is a document which shows how to rebuild sysadmin database online but
when the instance is online it does not allow to drop/rebuild this db and when
the instance is taken down because of error/corruption in sysadmin then it
does not come online in order to automatically build the sysadmin db.
Any help is appreciated
Regards
Vikas
Restore!
art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Wed, Aug 12, 2009 at 4:23 AM, VIKAS HIVARKAR
<vikas.hivarkar@gmail.com>wrote:
> Hi all,
>
> IDS 11.10.FC3 on Solaris 10
>
> I'm getting the following error in my message.log file:
>
> 09:21:36 pthdrpage:rsgetptname:bad partn page
> 09:21:40 Assert Failed: pthdrpage:rsgetptname:bad partn page
> 09:21:40 IBM Informix Dynamic Server Version 11.10.FC3
> 09:21:40 Who: Session(13, root@testdb05, 0, 17c034eb8)
>
> Thread(55, btscanner_0, 17bfff358, 8)
>
> File: rspartn.c Line: 7102
> 09:21:40 Results: Cannot use TBLSpace page for TBLSpace 1048854
> 09:21:40 Action: Run 'oncheck -pt 1048854'
>
> 'oncheck -pt 1048854' does not solve the issue.
>
> I then tried other oncheck options & got the following:
>
> Validating extents for Space 'rootdbs' ...
>
> Chunk Pathname Pagesize(k) Size(p) Used(p) Free(p)
>
> 1 /db1/informix/dbs/rootdbs 2 500000 12361 487639
> ERROR: Missing pages 1305 through 1309 inclusive
> ERROR: Missing pages 1773 through 1777 inclusive
> ...
> ...
>
> ERROR:
> Extent Description Start Length
> ------------------ ----- ------
> FREE 8513 16740
>
> overlaps ...
> sysadmin:'informix'.ix_ph_alert_02 19665 4
> ERROR: Missing pages 19677 through 24757 inclusive
> ERROR: Missing pages 24765 through 25221 inclusive
> ...
> ...
> Few more line here with similar error on ix_ph_alert_01
>
> Could any one suggest me if this could be resolved with oncheck or better i
> move on with level 0 restore?
>
> There is chance that the reboot might fail and I will be left with no
> choice
> but to restore.
>
> Atleast I would like to know if this error is Only due to bad index/data
> pages
> in "sysadmin" database?
>
> Twice i have experienced an issue with sysadmin database only, any i am not
> even using it yet.
>
> There is a document which shows how to rebuild sysadmin database online but
> when the instance is online it does not allow to drop/rebuild this db and
> when
> the instance is taken down because of error/corruption in sysadmin then it
> does not come online in order to automatically build the sysadmin db.
>
> Any help is appreciated
>
> Regards
> Vikas
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--00151747b4e0b8ba62047106411c
Hello Mr Kagel!
I did restored but the last level 0 had the same bad page/corruption.
The online.log was flooded with erros like:
11:29:25 SCHAPI: Started dbScheduler thread.
11:29:25 SCHAPI: Started 2 dbWorker threads.
11:29:25 SCHAPI: Error -243 Could not position within a table
(informix.ph_run).
11:29:25 SCHAPI: Type: SENSOR, Name: mon_checkpoint, Location: NULL.
11:29:25 SCHAPI: Error -135 ISAM error: TBLspace does not exist
11:29:25 SCHAPI: Type: SENSOR, Name: mon_checkpoint, Location: NULL.
11:29:25 SCHAPI: Error -243 Could not position within a table
(informix.ph_run).
11:29:25 SCHAPI: Type: SENSOR, Name: mon_table_names, Location: NULL.
11:29:25 SCHAPI: Error -135 ISAM error: TBLspace does not exist
11:29:25 SCHAPI: Type: SENSOR, Name: mon_table_names, Location: NULL.
I tried to stop the schedular, rebuild the sysadmin and also move the sysadmin
in another dbspace but with no luck. ever time i got error of missing
tablespace.
Then I had to restore the second latest backup which seems to be good enough
and the instance is working fine for last 1 day.
I don't know what was the cause of bad page, I don't use the sysadmin on this
instance but yes the schedular is on by default.
Is there is a way to rebuild the sysadmin database?
Thanks for your reply
Regards
Vikas
*******************************************************************************
Restore!
art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Wed, Aug 12, 2009 at 4:23 AM, VIKAS HIVARKAR
<vikas.hivarkar@gmail.com>wrote:
> Hi all,
>
> IDS 11.10.FC3 on Solaris 10
>
> I'm getting the following error in my message.log file:
>
> 09:21:36 pthdrpage:rsgetptname:bad partn page
> 09:21:40 Assert Failed: pthdrpage:rsgetptname:bad partn page
> 09:21:40 IBM Informix Dynamic Server Version 11.10.FC3
> 09:21:40 Who: Session(13, root@testdb05, 0, 17c034eb8)
>
> Thread(55, btscanner_0, 17bfff358, 8)
>
> File: rspartn.c Line: 7102
> 09:21:40 Results: Cannot use TBLSpace page for TBLSpace 1048854
> 09:21:40 Action: Run 'oncheck -pt 1048854'
>
> 'oncheck -pt 1048854' does not solve the issue.
>
> I then tried other oncheck options & got the following:
>
> Validating extents for Space 'rootdbs' ...
>
> Chunk Pathname Pagesize(k) Size(p) Used(p) Free(p)
>
> 1 /db1/informix/dbs/rootdbs 2 500000 12361 487639
> ERROR: Missing pages 1305 through 1309 inclusive
> ERROR: Missing pages 1773 through 1777 inclusive
> ...
> ...
>
> ERROR:
> Extent Description Start Length
> ------------------ ----- ------
> FREE 8513 16740
>
> overlaps ...
> sysadmin:'informix'.ix_ph_alert_02 19665 4
> ERROR: Missing pages 19677 through 24757 inclusive
> ERROR: Missing pages 24765 through 25221 inclusive
> ...
> ...
> Few more line here with similar error on ix_ph_alert_01
>
> Could any one suggest me if this could be resolved with oncheck or better i
> move on with level 0 restore?
>
> There is chance that the reboot might fail and I will be left with no
> choice
> but to restore.
>
> Atleast I would like to know if this error is Only due to bad index/data
> pages
> in "sysadmin" database?
>
> Twice i have experienced an issue with sysadmin database only, any i am not
> even using it yet.
>
> There is a document which shows how to rebuild sysadmin database online but
> when the instance is online it does not allow to drop/rebuild this db and
> when
> the instance is taken down because of error/corruption in sysadmin then it
> does not come online in order to automatically build the sysadmin db.
>
> Any help is appreciated
>
> Regards
> Vikas
>
>
>
>
*******************************************************************************
Sanjit Chakraborty posted the following in March:
There may be a situation occurs when you need to rebuild sysadmindatabase
without restart the IDS. For example,previously IDS started with
'$INFORMIX/etc/sysadmin/stop'file present (or windows equivalent) and no
sysadmin database exists in the instance.
Here is an example of rebuild sysadmin database manually:
1. cd$INFORMIXDIR/etc/sysadmin
2. dbaccess -db_create.sql
3. dbaccess sysadmindb_install.sql
4. dbaccess sysadminsch_tasks.sql
5. dbaccess sysadminsch_aus.sql
6. dbaccess sysadminsch_sqlcap.sql
7. dbaccess sysadminstart.sql
If you encountered any problem during above mentioned process, restartingIDS
automatically rebuild sysadmin database.Considering
'$INFORMIX/etc/sysadmin/stop' file is not exists.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Fri, Aug 14, 2009 at 4:07 AM, VIKAS HIVARKAR
<vikas.hivarkar@gmail.com>wrote:
> Hello Mr Kagel!
>
> I did restored but the last level 0 had the same bad page/corruption.
>
> The online.log was flooded with erros like:
> 11:29:25 SCHAPI: Started dbScheduler thread.
> 11:29:25 SCHAPI: Started 2 dbWorker threads.
> 11:29:25 SCHAPI: Error -243 Could not position within a table
> (informix.ph_run).
> 11:29:25 SCHAPI: Type: SENSOR, Name: mon_checkpoint, Location: NULL.
> 11:29:25 SCHAPI: Error -135 ISAM error: TBLspace does not exist
> 11:29:25 SCHAPI: Type: SENSOR, Name: mon_checkpoint, Location: NULL.
> 11:29:25 SCHAPI: Error -243 Could not position within a table
> (informix.ph_run).
> 11:29:25 SCHAPI: Type: SENSOR, Name: mon_table_names, Location: NULL.
> 11:29:25 SCHAPI: Error -135 ISAM error: TBLspace does not exist
> 11:29:25 SCHAPI: Type: SENSOR, Name: mon_table_names, Location: NULL.
>
> I tried to stop the schedular, rebuild the sysadmin and also move the
> sysadmin
> in another dbspace but with no luck. ever time i got error of missing
> tablespace.
>
> Then I had to restore the second latest backup which seems to be good
> enough
> and the instance is working fine for last 1 day.
>
> I don't know what was the cause of bad page, I don't use the sysadmin on
> this
> instance but yes the schedular is on by default.
>
> Is there is a way to rebuild the sysadmin database?
>
> Thanks for your reply
>
> Regards
> Vikas
>
>
>
>
*******************************************************************************
> Restore!
>
> art
>
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> Disclaimer: Please keep in mind that my own opinions are my own opinions
> and
> do not reflect on my employer, Oninit, the IIUG, nor any other organization
> with which I am associated either explicitly or implicitly. Neither do
> those opinions reflect those of other individuals affiliated with any
> entity
> with which I am affiliated nor those of the entities themselves.
>
> On Wed, Aug 12, 2009 at 4:23 AM, VIKAS HIVARKAR
> <vikas.hivarkar@gmail.com>wrote:
>
> > Hi all,
> >
> > IDS 11.10.FC3 on Solaris 10
> >
> > I'm getting the following error in my message.log file:
> >
> > 09:21:36 pthdrpage:rsgetptname:bad partn page
> > 09:21:40 Assert Failed: pthdrpage:rsgetptname:bad partn page
> > 09:21:40 IBM Informix Dynamic Server Version 11.10.FC3
> > 09:21:40 Who: Session(13, root@testdb05, 0, 17c034eb8)
> >
> > Thread(55, btscanner_0, 17bfff358, 8)
> >
> > File: rspartn.c Line: 7102
> > 09:21:40 Results: Cannot use TBLSpace page for TBLSpace 1048854
> > 09:21:40 Action: Run 'oncheck -pt 1048854'
> >
> > 'oncheck -pt 1048854' does not solve the issue.
> >
> > I then tried other oncheck options & got the following:
> >
> > Validating extents for Space 'rootdbs' ...
> >
> > Chunk Pathname Pagesize(k) Size(p) Used(p) Free(p)
> >
> > 1 /db1/informix/dbs/rootdbs 2 500000 12361 487639
> > ERROR: Missing pages 1305 through 1309 inclusive
> > ERROR: Missing pages 1773 through 1777 inclusive
> > ...
> > ...
> >
> > ERROR:
> > Extent Description Start Length
> > ------------------ ----- ------
> > FREE 8513 16740
> >
> > overlaps ...
> > sysadmin:'informix'.ix_ph_alert_02 19665 4
> > ERROR: Missing pages 19677 through 24757 inclusive
> > ERROR: Missing pages 24765 through 25221 inclusive
> > ...
> > ...
> > Few more line here with similar error on ix_ph_alert_01
> >
> > Could any one suggest me if this could be resolved with oncheck or better
> i
> > move on with level 0 restore?
> >
> > There is chance that the reboot might fail and I will be left with no
> > choice
> > but to restore.
> >
> > Atleast I would like to know if this error is Only due to bad index/data
> > pages
> > in "sysadmin" database?
> >
> > Twice i have experienced an issue with sysadmin database only, any i am
> not
> > even using it yet.
> >
> > There is a document which shows how to rebuild sysadmin database online
> but
> > when the instance is online it does not allow to drop/rebuild this db and
> > when
> > the instance is taken down because of error/corruption in sysadmin then
> it
> > does not come online in order to automatically build the sysadmin db.
> >
> > Any help is appreciated
> >
> > Regards
> > Vikas
> >
> >
> >
> >
>
>
*******************************************************************************
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5b68008101404711b2998