Corruption in old and unsupported v7 database ...
Posted in 2004
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion, Platform-Specific Issues
My customer is on 7.2x on HP-UX 10.20.
Informix support patched one of his chinks better a couple of months ago.
Now (and probably then) he is getting page errors:
Noticed assert failure af.5008e6dc which advised oncheck -cDI 8394250
Dropped index tfgld1061001abaan
Ran create unique index "baan".tfgld1061001abaanon "baan".ttfgld106100
(hash1)
Process halted with 25580:System erroroccurred in network function, invalid
arguement
Ran oncheck cDI 8394250 - It reported bad page, pg-stamp 155ccd15 !=
PG_STAMP2 0
Ran onckeck -cD 8394250 - It reported bad page 33a155f: pg_stamp 358403349
!= PG_STAMP2 0
He's keen to try and do an ASCII unload, but I think it will fail with the
same thing. I'd like to get a copy of his database to work on, but we have
no HP-UX 10.20 servers. He doesn't have enough disk space to
onunlaod/onload the file to that server.
Any other ideas for helping him out? IBM tech Support won;t touch it - the
version is too old.
thanks
Neil
Neil Truby wrote:
[ ... problem description snipped ... ]
> no HP-UX 10.20 servers. He doesn't have enough disk space to
> onunlaod/onload the file to that server.
>
> Any other ideas for helping him out? IBM tech Support won;t touch it - the
> version is too old.
>
sorry, I can only offer one idea for the disk storage &
for the unload.
If you have a laptop with sufficient disk, or anytype
of PeeCee with enuff disk, then put a Linux distro
onto it, start the nfsd and export the disks
On HPUX it was possible to run a nfs client when I last
saw this OS (somewhen in 1994)
nfs_mount the laptop or PeeCee disk and you have some
disk space for an unload like so:
---- untested ------
mkfifo mypipe; ## only once, out side any loop
gzip -fc <mypipe >$TABLE_file_on_nfsmount.gz &
UNLOAD TO "MYPIPE"
SELECT ......FROM $TABLE ;--------------------
If you create a file of the table names to unload
& if you put a shell-forloop around, set TABLE
iterator variable you have 'poor man's unload'
Here is an example you can run using bash
for TABLE in $( cat file_containing_tablenames ); do
unload_script.sh $TABLE
done
I have no idea, how to solve the other problem, sorry
dic_k
--
Richard Kofler
SOLID STATE EDV
Dienstleistungen GmbH
Vienna/Austria/Europe