Re: unix odbc and informix datasource problem
Posted in 2006
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Connectivity: ESQL/C, 4GL & Embedded SQL, Internationalization & Character Sets
OK. I have installed sdk 32 bit and have set up my INFORMIXDIR to point
to where it is installed /usr/informix32/....
This is the contents of my odnbinst.ini file
[Informix]
Description=Informix IDS 2000
Driver=/usr/informix32/lib/cli/iclis09b.so
APILevel=1
ConnectFunctions=YYY
DriverODBCVer=03.00
FileUsage=0
SQLLevel=1
smProcessPerConnect=Y
and this of my odbc.ini file
[pic2]
Driver=Informix
Server=kylie
Database=pic2
CLIENT_LOCALE=en_us.8859-1
DB_LOCALE=en_us.8859-1TRANSLATIONDLL=/usr/informix32/lib/esql/igo4a304.so
And now I get only
[root@kylie bin]# ./isql pic2
[ISQL]ERROR: Could not SQLConnect
No other error.
I followed the instructions in
http://www.unixodbc.org/doc/informix.html
So I'm not sure where I'm going wrong ....
Any help appreciated
What version of unix ODBC DM are you using? Is it >= 2.2.11? As enough
error message is not provided...Are you getting something of "ERROR
-11048: UNABLE TO LOAD TRANSLATION SHARED LIBRARY (DLL)" ..If so there ishigh possibility that you are hitting Informix ODBC defect 175992. Ask
your Tech Support for the patch.
There is workaround exist, while linking(your application) if you use
libifgls.so library (i.e -lifgls) then you will not see this issue.
Thanks & Regards
-Shesh
"kjuliff@gmail.com" <kjuliff@gmail.com>
Sent by: informix-list-bounces@iiug.org
07/19/2006 02:51 AM
To
informix-list@iiug.org
cc
Subject
Re: unix odbc and informix datasource problem
OK. I have installed sdk 32 bit and have set up my INFORMIXDIR to point
to where it is installed /usr/informix32/....
This is the contents of my odnbinst.ini file
[Informix]
Description=Informix IDS 2000
Driver=/usr/informix32/lib/cli/iclis09b.so
APILevel=1
ConnectFunctions=YYY
DriverODBCVer=03.00
FileUsage=0
SQLLevel=1
smProcessPerConnect=Y
and this of my odbc.ini file
[pic2]
Driver=Informix
Server=kylie
Database=pic2
CLIENT_LOCALE=en_us.8859-1
DB_LOCALE=en_us.8859-1TRANSLATIONDLL=/usr/informix32/lib/esql/igo4a304.so
And now I get only
[root@kylie bin]# ./isql pic2
[ISQL]ERROR: Could not SQLConnect
No other error.
I followed the instructions in
http://www.unixodbc.org/doc/informix.html
So I'm not sure where I'm going wrong ....
Any help appreciated
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
> What version of unix ODBC DM are you using? Is it >= 2.2.11?
Yes it is
As enough
> error message is not provided...Are you getting something of "ERROR
> -11048: UNABLE TO LOAD TRANSLATION SHARED LIBRARY (DLL)" ..
No, there IS no error message. Just what I posted.
Kate
If so there is
> high possibility that you are hitting Informix ODBC defect 175992. Ask
> your Tech Support for the patch.
>
> There is workaround exist, while linking(your application) if you use
> libifgls.so library (i.e -lifgls) then you will not see this issue.
>
> Thanks & Regards
> -Shesh
>
>
>
>
> "kjuliff@gmail.com" <kjuliff@gmail.com>
> Sent by: informix-list-bounces@iiug.org
> 07/19/2006 02:51 AM
>
> To
> informix-list@iiug.org
> cc
>
> Subject
> Re: unix odbc and informix datasource problem
>
>
>
>
>
>
> OK. I have installed sdk 32 bit and have set up my INFORMIXDIR to point
> to where it is installed /usr/informix32/....
>
> This is the contents of my odnbinst.ini file
>
> [Informix]
> Description=Informix IDS 2000
> Driver=/usr/informix32/lib/cli/iclis09b.so
> APILevel=1
> ConnectFunctions=YYY
> DriverODBCVer=03.00
> FileUsage=0
> SQLLevel=1
> smProcessPerConnect=Y
>
>
> and this of my odbc.ini file
> [pic2]
> Driver=Informix
> Server=kylie
> Database=pic2
> CLIENT_LOCALE=en_us.8859-1
> DB_LOCALE=en_us.8859-1> TRANSLATIONDLL=/usr/informix32/lib/esql/igo4a304.so
>
>
> And now I get only
> [root@kylie bin]# ./isql pic2
> [ISQL]ERROR: Could not SQLConnect
>
>
> No other error.
>
> I followed the instructions in
> http://www.unixodbc.org/doc/informix.html
>
> So I'm not sure where I'm going wrong ....
>
> Any help appreciated
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
>
> --=_alternative 00382AFA652571B0_=
> Content-Type: text/html
> X-Google-AttachSize: 2630
>
>
> <br><font size=2 face="sans-serif">What version of unix ODBC DM are you
> using? Is it >= 2.2.11? As enough error message is not provided...Are
> you getting something of "ERROR -11048: UNABLE TO LOAD TRANSLATION
> SHARED LIBRARY (DLL)" ..If so there is high possibility that you are
> hitting Informix ODBC defect 175992. Ask your Tech Support for the patch.</font>
> <br>
> <br><font size=2 face="sans-serif">There is workaround exist, while linking(your
> application) if you use libifgls.so library (i.e -lifgls) then you will
> not see this issue.</font>
> <br>
> <br><font size=2 face="sans-serif">Thanks & Regards<br>
> -Shesh</font>
> <br>
> <br>
> <br>
> <br>
> <table width=100%>
> <tr valign=top>
> <td width=40%><font size=1 face="sans-serif"><b>"kjuliff@gmail.com"
> <kjuliff@gmail.com></b> </font>
> <br><font size=1 face="sans-serif">Sent by: informix-list-bounces@iiug.org</font>
> <p><font size=1 face="sans-serif">07/19/2006 02:51 AM</font>
> <td width=59%>
> <table width=100%>
> <tr valign=top>
> <td>
> <div align=right><font size=1 face="sans-serif">To</font></div>
> <td><font size=1 face="sans-serif">informix-list@iiug.org</font>
> <tr valign=top>
> <td>
> <div align=right><font size=1 face="sans-serif">cc</font></div>
> <td>
> <tr valign=top>
> <td>
> <div align=right><font size=1 face="sans-serif">Subject</font></div>
> <td><font size=1 face="sans-serif">Re: unix odbc and informix datasource
> problem</font></table>
> <br>
> <table>
> <tr valign=top>
> <td>
> <td></table>
> <br></table>
> <br>
> <br>
> <br><tt><font size=2>OK. I have installed sdk 32 bit and have set up my
> INFORMIXDIR to point<br>
> to where it is installed /usr/informix32/....<br>
> <br>
> This is the contents of my odnbinst.ini file<br>
> <br>
> [Informix]<br>
> Description=Informix IDS 2000<br>
> Driver=/usr/informix32/lib/cli/iclis09b.so<br>
> APILevel=1<br>
> ConnectFunctions=YYY<br>
> DriverODBCVer=03.00<br>
> FileUsage=0<br>
> SQLLevel=1<br>
> smProcessPerConnect=Y<br>
> <br>
> <br>
> and this of my odbc.ini file<br>
> [pic2]<br>
> Driver=Informix<br>
> Server=kylie<br>
> Database=pic2<br>
> CLIENT_LOCALE=en_us.8859-1<br>
> DB_LOCALE=en_us.8859-1<br>> TRANSLATIONDLL=/usr/informix32/lib/esql/igo4a304.so<br>
> <br>
> <br>
> And now I get only<br>
> [root@kylie bin]# ./isql pic2<br>
> [ISQL]ERROR: Could not SQLConnect<br>
> <br>
> <br>
> No other error.<br>
> <br>
> I followed the instructions in<br>
> http://www.unixodbc.org/doc/informix.html<br>
> <br>
> So I'm not sure where I'm going wrong ....<br>
> <br>
> Any help appreciated<br>
> <br>
> _______________________________________________<br>
> Informix-list mailing list<br>
> Informix-list@iiug.org<br>
> http://www.iiug.org/mailman/listinfo/informix-list<br>
> </font></tt>
> <br>
> --=_alternative 00382AFA652571B0_=--