configuration problem
Posted in 2007
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
i Successfully install informix dynamic server 10 on aix 5.3
without demo
After that i set envirnomental variables
export INFORMIXDIR=/informix
export PATH=$INFORMIXDIR/bin:$PATH
export INFORMIXSERVER=demo_on
export ONCONFIG=/informix/etc/onconfig
export INFORMIXSQLHOSTS=/informix/etc/sqlhostsexport LIBPATH=$INFORMIXDIR/lib:$LIBPATH
After setting envinoment variables i made some changes in onconfig file
i-e
ROOTPATH=/informix/dbspaces/online_root
MSGPATH =/informix/logs/online.log
LTAPEDEV=/dev/null
DBSERVERNAME=demo_on
After doning these tasks i run oninit it error messages i-e
exec(): 0509-036 Connot load program oninit because of the following errors:
0509-130 Symbol resolution failed for /usr/lib/libc_r.a(aio.o)because
symbol kaio_rdwr (number 0) in not exported for dependent module /unix
aymbol listio(number 1)
symbol acencel(number 2)
symbol iosuspend(number3)
symbol aio_nwait(number 4)
aio_nwait64(number 5)
aio_nwait64_timeout(number 6)
aio_nwait_timeout(number 7)
examine .loader section symbols with the 'dump -Tv'command
plz replay me how to solve this problem
Hi,
see the Machine Specific Notes in $INFORMIXDIR/release/en_us/0333/...
It has (among other things) the following info for you:
------------------------------------------------------------------
...
3. The IBM Informix Dynamic Server requires that the drivers for
- Portable Streams Environment (PSE)
- Asynchronous IO (AIO)
be loaded on the AIX system where the IBM Informix Dynamic Server is
used. The IBM Informix Dynamic Server executables use entry points
defined by these drivers.
The PSE driver can be loaded using the "/usr/sbin/strload" command.
The
AIO device can be enabled using either the AIX "smit" interface or by
doing the following.
To enable AIO after subsequent reboots, issue the following commands
as root:
/usr/sbin/chdev -l aio0 -a autoconfig=available
/usr/sbin/mkdev -l aio0
For further information, refer to the AIX documentation.
...
6. Kernel Asynchronous I/O (KAIO)
KAIO is enabled by default on this platform. The AIO driver must be
configured into the AIX system for KAIO to work. Instructions are
provided in the "System Requirements" section above. If AIO is not
configured, the IBM Informix Dynamic Server will report the following
error while coming up:
0509-037 System error: error data is: oninit
0509-023 Symbol kaio_rdwr in /usr/lib/libc.a is not defined.
0509-023 Symbol listio in /usr/lib/libc.a is not defined.
0509-023 Symbol acancel in /usr/lib/libc.a is not defined.
0509-023 Symbol iosuspend in /usr/lib/libc.a is not defined.
0509-022 Cannot load library libc.a[aio.o].
0509-026 System error: Cannot run a file that does not have a
valid
format
To disable KAIO, set the environment variable KAIOOFF.
KAIOOFF=1 ; export KAIOOFF ( for Bourne or Korn shell )
setenv KAIOOFF 1 ( for C shell )
...
------------------------------------------------------------------
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
IBM Deutschland GmbH
Chairman of the Supervisory Board: Hans Ulrich Märki
Board of Management: Martin Jetter (Chairman), Rudolf Bauer, Christian
Diedrich, Christoph Grandpierre, Matthias Hartmann, Andreas Kerstan
Corporate Seat: Stuttgart, Germany; Reg.-Gericht: Amtsgericht Stuttgart,
HRB-Nr.: 14 562 WEEE-Reg.-Nr. DE 99369940
ids-bounces@iiug.org wrote on 25.04.2007 10:07:31:
> i Successfully install informix dynamic server 10 on aix 5.3
> without demo
>
> After that i set envirnomental variables
>
> export INFORMIXDIR=/informix
> export PATH=$INFORMIXDIR/bin:$PATH
> export INFORMIXSERVER=demo_on
> export ONCONFIG=/informix/etc/onconfig
> export INFORMIXSQLHOSTS=/informix/etc/sqlhosts> export LIBPATH=$INFORMIXDIR/lib:$LIBPATH
>
> After setting envinoment variables i made some changes in onconfig file
> i-e
> ROOTPATH=/informix/dbspaces/online_root
> MSGPATH =/informix/logs/online.log
> LTAPEDEV=/dev/null
> DBSERVERNAME=demo_on
> After doning these tasks i run oninit it error messages i-e
>
> exec(): 0509-036 Connot load program oninit because of the following
errors:
>
> 0509-130 Symbol resolution failed for /usr/lib/libc_r.a(aio.o)because
>
> symbol kaio_rdwr (number 0) in not exported for dependent module /unix
>
> aymbol listio(number 1)
>
> symbol acencel(number 2)
>
> symbol iosuspend(number3)
>
> symbol aio_nwait(number 4)
>
> aio_nwait64(number 5)
>
> aio_nwait64_timeout(number 6)
>
> aio_nwait_timeout(number 7)
> examine .loader section symbols with the 'dump -Tv'command
>
> plz replay me how to solve this problem
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
Thanks dear Plz do guide me what t do to resolve this one "ONCONFIG can only specify a simple filename with no path components"
WAQAS ARSHAD said: > Thanks dear > Plz do guide me what t do to resolve this one > > "ONCONFIG can only specify a simple filename with no path components" Have you tried specifying only a file name with no path components? -- Bye now, Obnoxio "I'm astonished anyone pays real money for this crap." -- Cosmo -- This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean.
Meaning: The server requires onconfig to be located in $INFORMIXDIR/etc, you should give only the name of the file as a value. Marcus -----Original Message----- From: Obnoxio The Clown [mailto:obnoxio@serendipita.com] Sent: Wednesday, April 25, 2007 12:24 PM To: ids@iiug.org Subject: Re: configuration problem [9013] WAQAS ARSHAD said: > Thanks dear > Plz do guide me what t do to resolve this one > > "ONCONFIG can only specify a simple filename with no path components" Have you tried specifying only a file name with no path components? -- Bye now, Obnoxio "I'm astonished anyone pays real money for this crap." -- Cosmo -- This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean. ************************************************************************ ******* Forum Note: Use "Reply" to post a response in the discussion forum.