Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
Reardon, Andrew J — — source: Informix-list mailing list archive (1991-1998)
Hi all
Just had a look at my "onstat -p" and it was showing a terribly large number
of seqscans (~100K), so I went in and had a look at the offending table.
Turns out the table with the most seqscans against it has only got *one row*
in it. There were some other tables having seqscans done on them, ranging in
size from about 10 to 10K rows.
My setup is: IDS 7.24.UC6 on Solaris 2.6 on a Sun E450 (3 CPU) with 1GB RAM.
The database is on cooked UFS disks. I run update stats high nightly
(probably overkill but hey I've got some spare CPU cycles so why not:)
My questions are:
1. Is it just a recording error that a one row table can contribute to the
seqscans count ? Would I be correct in discounting any seqscans on a one row
table when I'm looking at things like sysptprof in SMI ?
2. How many rows should a table be before sequential scans on that table
hurt performance ? eg if a 100 row table was being seqscanned, would you be
inclined to put an index on that table as a matter of course ?
Thanks!
Andrew Reardon
Boeing Australia
Tel: +61 7 3306 3346
Mobile: 0419 745 831
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.