RE: Problem adding a foreign key
Posted in 2004
most likely the proj_request table has a foreign key to the contract table.
You must learn to drink the cup of life as it comes...without stirring it up from the bottom. That's where the bitter dregs are. Agnes Sligh Turnbull (1888-1982) Writer
-----Original Message-----
From: Malc P [mailto:malc_p@btinternet.com]
Sent: Monday, November 22, 2004 7:44 AM
To: informix-list@iiug.org
Subject: Problem adding a foreign key
IDS 9.30HC5; HP-UX 11i
Not a problem, really, (I can kick the users off) but I can't
understand why issuing this:
set isolation to dirty read;alter table "dba".proj_request add constraint (foreign key
(cntrctid_ref)
references "dba".contract constraint "dba".proj_request_fk_02);
... produces this:
242: Could not open database table (dba.contract).
106: ISAM error: non-exclusive access.
I'm not DOING anything to the 'contract' table; and finderr for 106
says:
"The ISAM processor has been asked to add or drop an index but it does
not have exclusive access. ... For SQL products, the database server
returns this error when an exclusive lock is required on a table. For
example, this error appears when a second user tries to alter a table
that the first user has locked."
But AFAICS, the only table I'm altering is 'proj_request'.
Confused of Tunbridge Wells.
(Also posting to the ids list)
sending to informix-list