Re: Urgent: IRIX ESQL/C <--> Linux SE
Posted in 1998
Marco Mechelli pleaded: %Kurt Wall wrote: %> Marco Mechelli pleaded: %> %My setup is as follows: an IRIX 6.3 box running Netscape Enterprise Server %> %3.5.1 connects via LiveWire (using ESQL/C shared libraries) to a Slackware %> %Linux SE Server. %> %Everything worked until we had to power off both the machines. After this, %> %infact, everytime LiveWire tries to connect to SE it fails with the %> %following error: %> %-957: Cannot create/access database on NFS mount %> %> Can you access the database from your IRIX box directly, that is, without %> going through LiveWire? If so, it sounds like a LiveWire config problem. %> If you can't get to the Slackware box from IRIX, though (try telnetting %> to the Informix port, for example), then your network is hosed somehow. % %I tried to run esqldemo7, but it fails with the following error: % %Creating stores7 database ... % %/usr/informix/bin/esqldemo7: test: integer expression expected before -eq Seems to be a problem with the esqldemo7 script. I looked at it, and it doesn't specify which shell to use at the top. You might have a go at adding #/bin/ksh at the top. You using (t)csh on either of these boxes? %following create database sqlcode -956, isam code 2. % %Database setup incomplete. % %which seems to be a different error! "finderr -956" explains this. The problem would seem to be that your Slackware box doesn't recognize your IRIX box. The real pros here can correct me (and will, no doubt), but I should think you'd need to add the same port in your services file on the IRIX box as on the Slackware box. In any event, it sounds like a network configuration problem. As to the -957 error, you're supposed to complain to Informix's tech support, but I'm guessing that they'll tell you you're not supposed create or try to access an NFS-mounted database. Kurt