Re: Update failed question
Posted in 1995
On 4 Apr 1995, Colonel Panic wrote: ----- stuff deleted ---- > >>$BEGIN > >>for (i=0; i<600; i++) { > >> $UPDATE .... > >>} > >>$COMMIT > >> > >With this one, every update causes a lock and you are running out of locks. > >So it bombs. Either, increase your locks or, before that $BEGIN, do a > >$LOCK TABLE FOO IN EXCLUSIVE MODE. Just as a point of interest, using SE 5.x, I discovered that using exclusive mode caused some of our long update/insert transactions to halt before completion. Changing to share mode solved the problem. I don't know exactly why, but my guess is share seems to be locking and releasing locks on a record by record basis. Yours, ********************************* Nick Nobbe, Library of Congress NLS/BPH mail: nnob@loc.gov *********************************