CDR define server problem
Posted in 2004
Topics: High Availability & Replication
I try define primary-target replication.
steps:
cdr define serv --init g_whrhouse
ok
cdr define serv --connect fno6004 --sync=g_whrhouse --init g_fno6004
error: command failed -- unable to connect to server specified (5)
online.log on target server write:
22:56:31 Building 'syscdr' database ...
22:56:31 'syscdr' database built successfully.
22:56:31 CDR queuer initialization complete
22:56:31 CDR NIF listening on asf://g_fno6004
22:56:35 CDR NIF site: 0 <g_whrhouse> clocks differ by 82 seconds
22:56:35 CDR GC: operation sync server check (not source) failed
(error 0).
22:56:35 CDR connection to server lost, id 21, name <g_whrhouse>Reason: Handshake detected duplicate id
22:56:35 CDR GC: operation sync connect failed (error 5).
22:56:35 CDR GC: synchronization failed (sync abort, shutting down
CDR)
22:56:35 CDR NIF Shutdown: connections all shutdown.
22:56:35 CDR The NIF sub-component has shut down.
22:56:35 CDR shutdown complete
22:56:35 CDR GC: operation select deltabid,dbname from
syscdr:deltabdef_tab failed (error -349).
22:56:35 CDR GC: operation catalog purge (drop) failed (error -329).
You need to check on g_whrhouse to see what errors you may have encountered.
"Vadim Yezhakov" <yezhakov@mail.ru> wrote in message
news:2d8b1865.0401060901.21fcdb41@posting.google.com...
> I try define primary-target replication.
> steps:
> cdr define serv --init g_whrhouse
> ok
> cdr define serv --connect fno6004 --sync=g_whrhouse --init g_fno6004
> error: command failed -- unable to connect to server specified (5)
>
> online.log on target server write:
> 22:56:31 Building 'syscdr' database ...
> 22:56:31 'syscdr' database built successfully.
> 22:56:31 CDR queuer initialization complete
> 22:56:31 CDR NIF listening on asf://g_fno6004
> 22:56:35 CDR NIF site: 0 <g_whrhouse> clocks differ by 82 seconds
> 22:56:35 CDR GC: operation sync server check (not source) failed
> (error 0).
> 22:56:35 CDR connection to server lost, id 21, name <g_whrhouse>> Reason: Handshake detected duplicate id
> 22:56:35 CDR GC: operation sync connect failed (error 5).
> 22:56:35 CDR GC: synchronization failed (sync abort, shutting down
> CDR)
> 22:56:35 CDR NIF Shutdown: connections all shutdown.
> 22:56:35 CDR The NIF sub-component has shut down.
> 22:56:35 CDR shutdown complete
> 22:56:35 CDR GC: operation select deltabid,dbname from
> syscdr:deltabdef_tab failed (error -349).
> 22:56:35 CDR GC: operation catalog purge (drop) failed (error -329).
"Vadim Yezhakov" <yezhakov@mail.ru> '''''''/'''''''' ' '''''''' ''''''''':
news:2d8b1865.0401060901.21fcdb41@posting.google.com...
> I try define primary-target replication.
> steps:
> cdr define serv --init g_whrhouse
> ok
> cdr define serv --connect fno6004 --sync=g_whrhouse --init g_fno6004
I think '--connect ...' on target server is unnecessary.
> error: command failed -- unable to connect to server specified (5)
>
> online.log on target server write:
> 22:56:31 Building 'syscdr' database ...
> 22:56:31 'syscdr' database built successfully.
> 22:56:31 CDR queuer initialization complete
> 22:56:31 CDR NIF listening on asf://g_fno6004
> 22:56:35 CDR NIF site: 0 <g_whrhouse> clocks differ by 82 seconds
As I remember clocks on both servers must be strictly synchronized.
> 22:56:35 CDR GC: operation sync server check (not source) failed
> (error 0).
> 22:56:35 CDR connection to server lost, id 21, name <g_whrhouse>> Reason: Handshake detected duplicate id
Please show etc/sqlhosts on both servers.
> 22:56:35 CDR GC: operation sync connect failed (error 5).
> 22:56:35 CDR GC: synchronization failed (sync abort, shutting down
> CDR)
> 22:56:35 CDR NIF Shutdown: connections all shutdown.
> 22:56:35 CDR The NIF sub-component has shut down.
> 22:56:35 CDR shutdown complete
> 22:56:35 CDR GC: operation select deltabid,dbname from
> syscdr:deltabdef_tab failed (error -349).
> 22:56:35 CDR GC: operation catalog purge (drop) failed (error -329).