Table level restore archecker fails -1226
Posted in 2017
Topics: Backup & Restore, Server Administration
Dear all,
Have been trying for a while to restore 1 single table from ontape using
archecker.
However i am getting -1226 both when i restore in the table or when i restore
to external file. (http://www-01.ibm.com/support/docview.wss?uid=swg21655476#)
When I do the last I am getting value
-67676767676767680000000000000000000000000000000000000000000000. for
decimal(16,2) column.
Does it makes sense to define the external table with bigger precision/scale
so that the source data can fit?
Is there any setting in the archecker conf file or onconfig file on the
destination that I am not aware of?
Thank you
Aleksandar
My first piece of advice would be to double check that decimal(16= ,2)
is the original size. The source table the size must match exactl=
y. If the size is larger then it will try and read part of the
follow= ing column and convert that to a decimal.
If you a= re not sure of the exact size then you can extract the
tables systabl= es and syscolumns to new tables that you can query
and get the correct info= rmation.
John
= =0A
=0A
=0A-------- Origi= nal Message --------
=0ASubject: Table level restore archecker fails -12= 26 [39983]
=0AFrom: "ALEKSANDAR IVANOVSKI" <[1]aleksandar.ivanovski@gmail.com>
=0ADate= : Mon, September 25, 2017 12:45 am
=0ATo: [2]ids@iiug.org
=0A
=0ADear all,
=0A
=0AHave been trying fo= r a while to restore 1 single table from
ontape using
=0Aarchecker.
=0AHowever i am getting -1226 both when i restore in the table or when
i r= estore
=0Ato external file.
([3]http://www-01.ibm.com/support/docview.wss?uid= =3Dswg21655476#)
=0A
=0AWhen I do the last I am getting value
=0A-67676767676767680000000000000000000000000000000000000000000000.
for <= br>=0Adecimal(16,2) column.
=0A
=0ADoes it makes sense to define the= external table with bigger
precision/scale
=0Aso that the source data = can fit?
=0A
=0AIs there any setting in the archecker conf file or o= nconfig file
on the
=0Adestination that I am not aware of?
=0A
= =0AThank you
=0AAleksandar
=0A
=0A
=0A***********************=
********************************************************
=0A Forum Not= e: Use "Reply" to post a response in the discussion
forum.
=0A
=0A= =0A
=0A
References
1. 3D"mailto:aleksa=
2. 3D"mailto:ids@iiug.org=
3. 3D"http://www-01.ibm.com/support/d=
Solved. The problem was in wrong copy paste for the first time definition in the archecker file, after which the definition of the table (empty) on the IDS was not the same with the conf file itself. Now everything works perfect. Thank you, Aleksandar
Related threads
- problem with sum() aggregate on IDS 7.30
- realease of Informix
- Error 1226 when using sum()? Dynamic Server broken or what?!
- 4gl Error Anyhelp ?