RE: onbar scripts to TSM
Posted in 2005
You really don't need a script unless you're doing something out of the
ordinary, like special handling for monthlys. From my midnight
processing script:
export DSMI_CONFIG=${INFORMIXDIR}/prodifx.opt
onbar -b -L0
RC=$?
${INFORMIXDIR}/prodifx.opt would contain the name of your node in TSM:
SErvername PRODIFX
If you have other events dependent on a successful backup, check the
return code to ignore the failed log backup, something like:
if [ $RC -ne 0 ]; then
#don't fail on return code 152 "can't back up logical logs"
if [ $RC -eq 152 ]; then
message "onbar -b -L0 failed return code = $RC ,
continue midnight processing"
else
message "onbar -b -L0 failed return code = $RC ,
exiting"
echo "onbar -b -L0 failed return code = $RC , exiting" |
mailx -s "onbar failure" dareb@jevic.com
#FS backup, monthly or daily, do regardless of onbar
success or fail
if [ `date +%d` -ne 2 ]; then
sudo dsmc i
else
sudo dsmc i -virtualnode=proddb_m
-pass=**********
fi
quit 1
fi
fi
Regards,
Bill
> -----Original Message-----
> From: owner-informix-list@iiug.org [SMTP:owner-informix-list@iiug.org]
> On Behalf Of Darren_Jacobs@carmax.com
> Sent: Tuesday, December 20, 2005 10:23 AM
> To: informix-list@iiug.org
> Subject: onbar scripts to TSM
>
> Greetings,
>
> Does anyone have a script to perform nightly backups to TSM?
>
> IDS 9.40 FC2
> HPUX 11.11
>
> TIA
> sending to informix-list
sending to informix-list