Creating a temp dbspace failing on RedHat ES 4.0
Posted in 2005
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Versions, Editions & End-of-Life
Greetings,
RedHat Enterprise Server 4.0 (kernel 2.6, glibc 2.3.4-2.9)
IDS 9.40.UC4
This is a new machine, new install. Initialised the server and it seemed to
work fine - created rootdbs with sysmaster and sysutils databases. But when I
try to add a temp dbspace (in quiesent mode) it fails:
onspaces -c -d temp -t -p /data/inf9_temp.dbs -o 0 -s 20480
shared memory not initialized for INFORMIXSERVER 'inf9'
The 3rd party vendor who embeds informix only supports it on RH ES 3.0. Has
anyone managed to install 9.4 on ES 4.0? Any tips much appreciated.
Thanks.
Maeve
MAEVE DEVINE wrote:
>Greetings,
>
>RedHat Enterprise Server 4.0 (kernel 2.6, glibc 2.3.4-2.9)
>IDS 9.40.UC4
>
>This is a new machine, new install. Initialised the server and it seemed to
work fine - created rootdbs with sysmaster and sysutils databases. But when I
try to add a temp dbspace (in quiesent mode) it fails:
>
> onspaces -c -d temp -t -p /data/inf9_temp.dbs -o 0 -s 20480>
> shared memory not initialized for INFORMIXSERVER 'inf9'
>
>The 3rd party vendor who embeds informix only supports it on RH ES 3.0. Has
anyone managed to install 9.4 on ES 4.0? Any tips much appreciated.
>
>Thanks.
>
>Maeve
>
>Greetings,
>
>
I think that you must use raw devices /dev/raw/raw[1...]
vi /etc/sysconfig/rawdevices
mode 660
user and group informix
you must have all compatibility libraries
rpm -qa | grep compat
compat-openldap-2.1.30-2
compat-gcc-32-3.2.3-47.3
compat-libstdc++-296-2.96-132.7.2
compat-libstdc++-33-3.2.3-47.3
compat-gcc-32-c++-3.2.3-47.3
compat-db-4.1.25-9
compat-glibc-2.3.2-95.30
compat-glibc-headers-2.3.2-95.30
compat-libgcc-296-2.96-132.7.2
Please send your online.log
Dimitar Bachvarov
Thanks for all the replies, and huge thanks to Sandor Szabo who got this working. 1. Set an enviroment variable INFORMIXSHMBASE to -1 2. In the ONCONFIG, set SHMBASE to 0x44000000 After that it all works fine. Details from Sandor: RHEL 3 Update 3 added a new feature "Exec Shield Randomize" and turned it on by default. IBM Informix application with this release will unpredictably fail to connect to a local IBM Informix database instance because shmat() will fail to attach shared memory at the configured location. If you use SHM communication then I would recommend setting environment variable INFORMIXSHMBASE to -1; Because of the exec-shield-randomize feature.... for example : export INFORMIXSHMBASE=-1 This will use the SHMBASE of 0x40 000 000 which should be set in $ONCONFIG