RE: garbage after unsintall BTS 1.10
Posted in 2008
Hi César
I am the principle developer or Basic Text Search DataBlade and I just had a look at this issue and I hope I can offer some suggestions to help with this process.
Regarding bts objects left behind after bts.1.10 is unregistered.: I am concerned that you are seeing BTS object in the export file after you drop all the BTS indexes and unregister the bts.1.10. I have not been able to reproduce this in the lab. I have created a database, registered bts.1.10, created tables and bts indexes. Then dropped all the bts indexes and ran:
> blademgr
mark_on> set confirm off
mark_on> unregister bts.1.10 mydb
mark_on> exit
>
Then I ran: dbexport mydb.
I don’t see any objects from the bts datablade in the export files. The bts datablade defines a number of error messages, some functions, opclasses and the bts access method. It does not define any casts, datatypes or procedures (in bts.1.10). What objects are you seeing left behind and I will investigate further?
Regarding moving a database from a 11.50.xC2 server to a 11.50.xC3 server with dbexport/import, there are some issues! However, I don’t think you need to drop the indexes or unregister the datablade in database on the 11.50.xC2 server before you export the database.
I export the database: dbexport -ss mydb
Making sure the 11.50.xC3 server default sbspace defined in with the onconfig variable: SBSPACENAME).
Then perform the following dbimport command: dbimport -c -q -l buffered mydb
And you see the following errors when the dbimport try to create a BTS index:
> 212 - Cannot add index.
>
> 12802 - Error in initializing an access_method routine execution sequence.
For now I ignore the errors if they for CREATE INDEX for the bts indexes. Once dbimport finishes, I immediately register bts.2.00 on that database. Blademgr will perform the upgrade from bts.1.10 to bts.2.00 even though bts.1.10 is not on 11.50.xC3.
Then I find all the bts indexes in the export SQL file and recreate create them after bts.2.00 is registered. Its also is a good opportunity to move the BTS indexes into sbspaces.
I hope this helps.
Fair winds,
Mark
mailto:mark.ashworth@acm.org
Outgoing email check by Norton AntiVirus
From: informix-list-bounces@iiug.org [mailto:informix-list-bounces@iiug.org] On Behalf Of Cesar Inacio Martins
Sent: November 20, 2008 11:32 AM
To: informix-list cdi
Subject: garbage after unsintall BTS 1.10
Hi,
I have here a IDS 11.50 UC2 Developer with BTS 1.10 installed and registered in a database.
Now I will migrate all data to another instalation with IDS 11.50 UC3 Developer on another machine, and I want to use the dbexport. So I execute the dbexport and see a lot of casts, data types, procedures generated by BTS, so I remove all indexes created to BTS and unregister it . After execute the dbexport/dbschema again still have some casts , data types and procedures.
There is a way to clean all refer to BTS automaticly? or after uninstall/unregister any datablade always will still a garbage ...
The solution I have here is identify the owner of objects, where on my database isn't "informix" user (and the objects of BTS is "informix") or execute a unload table by table....
César
_____
Novos endereços, o Yahoo! que você conhece. Crie <http://br.rd.yahoo.com/mail/taglines/mail/*http:/br.new.mail.yahoo.com/addresses> um email novo com a sua cara @ymail.com ou @rocketmail.com.