Re: ONINIT ERROR - shared memory
Posted in 1996
Hi Peter,
The parametrs in the release notes are the number with which the
software has been tested. Naturally, it will not sufice for all
possible configurations.
Minimize your onconfig parameters to small values, especially
use a small number of BUFFERS, LOCKS, DS_TOTAL_MEMORY and use 0
as the value for SHMTOTAL.
Check carefully the release notes, in some ports there are 2 lists
on system parameters.
Regards,
Roy Gvirtsman,
Snr. Project Manager,
Comsoft Technologies,
INFORMIX representatives in ISRAEL
Peter Strempel wrote:
>
> I get the following error when running oninit or onmonitor to initialise
> our database for the first time:
>
> WARNING: semsys: can't load module, too much memory requested.
>
> We are running ONLINE DS ver 7.20.UC3 on Solaris 2.5.1. The hardware is
> a SPARCSTATION-20 with 32MB of memory.
>
> I have the correct parameters(per Informix doco) set up in my /etc/system
> file and have checked all others in my onconfig with Informix support.
>
> Any assistance would be greatly appreciated.
>
> Thanks,
> Peter Strempel
> chandos@sydney.dialix.oz.au