Re: Informix DSA 7.23, Error 214 (Cannot remove file or table)
Posted in 1997
In <ZSYToDAgnInzEwuK@smooth1.demon.co.uk>, David Williams wrote: <snip> >>Have any of you ever encountered 214 error while dropping a table >>( for re-creation ), from a stored procedure. On On-Line DSA 7.23 UC1, >>we have the following problem on one of the tables : >> >>-214 Cannot remove file for table table-name. >> >>On this error our program quits, on next try, the engine happly drops >>the table !!!. >> > > What is the associated isam error? > Someone probably has a row/page locked in the table or holds a table > level lock. David, Thanks for your feed-back. We can't re-create the problem, when the user/tester got the error we couldn't catch the ISAM-error code. None of our program have any table/page level lock for the table involved in this, transactions where either committed/rolled-back and all cursors closed/freed, before executing the drop and re-create. For access permissions, Informix normally uses : SQL-CODE : -242 Could not open database table table-name With ISAM Code : -113 for file/table lock -106 non exclusive access . The problem was consistent for that session in which the user did retry the executable a few times (from error.log, information) and re-produced the problem. Only after re-starting the user-session we were informed about the problem, but we can't re-produce it. -- Have a nice day Felix K. Mathews mailto:fmathews@systems.dhl.com