Re: Phantom error 956 ...
Posted in 2004
Topics: Server Administration, Data Types & Schema Design, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi.
check your hosts and hosts.equiv in 7etc in both box
--- Jack <vomaringo@yahoo.com> wrote:
> kaskarria@yahoo.es (Jordi Tous) wrote in message
>
news:<643f9bf1.0409210836.3a96e37@posting.google.com>...
> > Hi gurus!
> >
> > Is there anybody ???
> >
> >
> >
> > kaskarria@yahoo.es (Jordi Tous) wrote in message
>
news:<643f9bf1.0409170554.686fa5b6@posting.google.com>...
> > > Hi everybody,
> > >
> > > I have a problem when traing to access across
> two different IDS in
> > > two different servers ...
> > >
> > > 1.- IDS server Linux-dokum
> > > ==========================
> > > IDS 9.30.UC3
> > > Linux dokum 2.4.22-26mdkenterprise
> > >
> > > 2.- IDS server Solaris-sf4800
> > > =============================
> > > IDS 7.31.FD5
> > > SunOS sf4800 5.8 Generic_108528-16 sun4u sparc
> SUNW,Sun-Fire
> > >
> > >
> > > In the IDS930 I have a database albarantest with
> a table
> > > with the schema as below :
> > >
> > > create table albaran
> > > (
> > > albid serial not null ,
> > > albaran char(30),
> > > partida integer,
> > > imagen blob,
> > > usrins varchar(18) default user not null
> ,
> > > fecins date default today not null
> ,
> > > usrupd varchar(18) default user not null
> ,
> > > fecupd date default today not null>
> > > );
> > > create index i_albaran1 on albaran (albaran);
> > > create index i_albaran2 on albaran
> (usrins,fecins);
> > > create index i_albaran3 on albaran (partida);
> > > create unique index p_albaran on albaran
> (albid);> > >
> > > In the IDS731 there are a view against the table
> of the IDS930 as below :
> > >
> > > create view v_albaran as
> > > select albaran, partida from> albaranhamann@ol_dokum:albaran;
> > >
> > > As you see, the blob column of the table is
> ommited in the view, cause
> > > IDS731 don't support this kind of data type !
> > >
> > > The view on IDS731 has been created to do
> selects as :
> > >
> > > SELECT COUNT(*) FROM v_albaran WHERE partida => ???
> > >
> > > The problem, reproduced in dbaccess, is that
> many times, but not allways,
> > > i try to execute the SELECT COUNT(*) ...
> statment from dbaccess in IDS731,
> > > and error like :
> > >
> > > >>956: Client host or user (wwwzar@a11b5505) is> not trusted by the server
>
> i'm not a guru, but a11b5505 seems to say that the
> ip address of the hosts
> is not resolved. could you check your hosts files on
> both server ou name
> server.
>
> regards,
>
>
> > >
> > > is showed!!!
> > >
> > > If you try to run the statment again the sistem
> goes and the statment is
> > > succesfully executed, so the problem related for
> 956 error is solvented ???
> > >
> > > Sometimes it goes and sometimes it doesn`t ...
> Anyone has any idea ??
> > >
> > > Thanks in advance!
>
_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com
sending to informix-list
Hi everybody,
First of all thanks to everybody for your ideas ...
All the setings on the configuration files of the SOLARIS and LINUX
sistems are OK..
The mistery is why when i'm executing the statment :
SELECT COUNT(*) FROM v_albaran WHERE partida = ???
from the IDS731 on SOlaris against the IDS930 on Linux, from the
dbaccess enviroinment, SOMETIMES IT WORKS AND SOMETIMES IT FAILS ...
that's the question ... if the setings of hosts, hosts.equiv .... all
of them or any of them where wrong i think thent the execution of the
statment never will be resolved ... what do you thing about it ...
I think that there are a problem when we work with this two
enviroinments :
IDS731 on Solaris against IDS930 on Linux, and i need a confirmation,
or not,
that this is a IDS BUG.. and how to solve it..
Thanks in advance
<jcrs29@yahoo.com> wrote in message news:<ciso25$st6$1@news.xmission.com>...
> Hi.
>
> check your hosts and hosts.equiv in 7etc in both box
>
>
>
> --- Jack <vomaringo@yahoo.com> wrote:
>
> > kaskarria@yahoo.es (Jordi Tous) wrote in message
> >
> news:<643f9bf1.0409210836.3a96e37@posting.google.com>...
> > > Hi gurus!
> > >
> > > Is there anybody ???
> > >
> > >
> > >
> > > kaskarria@yahoo.es (Jordi Tous) wrote in message
> >
> news:<643f9bf1.0409170554.686fa5b6@posting.google.com>...
> > > > Hi everybody,
> > > >
> > > > I have a problem when traing to access across
> two different IDS in
> > > > two different servers ...
> > > >
> > > > 1.- IDS server Linux-dokum
> > > > ==========================
> > > > IDS 9.30.UC3
> > > > Linux dokum 2.4.22-26mdkenterprise
> > > >
> > > > 2.- IDS server Solaris-sf4800
> > > > =============================
> > > > IDS 7.31.FD5
> > > > SunOS sf4800 5.8 Generic_108528-16 sun4u sparc
> SUNW,Sun-Fire
> > > >
> > > >
> > > > In the IDS930 I have a database albarantest with
> a table
> > > > with the schema as below :
> > > >
> > > > create table albaran
> > > > (
> > > > albid serial not null ,
> > > > albaran char(30),
> > > > partida integer,
> > > > imagen blob,
> > > > usrins varchar(18) default user not null
> ,
> > > > fecins date default today not null
> ,
> > > > usrupd varchar(18) default user not null
> ,
> > > > fecupd date default today not null>
> > > > );
> > > > create index i_albaran1 on albaran (albaran);
> > > > create index i_albaran2 on albaran
> (usrins,fecins);
> > > > create index i_albaran3 on albaran (partida);
> > > > create unique index p_albaran on albaran
> (albid);> > > >
> > > > In the IDS731 there are a view against the table
> of the IDS930 as below :
> > > >
> > > > create view v_albaran as
> > > > select albaran, partida from
> albaranhamann@ol_dokum:albaran;> > > >
> > > > As you see, the blob column of the table is
> ommited in the view, cause
> > > > IDS731 don't support this kind of data type !
> > > >
> > > > The view on IDS731 has been created to do
> selects as :
> > > >
> > > > SELECT COUNT(*) FROM v_albaran WHERE partida =
> ???> > > >
> > > > The problem, reproduced in dbaccess, is that
> many times, but not allways,
> > > > i try to execute the SELECT COUNT(*) ...
> statment from dbaccess in IDS731,
> > > > and error like :
> > > >
> > > > >>956: Client host or user (wwwzar@a11b5505) is> > not trusted by the server
> >
> > i'm not a guru, but a11b5505 seems to say that the
> > ip address of the hosts
> > is not resolved. could you check your hosts files on
> > both server ou name
> > server.
> >
> > regards,
> >
> >
> > > >
> > > > is showed!!!
> > > >
> > > > If you try to run the statment again the sistem
> goes and the statment is
> > > > succesfully executed, so the problem related for
> 956 error is solvented ???
> > > >
> > > > Sometimes it goes and sometimes it doesn`t ...
> Anyone has any idea ??
> > > >
> > > > Thanks in advance!
> >
>
>
>
>
> _______________________________
> Do you Yahoo!?
> Declare Yourself - Register online to vote today!
> http://vote.yahoo.com
> sending to informix-list
On Thu, 23 Sep 2004 03:35:22 -0400, Jordi Tous wrote:
Hmm, query to 9.xx from 7.xx ... Does the table have any columns that are
types not recognized by 7.xx? Yes? Does the table have an index on the
filter column (partida?)? Does it always fail or succeed for the specific
values of partida (ie always fail when ??? == 12 but always success if ??? ==
20)?
Could be that it always succeeds when it can perform an indexed count(*) and
always fails when the optimizer chooses a table scan to perform the count.
This would be expected as the table scan would require 7.xx to deblock the
records which it does not understand while the index scan would not. Of
course I would not expect that to generate a -956 error though..... Hmm....
Art S. Kagel
> Hi everybody,
>
> First of all thanks to everybody for your ideas ...
>
> All the setings on the configuration files of the SOLARIS and LINUX sistems
> are OK..
> The mistery is why when i'm executing the statment :
>
> SELECT COUNT(*) FROM v_albaran WHERE partida = ???>
> from the IDS731 on SOlaris against the IDS930 on Linux, from the dbaccess
> enviroinment, SOMETIMES IT WORKS AND SOMETIMES IT FAILS ... that's the
> question ... if the setings of hosts, hosts.equiv .... all of them or any of
> them where wrong i think thent the execution of the statment never will be
> resolved ... what do you thing about it ...
>
> I think that there are a problem when we work with this two enviroinments :
>
> IDS731 on Solaris against IDS930 on Linux, and i need a confirmation, or
> not,
> that this is a IDS BUG.. and how to solve it..
>
> Thanks in advance
>
>
>
> <jcrs29@yahoo.com> wrote in message news:<ciso25$st6$1@news.xmission.com>...
>> Hi.
>>
>> check your hosts and hosts.equiv in 7etc in both box
>>
>>
>>
>> --- Jack <vomaringo@yahoo.com> wrote:
>>
>> > kaskarria@yahoo.es (Jordi Tous) wrote in message
>> >
>> news:<643f9bf1.0409210836.3a96e37@posting.google.com>...
>> > > Hi gurus!
>> > >
>> > > Is there anybody ???
>> > >
>> > >
>> > >
>> > > kaskarria@yahoo.es (Jordi Tous) wrote in message
>> >
>> news:<643f9bf1.0409170554.686fa5b6@posting.google.com>...
>> > > > Hi everybody,
>> > > >
>> > > > I have a problem when traing to access across
>> two different IDS in
>> > > > two different servers ...
>> > > >
>> > > > 1.- IDS server Linux-dokum
>> > > > ==========================
>> > > > IDS 9.30.UC3
>> > > > Linux dokum 2.4.22-26mdkenterprise
>> > > >
>> > > > 2.- IDS server Solaris-sf4800
>> > > > =============================
>> > > > IDS 7.31.FD5
>> > > > SunOS sf4800 5.8 Generic_108528-16 sun4u sparc
>> SUNW,Sun-Fire
>> > > >
>> > > >
>> > > > In the IDS930 I have a database albarantest with
>> a table
>> > > > with the schema as below :
>> > > >
>> > > > create table albaran
>> > > > (
>> > > > albid serial not null ,
>> > > > albaran char(30),
>> > > > partida integer,
>> > > > imagen blob,
>> > > > usrins varchar(18) default user not null
>> ,
>> > > > fecins date default today not null
>> ,
>> > > > usrupd varchar(18) default user not null
>> ,
>> > > > fecupd date default today not null>>
>> > > > );
>> > > > create index i_albaran1 on albaran (albaran); create index i_albaran2
>> > > > on albaran
>> (usrins,fecins);
>> > > > create index i_albaran3 on albaran (partida); create unique index>> > > > p_albaran on albaran
>> (albid);
>> > > >
>> > > > In the IDS731 there are a view against the table
>> of the IDS930 as below :
>> > > >
>> > > > create view v_albaran as
>> > > > select albaran, partida from
>> albaranhamann@ol_dokum:albaran;>> > > >
>> > > > As you see, the blob column of the table is
>> ommited in the view, cause
>> > > > IDS731 don'''t support this kind of data type !
>> > > >
>> > > > The view on IDS731 has been created to do
>> selects as :
>> > > >
>> > > > SELECT COUNT(*) FROM v_albaran WHERE partida =
>> ???>> > > >
>> > > > The problem, reproduced in dbaccess, is that
>> many times, but not allways,
>> > > > i try to execute the SELECT COUNT(*) ...
>> statment from dbaccess in IDS731,
>> > > > and error like :
>> > > >
>> > > > >>956: Client host or user (wwwzar@a11b5505) is>> > not trusted by the server
>> >
>> > i'm not a guru, but a11b5505 seems to say that the ip address of the
>> > hosts
>> > is not resolved. could you check your hosts files on both server ou name
>> > server.
>> >
>> > regards,
>> >
>> >
>> >
>> > > > is showed!!!
>> > > >
>> > > > If you try to run the statment again the sistem
>> goes and the statment is
>> > > > succesfully executed, so the problem related for
>> 956 error is solvented ???
>> > > >
>> > > > Sometimes it goes and sometimes it doesn`t ...
>> Anyone has any idea ??
>> > > >
>> > > > Thanks in advance!
>> >
>> >
>> >
>>
>>
>> _______________________________
>> Do you Yahoo!?
>> Declare Yourself - Register online to vote today! http://vote.yahoo.com
>> sending to informix-list