RE: Informix Instance Size
Posted in 1999
Topics: Storage & Space Management, Logging & Checkpoints, Platform-Specific Issues
We start to have the following INTERMEDIATE problem. I'm not sure if it is because of the size of instance or other problem. Both Informix Tech support and I are still fail to identify the cause: 1. Sometime the instance do not do checkpoint before shutdown; 2. Sometime the instance can not started after shutdown and gave the error as "out of shared memory"; 3. Sometime the instance restore the old image of rootdbs after system reboot and the instance can not roll forward from the old root reserved pages; I had to restore the 300GB from backup tape; 4. Sometime the batch process will hung in the midder of the process. When I tried the same SQL in the same time the batch process was still hunging, the one I re-issued can run through without any problem; Jean Wang -----Original Message----- From: Achyut Gadre [mailto:achyut@sprynet.com] Sent: Monday, October 04, 1999 4:08 PM To: informix-list@iiug.org Subject: Re: Informix Instance Size We have a data warehouse which is 700-800GB in size and ~400 chunks. But we have 7.30UC6 on solaris 2.5 version. Achyut Gadre Wang Jean wrote: > Hi, > Are there anybody have Informix instance with more than 300GB size and > more than 500 chunks? Our instance behaves very strange since we reach to > that size? We use Informix 7.23uc3 in Sun Solaris 2.5.1 environment. > > Thanks > Jean Wang
When you say "shutdown" do you mean engine shutdown or OS shutdown? If OS shutdown, do you have a shutdown script for the Informix instance? What OS and what is it named? (There is a bug in Solaris 2.5.1-2.6 which ONLY executes shutdown scripts that begin with an 'S' and NOT the conventional 'K' scripts!) There may lurk your problem. Art S. Kagel Wang Jean wrote: > > We start to have the following INTERMEDIATE problem. I'm not sure if it is > because of the size of instance or other problem. Both Informix Tech support > and I are still fail to identify the cause: > 1. Sometime the instance do not do checkpoint before shutdown; > 2. Sometime the instance can not started after shutdown and gave the error > as "out of shared memory"; > 3. Sometime the instance restore the old image of rootdbs after system > reboot and the instance can not roll forward from the old root reserved > pages; I had to restore the 300GB from backup tape; > 4. Sometime the batch process will hung in the midder of the process. When I > tried the same SQL in the same time the batch process was still hunging, the > one I re-issued can run through without any problem; > > Jean Wang > > -----Original Message----- > From: Achyut Gadre [mailto:achyut@sprynet.com] > Sent: Monday, October 04, 1999 4:08 PM > To: informix-list@iiug.org > Subject: Re: Informix Instance Size > > We have a data warehouse which is 700-800GB in size and ~400 chunks. > But we have 7.30UC6 on solaris 2.5 version. > > Achyut Gadre > > Wang Jean wrote: > > > Hi, > > Are there anybody have Informix instance with more than 300GB size and > > more than 500 chunks? Our instance behaves very strange since we reach to > > that size? We use Informix 7.23uc3 in Sun Solaris 2.5.1 environment. > > > > Thanks > > Jean Wang