Re: Informix I-Net problem
Posted in 1992
In-Reply-To: <memo.572497@cix.compulink.co.uk> shemminga@cix.compulink.co.uk (Stuart Hemming) In <memo.572497@cix.compulink.co.uk> I wrote: > Can anyone help me? We're running a small net of 386/486 boxes. On > the 486 machine we've got Informix SE installed along with SQL and > I-Net. On the other 2 machines we've go SQL and I-Net. > > We also have a number of Informix 4GL programs running. The problem > is that when a number of sqlexec processes are started the system > reports the following error messages if someone tries to start > another one: > > -932 : Error on network connection, t_open system call failed > 28 : No space left on device > > The message appears on the client terminals, the server doesn't seem > to be getting upset about it. I don't know however, whether it's the > client or the server that's generating the error message. In the replies that followed it was suggested that the kernel parameter NQUEUE was set wrong. I've since re-tuned the kernel on both the server and the clients. Using crash it would appear that the kernel resources are adequate (at least there are no failures). I've discovered that the error occurs if there are 8 remotely started sqlexec processes started on the server. This may seem like a dumb question but I understand the entry that is made in /etc/services is to allow tcp/ip to make connections. Would having more than one entry mean that I could have more connections? TIA -------------------------------------------------------------- | Who cares whos opinions these are?! | | Send me mail and I'll love you forever (Maybe) | |------------------------------------------------------------| | Stuart Hemming | shemminga@cix.compulink.co.uk | | Tudor Labels Ltd | | | Roman Bank Bourne | Tel : (+44) 778 426444 | | Lincs PE10 9LQ. UK. | Fax : (+44) 778 421862 | -------------------------------------------------------------- Stuart |8-)