Re: aborting long transaction
Posted in 1998
This happens when one transaction potentially
spans over 50% of your logs.
Adding more logs is one way that may help (not a smart one
but sometimes the simplest if you got the space.)
The real trouble is in the application unless you are
processing a huge amount of data , the program is
not written well, I've seen this at period/ends , year/ends
type of processes, in those cases the programs have
to be written so that they process one logical transaction
at a time , and not the whole thing .
Another thing which may be causing this is the
following :
An application issues a begin work
this is marked in the log as trans start,
user goes away for extended amount of time
during which other users are processing data ,
when the user left the current log was 1 ,
now it is 25 (you got 50) , the user comes back
continues or aborts , this tries to write to the log
oops the transaction started in log 1 you are now in
log 26 that is a Long Transaction ...
Bottom line never have a interactive step (input , menu ) ,
inside a transaction .
Mariusz Malogrosz
SPA
Thuc Nguyen <thucn@email.utcourts.gov> wrote in article
<6bad02$855$1@news.xmission.com>...
>
> Hi
>
> I am running ODS 7.23 on HP O/S 10.20. A few users have received some
error messages. I looked at the log file and then added 14 more logs. But
they got the same errors. I checked onstat -l and they were not full.
>
> What else I should look at? Here is the log file info.
>
>
> 10:22:58 Checkpoint Completed: duration was 3 seconds.
> 10:25:49 Logical Log 291 Complete.
> 10:25:51 Checkpoint Completed: duration was 1 seconds.
> 10:25:51 Aborting Long Transaction: tx 0xc26424a0 username: marlynr uid:112
> 10:25:54 Process exited with return code 133: /bin/sh /bin/sh -c
/usr/informix/> etc/log_full.sh 2 23 "Logical Log 291 Complete." "Logical Log 291
Complete."
> 10:31:05 Checkpoint Completed: duration was 2 seconds.
>
> Thaks
> Thuc
>
>