Shared memory not initialized
Posted in 1999
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Versions, Editions & End-of-Life
Hi folks,
we are running IDS 7.3 on Windows NT Server.
Yesterday a network error occurred during a long database transaction
and Informix shut down. Now we're unable to bring Informix online.
Can anyone help, please?
The online log looks like this:
16:22:22 DR: DRAUTO is 0 (Off)
16:22:23 Informix Dynamic Server Version 7.30.TC2 Software SerialNumber AAC#J362026
16:22:23 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
16:22:23 Physical Recovery Started.
16:22:24 Physical Recovery Complete: 1344 Pages Restored.
16:22:24 Logical Recovery Started.
16:22:41 (5) connection rejected - no calls allowed for sqlexec
16:22:41 listener-thread: err = -27002: oserr = 0: errstr = : Noconnections are allowed in Dynamic Server quiescent mode.
16:22:51 (9) connection rejected - no calls allowed for sqlexec
16:22:51 listener-thread: err = -27002: oserr = 0: errstr = : Noconnections are allowed in Dynamic Server quiescent mode.
16:23:03 Assert Failed: Rollback error 126
16:23:03 Informix Dynamic Server Version 7.30.TC2
16:23:03 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
Thread(15, fast_rec, 0, 1)
File: r:\\rsam\\rstrans.c Line: 2116
16:23:03 Results: Log record (OLDRSAM:HDELETE) in log 227, offset0x318f140 was not rolled back
16:23:03 Action: Use 'onlog' to view the transaction and repair
manually.
16:23:10 See Also: af.fd046, shmem.fd046.0
16:23:12 Rollback error 126
16:23:12 Assert Failed: Rollback error 126
16:23:12 Informix Dynamic Server Version 7.30.TC2
16:23:12 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
Thread(15, fast_rec, 0, 1)
File: r:\\rsam\\rsextlog.c Line: 1414
16:23:12 Results: Log record (OLDRSAM:HDELETE) in log 227, offset0x318f140 was not rolled back
16:23:12 Action: Use 'onlog' to view the transaction and repair
manually.
16:23:19 See Also: af.fd046, shmem.fd046.1
16:23:28 Rollback error 126
16:23:30 Logical Logging error in 'rollback'
16:23:39 Assert Failed: Dynamic Server must abort
16:23:39 Informix Dynamic Server Version 7.30.TC2
16:23:39 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
Thread(15, fast_rec, 0, 1)
File: r:\\rsam\\rslog.c Line: 3152
16:23:39 Results: Dynamic Server must abort
16:23:39 Action: Reinitialize shared memory
16:24:16 See Also: af.fd046, shmem.fd046.2
16:24:30 r:\\rsam\\rslog.c, line 3152, thread 15, proc id 187, DynamicServer must abort.
16:24:30 PANIC: Attempting to bring system down
Thanks in advance.
J'rgen
Sent via Deja.com http://www.deja.com/
Before you buy.
<kozioldejanews@my-deja.com> wrote in message
news:7umcot$fl8$1@nnrp1.deja.com...
> Hi folks,
>
> we are running IDS 7.3 on Windows NT Server.
> Yesterday a network error occurred during a long database transaction
> and Informix shut down. Now we're unable to bring Informix online.
> Can anyone help, please?
In this situation - only Informix Tech Support. Some logical log records are
damaged, that's why logical recovery can't be finished. If you have level 0
archive - try to restore without replaying logs. If you don't have backup -
only tech support will be able to restore integrity of logical logs pages or
reset transaction counter, used for logical recovery. Any way, I think data
consistency will be lost.
---------------------------------------------------
With best regards, Yuri Dovgart
SAP R/3, Informix technical consultant,
Senior System Consultant
System Architecture and High Availability Systems,
'Telecominvest' company
Email y_dovgart@tci.ukrtel.net
ICQ 39284285
>
> The online log looks like this:
>
> 16:22:22 DR: DRAUTO is 0 (Off)
> 16:22:23 Informix Dynamic Server Version 7.30.TC2 Software Serial> Number AAC#J362026
> 16:22:23 Informix Dynamic Server Initialized -- Shared Memory> Initialized.
> 16:22:23 Physical Recovery Started.
> 16:22:24 Physical Recovery Complete: 1344 Pages Restored.
> 16:22:24 Logical Recovery Started.
> 16:22:41 (5) connection rejected - no calls allowed for sqlexec
> 16:22:41 listener-thread: err = -27002: oserr = 0: errstr = : No> connections are allowed in Dynamic Server quiescent mode.
>
> 16:22:51 (9) connection rejected - no calls allowed for sqlexec
> 16:22:51 listener-thread: err = -27002: oserr = 0: errstr = : No> connections are allowed in Dynamic Server quiescent mode.
>
> 16:23:03 Assert Failed: Rollback error 126
> 16:23:03 Informix Dynamic Server Version 7.30.TC2
> 16:23:03 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
> Thread(15, fast_rec, 0, 1)
> File: r:\\rsam\\rstrans.c Line: 2116
> 16:23:03 Results: Log record (OLDRSAM:HDELETE) in log 227, offset> 0x318f140 was not rolled back
> 16:23:03 Action: Use 'onlog' to view the transaction and repair
> manually.
> 16:23:10 See Also: af.fd046, shmem.fd046.0
> 16:23:12 Rollback error 126
> 16:23:12 Assert Failed: Rollback error 126
> 16:23:12 Informix Dynamic Server Version 7.30.TC2
> 16:23:12 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
> Thread(15, fast_rec, 0, 1)
> File: r:\\rsam\\rsextlog.c Line: 1414
> 16:23:12 Results: Log record (OLDRSAM:HDELETE) in log 227, offset> 0x318f140 was not rolled back
> 16:23:12 Action: Use 'onlog' to view the transaction and repair
> manually.
> 16:23:19 See Also: af.fd046, shmem.fd046.1
> 16:23:28 Rollback error 126
> 16:23:30 Logical Logging error in 'rollback'
> 16:23:39 Assert Failed: Dynamic Server must abort
> 16:23:39 Informix Dynamic Server Version 7.30.TC2
> 16:23:39 Who: Session(8, informix@R9720569.gefm.eur.deuba.com, 0, 0)
> Thread(15, fast_rec, 0, 1)
> File: r:\\rsam\\rslog.c Line: 3152
> 16:23:39 Results: Dynamic Server must abort
> 16:23:39 Action: Reinitialize shared memory
> 16:24:16 See Also: af.fd046, shmem.fd046.2
> 16:24:30 r:\\rsam\\rslog.c, line 3152, thread 15, proc id 187, Dynamic> Server must abort.
> 16:24:30 PANIC: Attempting to bring system down>
>
> Thanks in advance.
> J'rgen
>
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
kozioldejanews@my-deja.com wrote: > > Hi folks, > > we are running IDS 7.3 on Windows NT Server. > Yesterday a network error occurred during a long database transaction > and Informix shut down. Now we're unable to bring Informix online. > Can anyone help, please? Looks like the rollback records in the logical log are damaged. Some of these are multiple record sets and often a partial set, caused by buffered logging most often, are written to disk by a buffer flush and the fast recovery gets confused, it basically cannot decide if it needs to reapply the rollback or not when it hits the end of the last log, so it simply refuses to do anything that might be harmful. Contact tech support. Have them truncate the log at the beginning of the LTX rollback so that the entire rollback can begin again as part of the fast recovery. Worst case other transactions that finished after that point will rollback as well. If you databases are using buffered logging consider changing to UNBUFFERED logging the window of risk for logical log inconsistencies is FAR smaller with unbuffered logging (you may have to add a few log files if you do this unbuffered logging uses logspace faster than buffered logs unless all transactions are close in size to, or larger than, the logical log buffers). Art S. Kagel