Replacement of database primary drive
Posted in 2012
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Transactions, Locking & Isolation, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
Dear All,
It's a long time since I've posted here as I haven't worked with Informix for
a while. However, I'm 'last man standing' and there's a problem at a customer
site.
The system has been installed and working for many years, but now the primary
drive of their mirrored pair is beginning to show soft errors and could do
with replacing. Regrettably, I've forgotten how to and I don't have the luxury
of a development system to practice on. Nightmare scenario...
This is how the server is configured on Solaris 2.6:
server# onstat -d
Informix Dynamic Server Version 7.31.UC6 -- On-Line -- Up 20 days 19:43:44 --
189696 Kbytes
Dbspaces
address number flags fchunk nchunks flags owner name
1104a150 1 2 1 2 M informix rootdbs
1 active, 2047 maximum
Chunks
address chk/dbs offset size free bpages flags pathname
1104a210 1 1 0 1026000 457502 PO- /INFORMIX_DBSPACE_CHUNK0
1104a2f0 1 1 0 1026000 0 MO- /.INFORMIX_INSTANCE_0.m0
11073798 2 1 0 852120 105896 PO- /INFORMIX_DBSPACE_CHUNK1
11073878 2 1 0 852120 0 MO- /.INFORMIX_INSTANCE_0.m1
2 active, 2047 maximum
server# ls -ld /INFORMIX_DBSPACE_CHUNK*lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK0 ->
/dev/rdsk/c0t2d0s3
lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK1 ->
/dev/rdsk/c0t2d0s4
server# ls -ld /.INFORMIX_INSTANCE_0.m*
lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m0 ->
/dev/rdsk/c0t1d0s3
lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m1 ->
/dev/rdsk/c0t1d0s4
server# prtvtoc /dev/rdsk/c0t1d0s2
* /dev/rdsk/c0t1d0s2 partition map
*
* Dimensions:
* 512 bytes/sector
* 135 sectors/track
* 16 tracks/cylinder
* 2160 sectors/cylinder
* 3882 cylinders
* 3880 accessible cylinders
*
* Flags:
* 1: unmountable
* 10: read-only
*
* First Sector Last
* Partition Tag Flags Sector Count Sector Mount Directory
0 0 00 0 4320 4319
1 3 01 4320 864000 868319
2 5 01 0 8380800 8380799
3 0 00 868320 4104000 4972319
4 0 00 4972320 3408480 8380799
server# prtvtoc /dev/rdsk/c0t2d0s2
* /dev/rdsk/c0t2d0s2 partition map
*
* Dimensions:
* 512 bytes/sector
* 135 sectors/track
* 16 tracks/cylinder
* 2160 sectors/cylinder
* 3882 cylinders
* 3880 accessible cylinders
*
* Flags:
* 1: unmountable
* 10: read-only
*
* First Sector Last
* Partition Tag Flags Sector Count Sector Mount Directory
0 0 00 0 4320 4319
1 3 01 4320 864000 868319
2 5 01 0 8380800 8380799
3 0 00 868320 4104000 4972319
4 0 00 4972320 3408480 8380799
server# iostat -En
<..snip..>
c0t1d0 Soft Errors: 230 Hard Errors: 0 Transport Errors: 0
Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: 9848310333
RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 230
Illegal Request: 0 Predictive Failure Analysis: 0
c0t2d0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: 99285G2252
RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
server# cat onconfig.INSTANCE_0
#**************************************************************************
#
# INFORMIX SOFTWARE, INC.
#
# Title: onconfig.ows# Description: INFORMIX-OnLine Configuration Parameters
#
#**************************************************************************
# Root Dbspace Configuration
ROOTNAME rootdbs # Root dbspace nameROOTPATH /INFORMIX_DBSPACE_CHUNK0
ROOTOFFSET 0 # Offset of root dbspace into device (Kbytes)
ROOTSIZE 2052000 # Size of root dbspace (Kbytes)# Disk Mirroring Configuration Parameters
MIRROR 1 # Mirroring flag (Yes = 1, No = 0)
MIRRORPATH /.INFORMIX_INSTANCE_0.m0
MIRROROFFSET 0 # Offset into mirrored device (Kbytes)# Physical Log Configuration
PHYSDBS rootdbs # Location (dbspace) of physical log
PHYSFILE 10000 # Physical log file size (Kbytes)# Logical Log Configuration
LOGFILES 20 # Number of logical log files
LOGSIZE 2000 # Logical log size (Kbytes)# Diagnostics
MSGPATH /usr/informix/etc/online.log # System message log file path
CONSOLE /dev/console # System console message path
ALARMPROGRAM /tanit/tcl/log_warn/log_full.sh # Alarm program path# System Archive Tape Device
TAPEDEV /dev/rmt/0
TAPEBLK 128 # Tape block size (Kbytes)
TAPESIZE 4000000 # Maximum amount of data to put on tape (Kbytes)# Log Archive Tape Device
LTAPEDEV /dev/rmt/1
LTAPEBLK 128 # Log tape block size (Kbytes)
LTAPESIZE 4000000 # Max amount of data to put on log tape (Kbytes)
# OpticalSTAGEBLOB # INFORMIX-OnLine/Optical staging area
# System Configuration
SERVERNUM 0 # Unique id corresponding to a OnLine instance
DBSERVERNAME INSTANCE_0 # Name of default database serverDBSERVERALIASES INSTANCE_0_SHM,INSTANCE_0_TCP # List of alternate dbservernames
NETTYPE ipcstr,1,200,NET
NETTYPE ipcshm,1,200,CPU
NETTYPE tlitcp,1,100,NET# increase tcp connections from 5 to 50. AL 1-mar-00
# read tasks failed to start correctly, error -25553 in database selection
# AL 23-nov-01
# increase again: str 100 -> 200
# shm 100 -> 200
# tcp 50 -> 100
# as a result of error -25560 from read tasks
DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.# AL 15-oct-00 change RESIDENT from 0 to 1
RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor
NUMCPUVPS 1 # Number of user (cpu) vps
SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vps to one
# AL 30-aug-2000
# disable process ageing
NOAGE 1 # Process aging
AFF_SPROC 0 # Affinity start processor
AFF_NPROCS 0 # Affinity number of processors# Shared Memory Parameters
LOCKS 2000 # Maximum number of locks#BUFFERS 1000 # Maximum number of shared buffers
# buffers increased from 1000 to 10000. al 22/12/98
# buffers increased to 20000. al 28/07/00
# buffers increased to 30000. al 17/4/02
# buffers increased to 40000. al 23/4/02
# buffers increased to 50000. al 16/10/02
BUFFERS 50000 # Maximum number of shared buffers
NUMAIOVPS # Number of IO vps
PHYSBUFF 32 # Physical log buffer size (Kbytes)
LOGBUFF 32 # Logical log buffer size (Kbytes)LOGSMAX 20 # Maximum number of logical log files
#CLEANERS 1 # Number of buffer cleaner processes
# cleaners incread in line with LRUS. AL 16/10/02
CLEANERS 63 # Number of buffer cleaner processes
SHMBASE 0xa000000 # Shared memory base address# SHMVIRTSIZE increased from 8000 to 37000, 5 jun 2000 by AL
# from 37000 to 75000, 16 Jun 2000 by AL
SHMVIRTSIZE 75000 # initial virtual shared memory segment size
SHMADD 8192 # Size of new shared memory segments (Kbytes)
SHMTOTAL 0 # Total shared memory (Kbytes). 0=>unlimited
CKPTINTVL 300 # Check point interval (in sec)#LRUS 8 # Number of LRU queues
# increase LRUs from 8 to 32. al 22/12/98
# increase LRUs to 64. al 28/07/00
# decrease LRUs to 63. suspicion that even numbers are bad... al 19 apr 02
LRUS 63 # Number of LRU qu
Mirrored you say? Can't you just replace the primary and let the mirror =
re-image it?
j.
On May 27, 2012, at 12:38 PM, ANDY LENNARD wrote:
> Dear All,=20
>=20
> It's a long time since I've posted here as I haven't worked with =
Informix for=20
> a while. However, I'm 'last man standing' and there's a problem at a =
customer=20
> site.=20
>=20
> The system has been installed and working for many years, but now the =
primary=20
> drive of their mirrored pair is beginning to show soft errors and =
could do=20
> with replacing. Regrettably, I've forgotten how to and I don't have =
the luxury=20
> of a development system to practice on. Nightmare scenario...=20
>=20
> This is how the server is configured on Solaris 2.6:=20
>=20
> server# onstat -d=20
>=20
> Informix Dynamic Server Version 7.31.UC6 -- On-Line -- Up 20 days =
19:43:44 --=20> 189696 Kbytes=20
>=20
> Dbspaces=20
> address number flags fchunk nchunks flags owner name=20
> 1104a150 1 2 1 2 M informix rootdbs=20
> 1 active, 2047 maximum=20
>=20
> Chunks=20
> address chk/dbs offset size free bpages flags pathname=20
> 1104a210 1 1 0 1026000 457502 PO- /INFORMIX_DBSPACE_CHUNK0=20
> 1104a2f0 1 1 0 1026000 0 MO- /.INFORMIX_INSTANCE_0.m0=20
> 11073798 2 1 0 852120 105896 PO- /INFORMIX_DBSPACE_CHUNK1=20
> 11073878 2 1 0 852120 0 MO- /.INFORMIX_INSTANCE_0.m1=20
> 2 active, 2047 maximum=20
>=20
> server# ls -ld /INFORMIX_DBSPACE_CHUNK*=20> lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK0 ->=20
> /dev/rdsk/c0t2d0s3=20
> lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK1 ->=20
> /dev/rdsk/c0t2d0s4=20
> server# ls -ld /.INFORMIX_INSTANCE_0.m*=20
> lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m0 ->=20
> /dev/rdsk/c0t1d0s3=20
> lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m1 ->=20
> /dev/rdsk/c0t1d0s4=20
>=20
> server# prtvtoc /dev/rdsk/c0t1d0s2=20
> * /dev/rdsk/c0t1d0s2 partition map=20
> *=20
> * Dimensions:=20
> * 512 bytes/sector=20
> * 135 sectors/track=20
> * 16 tracks/cylinder=20
> * 2160 sectors/cylinder=20
> * 3882 cylinders=20> * 3880 accessible cylinders=20
> *=20
> * Flags:=20
> * 1: unmountable=20
> * 10: read-only=20
> *=20
> * First Sector Last=20
> * Partition Tag Flags Sector Count Sector Mount Directory=20
>=20
> 0 0 00 0 4320 4319=20
>=20
> 1 3 01 4320 864000 868319=20
>=20
> 2 5 01 0 8380800 8380799=20
>=20
> 3 0 00 868320 4104000 4972319=20
>=20
> 4 0 00 4972320 3408480 8380799=20
>=20
> server# prtvtoc /dev/rdsk/c0t2d0s2=20
> * /dev/rdsk/c0t2d0s2 partition map=20
> *=20
> * Dimensions:=20
> * 512 bytes/sector=20
> * 135 sectors/track=20
> * 16 tracks/cylinder=20
> * 2160 sectors/cylinder=20
> * 3882 cylinders=20
> * 3880 accessible cylinders=20
> *=20
> * Flags:=20
> * 1: unmountable=20
> * 10: read-only=20
> *=20
> * First Sector Last=20
> * Partition Tag Flags Sector Count Sector Mount Directory=20
>=20
> 0 0 00 0 4320 4319=20
>=20
> 1 3 01 4320 864000 868319=20
>=20
> 2 5 01 0 8380800 8380799=20
>=20
> 3 0 00 868320 4104000 4972319=20
>=20
> 4 0 00 4972320 3408480 8380799=20
>=20
> server# iostat -En=20
>=20
> <..snip..>=20
>=20
> c0t1d0 Soft Errors: 230 Hard Errors: 0 Transport Errors: 0=20
> Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: =
9848310333=20
> RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>=20
> Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 230=20
> Illegal Request: 0 Predictive Failure Analysis: 0=20
>=20
> c0t2d0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0=20
> Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: =
99285G2252=20
> RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>=20
> Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0=20
> Illegal Request: 0 Predictive Failure Analysis: 0=20
>=20
> server# cat onconfig.INSTANCE_0=20
> =
#*************************************************************************=
*=20
> #=20
> # INFORMIX SOFTWARE, INC.=20
> #=20
> # Title: onconfig.ows=20> # Description: INFORMIX-OnLine Configuration Parameters=20
> #=20
> =
#*************************************************************************=
*=20
> # Root Dbspace Configuration=20
> ROOTNAME rootdbs # Root dbspace name=20
> ROOTPATH /INFORMIX_DBSPACE_CHUNK0=20
> ROOTOFFSET 0 # Offset of root dbspace into device (Kbytes)=20
> ROOTSIZE 2052000 # Size of root dbspace (Kbytes)=20> # Disk Mirroring Configuration Parameters=20
> MIRROR 1 # Mirroring flag (Yes =3D 1, No =3D 0)=20
> MIRRORPATH /.INFORMIX_INSTANCE_0.m0=20
> MIRROROFFSET 0 # Offset into mirrored device (Kbytes)=20> # Physical Log Configuration=20
> PHYSDBS rootdbs # Location (dbspace) of physical log=20
> PHYSFILE 10000 # Physical log file size (Kbytes)=20> # Logical Log Configuration=20
> LOGFILES 20 # Number of logical log files=20
> LOGSIZE 2000 # Logical log size (Kbytes)=20
> # Diagnostics=20
> MSGPATH /usr/informix/etc/online.log # System message log file path=20
> CONSOLE /dev/console # System console message path=20
> ALARMPROGRAM /tanit/tcl/log_warn/log_full.sh # Alarm program path=20> # System Archive Tape Device=20
> TAPEDEV /dev/rmt/0=20
> TAPEBLK 128 # Tape block size (Kbytes)=20
> TAPESIZE 4000000 # Maximum amount of data to put on tape (Kbytes)=20> # Log Archive Tape Device=20
> LTAPEDEV /dev/rmt/1=20
> LTAPEBLK 128 # Log tape block size (Kbytes)=20
> LTAPESIZE 4000000 # Max amount of data to put on log tape (Kbytes)=20
> # Optical=20> STAGEBLOB # INFORMIX-OnLine/Optical staging area=20
> # System Configuration=20
> SERVERNUM 0 # Unique id corresponding to a OnLine instance=20
> DBSERVERNAME INSTANCE_0 # Name of default database server=20
> DBSERVERALIASES INSTANCE_0_SHM,INSTANCE_0_TCP # List of alternate=20> dbservernames=20
> NETTYPE ipcstr,1,200,NET=20
> NETTYPE ipcshm,1,200,CPU=20
> NETTYPE tlitcp,1,100,NET=20> # increase tcp connections from 5 to 50. AL 1-mar-00=20
> # read tasks failed to start correctly, error -25553 in database =
selection=20
> # AL 23-nov-01=20
> # increase again: str 100 -> 200=20
> # shm 100 -> 200=20
> # tcp 50 -> 100=20
> # as a result of error -25560 from read tasks=20
> DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.=20> # AL 15-oct-00 change RESIDENT from 0 to 1=20
> RESIDENT 1 # Forced residency flag (Yes =3D 1, No =3D 0)=20
> MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor=20
> NUMCPUVPS 1 # Number of user (cpu) vps=20
> SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vps to one=20
>=20
> # AL 30-aug-2000=20> # disable process ageing=20
> NOAGE 1 # Process aging=20
> AFF_SPROC 0 # Affinity start processor=20
> AFF_NPROCS 0 # Affinity number of processors=20> # Shared Memory Parameters=20
> LOCKS 2000 # Maximum number of locks=20> #BUFFERS 1000 # Maximum number of shared buffers=20
> # buffers increased from 1000 to 10000. al 22/12/98=20
> # buffers increased to 20000. al 28/07/00=20
> # buff
You can do this with the engine online. Use "onspaces -s" to mark the
primary chunks on the failing drive offline, replace the drive and
partition appropriately, link the primary chunk paths to the new drive's
partitions, use "onspaces -s" to mark the replaced chunks online. Informix
will reconstruct the data.
You can do it with the engine offline, just replace the onspaces commands
with taking the engine offline and back online and copy the data manually
from the mirror chunks to the new primary chunks using dd.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Sun, May 27, 2012 at 12:38 PM, ANDY LENNARD <andy_lennard@hotmail.com>wrote:
> Dear All,
>
> It's a long time since I've posted here as I haven't worked with Informix
> for
> a while. However, I'm 'last man standing' and there's a problem at a
> customer
> site.
>
> The system has been installed and working for many years, but now the
> primary
> drive of their mirrored pair is beginning to show soft errors and could do
> with replacing. Regrettably, I've forgotten how to and I don't have the
> luxury
> of a development system to practice on. Nightmare scenario...
>
> This is how the server is configured on Solaris 2.6:
>
> server# onstat -d>
> Informix Dynamic Server Version 7.31.UC6 -- On-Line -- Up 20 days 19:43:44
> --
> 189696 Kbytes
>
> Dbspaces
> address number flags fchunk nchunks flags owner name
> 1104a150 1 2 1 2 M informix rootdbs
> 1 active, 2047 maximum
>
> Chunks
> address chk/dbs offset size free bpages flags pathname
> 1104a210 1 1 0 1026000 457502 PO- /INFORMIX_DBSPACE_CHUNK0
> 1104a2f0 1 1 0 1026000 0 MO- /.INFORMIX_INSTANCE_0.m0
> 11073798 2 1 0 852120 105896 PO- /INFORMIX_DBSPACE_CHUNK1
> 11073878 2 1 0 852120 0 MO- /.INFORMIX_INSTANCE_0.m1
> 2 active, 2047 maximum
>
> server# ls -ld /INFORMIX_DBSPACE_CHUNK*> lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK0 ->
> /dev/rdsk/c0t2d0s3
> lrwxrwxrwx 1 root other 18 May 29 2010 /INFORMIX_DBSPACE_CHUNK1 ->
> /dev/rdsk/c0t2d0s4
> server# ls -ld /.INFORMIX_INSTANCE_0.m*
> lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m0 ->
> /dev/rdsk/c0t1d0s3
> lrwxrwxrwx 1 root other 18 May 29 2010 /.INFORMIX_INSTANCE_0.m1 ->
> /dev/rdsk/c0t1d0s4>
> server# prtvtoc /dev/rdsk/c0t1d0s2
> * /dev/rdsk/c0t1d0s2 partition map
> *
> * Dimensions:
> * 512 bytes/sector
> * 135 sectors/track
> * 16 tracks/cylinder
> * 2160 sectors/cylinder
> * 3882 cylinders
> * 3880 accessible cylinders
> *
> * Flags:
> * 1: unmountable
> * 10: read-only
> *
> * First Sector Last
> * Partition Tag Flags Sector Count Sector Mount Directory
>
> 0 0 00 0 4320 4319
>
> 1 3 01 4320 864000 868319
>
> 2 5 01 0 8380800 8380799
>
> 3 0 00 868320 4104000 4972319
>
> 4 0 00 4972320 3408480 8380799
>
> server# prtvtoc /dev/rdsk/c0t2d0s2
> * /dev/rdsk/c0t2d0s2 partition map
> *
> * Dimensions:
> * 512 bytes/sector
> * 135 sectors/track
> * 16 tracks/cylinder
> * 2160 sectors/cylinder
> * 3882 cylinders
> * 3880 accessible cylinders
> *
> * Flags:
> * 1: unmountable
> * 10: read-only
> *
> * First Sector Last
> * Partition Tag Flags Sector Count Sector Mount Directory
>
> 0 0 00 0 4320 4319
>
> 1 3 01 4320 864000 868319
>
> 2 5 01 0 8380800 8380799
>
> 3 0 00 868320 4104000 4972319
>
> 4 0 00 4972320 3408480 8380799
>
> server# iostat -En
>
> <..snip..>
>
> c0t1d0 Soft Errors: 230 Hard Errors: 0 Transport Errors: 0
> Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: 9848310333
> RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>
> Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 230
> Illegal Request: 0 Predictive Failure Analysis: 0
>
> c0t2d0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
> Vendor: IBM Product: DDRS34560SUN4.2G Revision: S98E Serial No: 99285G2252
> RPM: 5400 Heads: 16 Size: 4.29GB <4292075520 bytes>
> Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
> Illegal Request: 0 Predictive Failure Analysis: 0
>
> server# cat onconfig.INSTANCE_0
> #**************************************************************************
> #
> # INFORMIX SOFTWARE, INC.
> #
> # Title: onconfig.ows> # Description: INFORMIX-OnLine Configuration Parameters
> #
> #**************************************************************************
> # Root Dbspace Configuration
> ROOTNAME rootdbs # Root dbspace name> ROOTPATH /INFORMIX_DBSPACE_CHUNK0
> ROOTOFFSET 0 # Offset of root dbspace into device (Kbytes)
> ROOTSIZE 2052000 # Size of root dbspace (Kbytes)> # Disk Mirroring Configuration Parameters
> MIRROR 1 # Mirroring flag (Yes = 1, No = 0)
> MIRRORPATH /.INFORMIX_INSTANCE_0.m0
> MIRROROFFSET 0 # Offset into mirrored device (Kbytes)> # Physical Log Configuration
> PHYSDBS rootdbs # Location (dbspace) of physical log
> PHYSFILE 10000 # Physical log file size (Kbytes)> # Logical Log Configuration
> LOGFILES 20 # Number of logical log files
> LOGSIZE 2000 # Logical log size (Kbytes)> # Diagnostics
> MSGPATH /usr/informix/etc/online.log # System message log file path
> CONSOLE /dev/console # System console message path
> ALARMPROGRAM /tanit/tcl/log_warn/log_full.sh # Alarm program path> # System Archive Tape Device
> TAPEDEV /dev/rmt/0
> TAPEBLK 128 # Tape block size (Kbytes)
> TAPESIZE 4000000 # Maximum amount of data to put on tape (Kbytes)> # Log Archive Tape Device
> LTAPEDEV /dev/rmt/1
> LTAPEBLK 128 # Log tape block size (Kbytes)
> LTAPESIZE 4000000 # Max amount of data to put on log tape (Kbytes)
> # Optical> STAGEBLOB # INFORMIX-OnLine/Optical staging area
> # System Configuration
> SERVERNUM 0 # Unique id corresponding to a OnLine instance
> DBSERVERNAME INSTANCE_0 # Name of default database server> DBSERVERALIASES INSTANCE_0_SHM,INSTANCE_0_TCP # List of alternate
> dbservernames
> NETTYPE ipcstr,1,200,NET
> NETTYPE ipcshm,1,200,CPU
> NETTYPE tlitcp,1,100,NET> # increase tcp connections from 5 to 50. AL 1-mar-00
> # read tasks failed to start correctly, error -25553 in database selection
> # AL 23-nov-01
> # increase again: str 100 -> 200
> # shm 100 -> 200
> # tcp 50 -> 100
> # as a result of error -25560 from read tasks
> DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.> # AL 15-oct-00 change RESIDENT from 0 to 1
> RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
> MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor
> NUMCPUVPS 1 # Number of user (cpu) vps
> SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vps
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape