ISM Startup Errors
Posted in 2003
Topics: Storage & Space Management, Server Administration
Hi, I am Oracle DBA new to Informix. IDS version 9.3 on AIX: 4.3 I was trying to configure ISM. I got it up and running as per the manual last week. Today when I typed "ism_watch" I got an error saying server not available. I couldn't find any nsr deamons. I wanted to re- start the ISM. When I try to start the ISM (as root) I get the following output: ---------------------------------- start_ism: is starting the ISM daemons. *** The environment variable PRINTER is not set. The ISM server cannot print important bootstrap information. To perform a full ISM recovery, e.g. from a disk failure, use 'ism_catalog -find_bootstrap'. ism_startup: Initializing the ISM server. create failed: A group already exists named 'ISMDiskData' create failed: save set of /dev/null would be specified by two create failed: There is already a `NSR label' with name `ISMDiskData' create failed: There is already a `NSR pool' with name `ISMDiskData' create failed: A group already exists named 'ISMDiskLogs' create failed: save set of /dev/null would be specified by two create failed: There is already a `NSR label' with name `ISMDiskLogs' create failed: There is already a `NSR pool' with name `ISMDiskLogs' create failed: A group already exists named 'ISMData' create failed: save set of /dev/null would be specified by two create failed: There is already a `NSR label' with name `ISMData' create failed: There is already a `NSR pool' with name `ISMData' create failed: A group already exists named 'ISMLogs' create failed: save set of /dev/null would be specified by two create failed: There is already a `NSR label' with name `ISMLogs' create failed: There is already a `NSR pool' with name `ISMLogs Clone' create failed: A policy already exists with name '6 Months' ---------------------------------------------------- Can I ignore these Messages? Also, When I try to run the following steps, ----------------- ism_add -device $SM_DISKDEV1 -type file ism_add -device $SM_DISKDEV2 -type file ism_op -label $SM_DISKDEV1 -pool ISMDiskData -volume ISMData ism_op -label $SM_DISKDEV1 -pool ISMDiskLogs -volume ISMLogs ism_op -mount $SM_DISKDEV1 ism_op -mount $SM_DISKDEV2 ------------------------------- I get a message saying that ---------------------- Tue 17:56:52 /fs/backup/dbqa/dbspaces duplicate name; pick new name or delete --------------- I unmounted the device and I still get the error. Can someone tell what I am doing wrong or everything is fine??? Thanks, Sree -- Posted via http://dbforums.com
sree_oradba wrote: > Hi, > > > > I am Oracle DBA new to Informix. IDS version 9.3 on AIX: 4.3 > > > > I was trying to configure ISM. I got it up and running as per the > manual last week. Today when I typed "ism_watch" I got an error saying > server not available. I couldn't find any nsr deamons. I wanted to re- > start the ISM. When I try to start the ISM (as root) I get the > following output: > > > > ---------------------------------- > > start_ism: is starting the ISM daemons. > > > > *** The environment variable PRINTER is not set. > > The ISM server cannot print important bootstrap information. > > To perform a full ISM recovery, e.g. from a disk failure, use > > 'ism_catalog -find_bootstrap'. > > > > ism_startup: Initializing the ISM server. > > create failed: A group already exists named 'ISMDiskData' > > create failed: save set of /dev/null would be specified by two > > create failed: There is already a `NSR label' with name `ISMDiskData' > > create failed: There is already a `NSR pool' with name `ISMDiskData' > > create failed: A group already exists named 'ISMDiskLogs' > > create failed: save set of /dev/null would be specified by two > > create failed: There is already a `NSR label' with name `ISMDiskLogs' > > create failed: There is already a `NSR pool' with name `ISMDiskLogs' > > create failed: A group already exists named 'ISMData' > > create failed: save set of /dev/null would be specified by two > > create failed: There is already a `NSR label' with name `ISMData' > > create failed: There is already a `NSR pool' with name `ISMData' > > create failed: A group already exists named 'ISMLogs' > > create failed: save set of /dev/null would be specified by two > > create failed: There is already a `NSR label' with name `ISMLogs' > > create failed: There is already a `NSR pool' with name `ISMLogs Clone' > > create failed: A policy already exists with name '6 Months' > > ---------------------------------------------------- > > Can I ignore these Messages? > > Also, When I try to run the following steps, > > ----------------- > > ism_add -device $SM_DISKDEV1 -type file > > ism_add -device $SM_DISKDEV2 -type file > > ism_op -label $SM_DISKDEV1 -pool ISMDiskData -volume ISMData > > ism_op -label $SM_DISKDEV1 -pool ISMDiskLogs -volume ISMLogs > > ism_op -mount $SM_DISKDEV1 > > ism_op -mount $SM_DISKDEV2 > > ------------------------------- > > I get a message saying that > > ---------------------- > > Tue 17:56:52 /fs/backup/dbqa/dbspaces duplicate name; pick new > name or delete > > --------------- > > I unmounted the device and I still get the error. > > > > Can someone tell what I am doing wrong or everything is fine??? > > > > Thanks, > > Sree > > > -- > Posted via http://dbforums.com Sounds like you are doing an ism_startup -init. You only need to do the -init to do the first initialisation, afterwards use ism_startup. The ism daemon is coming along and trying to add NSRLabel and NSRPools which already exist. Use ism_show -volumes and ism__show -volume "volume_name" to confirm what you have actually got in ISM.
> I was trying to configure ISM. I got it up and running as per the > manual last week. Today when I typed "ism_watch" I got an error saying > server not available. I couldn't find any nsr deamons. I wanted to re- > start the ISM. When I try to start the ISM (as root) I get the > following output: > > start_ism: is starting the ISM daemons. > *** The environment variable PRINTER is not set. > ism_startup: Initializing the ISM server. > create failed: A group already exists named 'ISMDiskData' DELETED > Can I ignore these Messages? The first error about the printer var is one you can ignore if you don't want a printout of the bootstrap (if you have this printout it could save you much time when you are restoring) The other errors indicate that you start ism with the -init flag, this flag is only needed the first time that you start ism, or when you want to re-initialize it. So just start it without flags. > Also, When I try to run the following steps, > ism_add -device $SM_DISKDEV1 -type file > ism_add -device $SM_DISKDEV2 -type file > ism_op -label $SM_DISKDEV1 -pool ISMDiskData -volume ISMData > ism_op -label $SM_DISKDEV1 -pool ISMDiskLogs -volume ISMLogs > ism_op -mount $SM_DISKDEV1 > I get a message saying that > Tue 17:56:52 /fs/backup/dbqa/dbspaces duplicate name; pick new > name or delete > > --------------- > > I unmounted the device and I still get the error. Here you try to add a device wich is already there, nothing to do with mounting. Please read backup guide.... Ronald