running out of Unix Shared memory segments
Posted in 1999
Topics: General Discussion
I have got a couple of queries . [We are currently running Informix version 7.11 on Digital Unix. ] 1. Frequently the following error message gets logged to the informix online.log : shmat: [EMFILE] [24]: out of shared memory segments, check system SHMSEG. Whenever we get this kind of error message the machine either tends to slow down extremely or freeze up. We are then forced to re initialize Informix . Can anyone give me a suggestion as to how to avoid this kind of errors or how to set up SHMSEG ? 2. Also we tend to get the following error message frequently while running any Unix Shell scripts : " out of swap space" . Any suggestions on this ? 3. Ours is basically a telecom set up and we connect to Unix / informix thro' a T1 connection . Whenever the machine freezes up, we are denied login to the unix box. Whenever this happens no errors are logged onto the informix online.log. Is there any way to know whether its unix or Informix at fault for the freeze up ? Any help would be appreciated. Jim
Your company seems to have a worrying lack of UNIX administration expertise. Both of the errors you report below are basic admin issues, and fundamental detriments to the effective running of your system. The second in particular is likely to adversely affect ANY application on your UNIX server. You will find information on recommened shared memory segment settings in the release notes that came on the Informix media. Ask your UNIX admin to configure more shared memory segments and more swap space. If he or she doesn't know how to do this, get a contractor, quick! Neil Truby Londis Stores Hampton Hill, UK Seepz wrote in message <19990601204105.05561.00003800@ng-cn1.aol.com>... >I have got a couple of queries . >[We are currently running Informix version 7.11 on Digital Unix. ] > >1. Frequently the following error message gets logged to the informix >online.log : >shmat: [EMFILE] [24]: out of shared memory segments, check system SHMSEG. >Whenever we get this kind of error message the machine either tends to slow >down extremely or freeze up. We are then forced to re initialize Informix . >Can anyone give me a suggestion as to how to avoid this kind of errors or how >to set up SHMSEG ? > >2. Also we tend to get the following error message frequently while running any >Unix Shell scripts : " out of swap space" . Any suggestions on this ? > >3. Ours is basically a telecom set up and we connect to Unix / informix thro' a >T1 connection . Whenever the machine freezes up, we are denied login to the >unix box. Whenever this happens no errors are logged onto the informix >online.log. Is there any way to know whether its unix or Informix at fault for >the freeze up ? > >Any help would be appreciated. >Jim
Jim,
Regarding your first question: SHMSEG is a UNIX kernel parameter. Check,
or ask your system administrator to check the value for this parameter that
is currently set on your machine. Compare this with the recommendation in
your release notes ($INFORMIXDIR/release/en_us/0333/ONLINEx.x). While
you're at it, you may wish to compare the values of the other kernel
parameters listed in those release notes.
In addition, you may wish to monitor your shared memory segments using
onstat -g seg. If you notice that large queries or other operations arecreating several memory segments, and then leaving them empty, you can clear
the empty memory segments using onmode -F. Hope some of this helps.
Kind regards,
John Bejarano.
Seepz wrote in message <19990601204105.05561.00003800@ng-cn1.aol.com>...
>I have got a couple of queries .
>[We are currently running Informix version 7.11 on Digital Unix. ]
>
>1. Frequently the following error message gets logged to the informix
>online.log :
>shmat: [EMFILE] [24]: out of shared memory segments, check system SHMSEG.
>Whenever we get this kind of error message the machine either tends to
slow
>down extremely or freeze up. We are then forced to re initialize Informix .
>Can anyone give me a suggestion as to how to avoid this kind of errors or
how
>to set up SHMSEG ?
>
>Jim
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g