Re: Informix OnLine 7.2 for WinNT4.0 BIG Problem
Posted in 1997
On 05/14/96 Steve DeLong wrote:
} I am in the process of setting up an Informix OnLine database server
} running on Windows NT 4.0. I installed ESQL/C (which I'll be using to
} code for the server), then I installed Informix OnLine 7.2.
} Role-separation was enabled, and everything was installed as the
} Administrator account (which Informix assures me is the proper way to do
} it). SetNet32 was run, using the defaults
} in most of the cases (except for naming the dbserver and the sqlhosts
} machine,
} which as far as I can tell, were both done correctly). Anyone who could
} be using the server was made a member of the ix_users group, and the
} services (Message and Database Servers) were set to automatic (database
} was started
} by the informix user rather than the system).
}
} Now, after all that (to set the stage, since everytime I've managed to
} get in touch with Informix, they asked me all that), whenever I access
} the database
} locally though DBAccess, I can fiddle with it just fine, everything does
} what it's
} supposed to do. However, whenever I write a program using the ESQL/C
} preprocessor to do even simple things (connect, make a table, populate
} it with
} one row, and exit), I get error -25571 (cannot create user thread) every
} time.
} I tried changing the ONCONFIG file so that it specified the number of
} threads
} rather than letting it default (but even if it defaults, it defaults to
} 50!).
}
} I'm really stumped here, and I can't get any further on the project I'm
} working
} on until I can make my programs interact with the database. If anyone
} can
} come up with something to help me out, I'd be VERY thankful.
}
} Thanks in advance,
} Steve DeLong
} katt@vt.edu
}
Steve,
I have seen error -25571 (cannot create user thread) after upgrading from
ODS 7.12.TC1 to ODS 7.20.TE1 on Windows NT 3.51. It seemed to be caused by
NOT allowing the setup.exe for ODS to initialize the rootdbs dbspace during
product installation.
I did not want to initialize the rootdbs dbspace because there were already
several existing databases there. No matter how I tried to do it, I could
either not get shared memory to initialize; or if I did get shared memory to
initialize I could not access the engine (using OnMonitor, DBAccess, or
onstat from the Command Line Utilities window) without error -25571 stopping
me.
I eventually found a way to solve the problem. I ran the "Uninstall" for
the ODS product removing everything (especially the registry entries),
rebooted my machine, re-installed the product and allowed the installation
to initialize my rootdbs dbspace, and then used dbimport to recover the
databases from a dbexport I made just before the upgrade. I haven't seen
error -25571 since then.
I see from your post that you are using Windows NT 4.0 while I experienced
my problems on NT 3.51, so this might not help you.
I do not know for sure what the problem was, but I suspect that the setup.exe
might be setting something in the registry AFTER it initializes both rootdbs
and shared memory for the first time. If this registry entry does not get
set (or does not get set correctly), error -25571 seems to result.
--
Regards,
Walter S. Tyszka (wstyszka@ingr.com) * Standard disclaimers apply *