Error messages in log
Posted in 2010
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Platform-Specific Issues
Hi !
I have just upgraded to 11.50.FC6 on HP-UX 11.31 Itanium.
I get a lot of the following messages in the online log:
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -206 The specified
table (mon_ssqltrace) is not in the
database.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -111 ISAM error: norecord
found.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -310 Table
(informix.mon_syssqltrace_info) already exists in
database.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -111 ISAM error: norecord
found.
Seems that is has to do with the sqltrace function, I have the
possibilty to view sql history in OAT.
Does anybody know what these messages mean and what to do about them ?
Regards
Ulf
Ulf,
I think that you can just rebuild the sysadmin database. See the admin guide for the proper steps to do that. Think that the scripts are in $INFORMIXDIR/etc/sysadmin/
drwxrwxr-x 3 informix informix 256 Jan 23 2009 .
drwxrwxr-x 4 informix informix 4096 Nov 19 05:26 ..
drwxrwxr-x 2 informix informix 256 Jun 25 2009 conv
-rw-r--r-- 1 informix informix 976 Apr 30 2009 db_create.sql
-rw-r--r-- 1 informix informix 20390 Apr 30 2009 db_install.sql
-rw-r--r-- 1 informix informix 1087 Apr 30 2009 db_uninstall.sql
-rw-r--r-- 1 informix informix 50616 Apr 30 2009 sch_aus.sql
-rw-r--r-- 1 informix informix 808 Apr 30 2009 sch_sqlcap.sql
-rw-r--r-- 1 informix informix 26294 Apr 30 2009 sch_tasks.sql
-rw-r--r-- 1 informix informix 1031 Apr 30 2009 start.sql
________________________________
From: informix-list-bounces@iiug.org [informix-list-bounces@iiug.org] On Behalf Of Ulf [ulf.akerberg@gmail.com]
Sent: Thursday, January 07, 2010 7:44 AM
To: informix-list@iiug.org
Subject: Error messages in log
Hi !
I have just upgraded to 11.50.FC6 on HP-UX 11.31 Itanium.
I get a lot of the following messages in the online log:
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -206 The specified
table (mon_ssqltrace) is not in the
database.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -111 ISAM error: norecord
found.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -310 Table
(informix.mon_syssqltrace_info) already exists in
database.
14:15:01 SCHAPI: [Save SQL Trace 20-149] Error -111 ISAM error: norecord
found.
Seems that is has to do with the sqltrace function, I have the
possibilty to view sql history in OAT.
Does anybody know what these messages mean and what to do about them ?
Regards
Ulf
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
I think that I have found the error. When comparing with a sysadmin database in a working instance of 11.50.XC6 I noticed that a number of tables where missing in the failing instanse. I created the tables in the failing instance and the problem seems to be solved. I also found that the function "sql_showsnap" is supposed to create these tables but as the function is constructed it will fail to do so in same cases. The instance that was correct is upgraded from FC5 to FC6, the one that had the problem was installed with FC6 from the beginning I anyone else get this probkem look in the function "sql_showsnap" and you will find the tables that you need to create