Re: Informix -753 error message
Posted in 1995
The solution to your problem is as follows: In a single-user version,
there is a hidden file in the $INFORMIXDIR/etc dir called .onuser
It's been quite a while since I've worked with the single user version,
so my spelling of the filename may be alittle off. When you access the
database, the username goes in this file. Then if anyone else tries to
access Informix, they get a -753 error. Since a user gets about 5
processes in a single user environment, the original user can continue
to connect to the database engine. When the user exits the database
a null is put in this file in the first character of the username. Now
a new user can log in. If for any reason the first user doesn't exit
properly, the .onuser file is not updated correctly and becomes
corrupted, causing everyone else to continue to get 753 errors. Even
if the original user logs in and then out, the only way I found to
fix the problem was to switch to user informix and edit the file.
Using vi I deleted the file until it was empty (there was a blank line
as well as the username line in the file). Everything worked fine
after this. I know this is a long narrative, but I felt the back-
ground was necessary. I hope this helps!
Tracy W. Nedd
National Weather Service - DBA
vball@skipper.ssmc.noaa.gov
} We have a single-user version of informix
} (not including root), and have been having
} different users accessing the informix at different
} times. One day the system replied -753 when a user
} "informix" attempted to select one of the databses.
} Since I am each user, I know that there is actually
} just the user getting the -753 error message. ie
} there are no other users using the system when this
} error message is received by "informix", or whatever
} other user happens to be selecting a database. The
} -753 error message even occurs when the user accessing
} the database owns the database and most of the tables
} in it. NOTE: root does not get this error. All the
} users were dba privileged when the error started
} occurring, and the user receiving the error message
} was in fact the only user using the system. The users
} "root" and "informix" now have dba, while the other users
} only have connect (including user "public").
} While it is possible to run our software under user
} "root", this is inconvenient, and we know that it
} used to be possible to have other users accessing the
} database.
}
} Hardware is HP Netserver, running latest(?) SCO unix
} system V, version 3.something, We have Informix ESQL,
} ONLINE engine. The problem usually manifests itself in
} dbaccess.
}
} Sincerely yours,
}
} Joseph R. Kerlin
}
} Transportation Management Solutions, Inc.
}
} [12~
}