J. David Schronce writes:
|> I'm getting an occasional error -154, DEADLOCK TIMEOUT on our HP 9000 800
|> G30, running Online 5.01. The docs mention that this is related tp
|> client/server applications, but we are running straight old dumb
|> terminals, and the only network connection is an NSF mount to my
|> workstation.
At least in earlier 5.** versions, this error can also be returned if you
use lock waits with a timeout, and the timeout has expired. For example
set lock mode to wait 5;
will wait 5 seconds for a lock, then return an error for the given sql
statement. -154 was being returned in this case.
Dave
Disclaimer: The opinions expressed in this message are not those of Informix
Software, its partners or lackeys. Anyone who says otherwise is itching for
a fight.
****************************************************************************
"I look back with some satisfaction on what an idiot I was when I was 25,
but when I do that, I'm assuming I'm no longer an idiot." - Andy Rooney