Basic trouble on ER - primary/target based
Posted in 2008
Topics: General Discussion
Hello! I have made a primary/target ER on IDS 11.50.FC2, for testing purposes. My groups are named g_primary and g_target. I started the 2 servers just fine. Then I created 2 replicates, based on a "select * from" statement. When I activate the replicate, my problem is: on server g_primary, it appears as REPLICATE: rep_uf STATE: Active ON:g_primary but on the g_target server, it appears as: REPLICATE: rep_daems STATE: Inactive ON:g_target do I need to start the replicate also on g_target server? I´ve even tryed it, executing the command on the g_primary server: cdr start repl -c g_target -S g_primary rep_uf g_target but it raises the error: command failed -- request denied on limited server (75) I actually need to syncronize the two replicates, and the command cdr check repl -R -m g_primary -r rep_uf g_target returned the "SYNC:Replicate rep_uf is not active" message. If someone could help me, thanks a lot!!!
ids-bounces@iiug.org wrote on 12/19/2008 09:51:26 AM: > [image removed] > > Basic trouble on ER - primary/target based [14380]> > > ALEXANDRE MARINI > > to: > > ids > > 12/19/2008 09:53 AM > > Sent by: > > ids-bounces@iiug.org > > Please respond to ids > > Hello! > I have made a primary/target ER on IDS 11.50.FC2, for testing purpose= s. > My groups are named g_primary and g_target. I started the 2 servers > just fine. > Then I created 2 replicates, based on a "select * from" statement. > When I activate the replicate, my problem is: > on server g_primary, it appears as > REPLICATE: rep_uf > STATE: Active ON:g_primary > but on the g_target server, it appears as: > REPLICATE: rep_daems > STATE: Inactive ON:g_target > do I need to start the replicate also on g_target server? No, check the primary and target server log for any errors when you defined/started replicate. You could also look at the error table via 'cdr error' command to see i= f any thing went wrong. while defining/starting replicate. > I=B4ve even tryed it, executing the command on the g_primary server: > cdr start repl -c g_target -S g_primary rep_uf g_target > but it raises the error: command failed -- request denied on limited server > (75) > I actually need to syncronize the two replicates, and the command > cdr check repl -R -m g_primary -r rep_uf g_target > returned the "SYNC:Replicate rep_uf is not active" message. > > If someone could help me, thanks a lot!!! > > > ***********************************************************************= ******** > Forum Note: Use "Reply" to post a response in the discussion forum.= >=
2008/12/19 ALEXANDRE MARINI <amarini@fazenda.ms.gov.br>:
> Hello!
> I have made a primary/target ER on IDS 11.50.FC2, for testing purposes.
> My groups are named g_primary and g_target. I started the 2 servers just
fine.
> Then I created 2 replicates, based on a "select * from" statement.
> When I activate the replicate, my problem is:
> on server g_primary, it appears as
> REPLICATE: rep_uf
> STATE: Active ON:g_primary
> but on the g_target server, it appears as:
> REPLICATE: rep_daems
> STATE: Inactive ON:g_target
> do I need to start the replicate also on g_target server?
> I´ve even tryed it, executing the command on the g_primary server:
> cdr start repl -c g_target -S g_primary rep_uf g_target
> but it raises the error: command failed -- request denied on limited server
> (75)
> I actually need to syncronize the two replicates, and the command
> cdr check repl -R -m g_primary -r rep_uf g_target
> returned the "SYNC:Replicate rep_uf is not active" message.
>
> If someone could help me, thanks a lot!!!
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
Alexandre
Start from first principles. Can you connect to the instance on
g_target from a dbaccess session on g_primary and access tables and
data, and then vice versa (or even the other way round !).
Does cdr list serv on both machines show both machines?
Were there any errors on either machine whaen you created the
replicate, what command was used?
Does cdr list repl return identical results from both machines?
onstat -g ddr, onstat -g rqm BRIEF on g.primary and onstat -g dss on
g.target might help.
Keith
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g