Informix Chunk Offline (IDS 7 on Windows 2000)
Posted in 2012
Topics: Storage & Space Management, Error Codes & Troubleshooting
hi all, one of our informix servers starting abnormally. the services on Widows starts ok but with no access to the database. one of the chunks seem to be offiline.. please find the errors below for your advice : =============== 18:15:29 DR: DRAUTO is 0 (Off) 18:17:01 IBM Informix Dynamic Server Version 7.31.TD8 Software Serial Number AAC#J993468 18:17:05 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized. 18:17:05 Physical Recovery Started. 18:17:05 Physical Recovery Complete: 1 Pages Restored. 18:17:05 Logical Recovery Started. 18:17:08 Logical Recovery Complete. 1 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks 18:17:09 Dataskip is now OFF for all dbspaces 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2dac706c, errno = 3 18:17:09 fildes = 1056 (gfd 7), buf = 2e001000, nbytes = 4096, offset = 1903558656 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2d9a886c, errno = 3 18:17:09 fildes = 1056 (gfd 7), buf = d8e9000, nbytes = 4096, offset = 1903587328 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2d99d448, errno = 3 18:17:09 fildes = 1056 (gfd 7), buf = d8fb000, nbytes = 4096, offset = 1903558656 18:17:09 Assert Failed: I/O error, Primary Chunk 'e:\\ifmxdata \\ol_ccbsrv\\datadbs_dat.002' -- Offline 18:17:09 IBM Informix Dynamic Server Version 7.31.TD8 18:17:09 Who: Thread(43, flush_sub(2), 0, 3) File: \\tristarm\\rsam\\rsbuff.c Line: 4175 18:17:09 Results: Chunk is now unusable 18:17:09 Action: Repair and restore from mirror or archive 18:17:12 Releasing server from system block 18:17:16 See Also: af.4130125 18:17:16 I/O error, Primary Chunk 'e:\\ifmxdata\\ol_ccbsrv\\datadbs_dat. 002' -- Offline 18:17:17 Assert Failed: Chunk 6 is being taken OFFLINE. 18:17:17 IBM Informix Dynamic Server Version 7.31.TD8 18:17:17 Who: Thread(43, flush_sub(2), 0, 3) File: \\tristarm\\rsam\\rsmirror.c Line: 1740 18:17:17 Results: Dynamic Server must abort 18:17:17 Action: Reinitialize shared memory 18:17:23 See Also: af.4130125 18:17:23 Chunk 6 is being taken OFFLINE. 18:17:24 Assert Failed: INFORMIX-OnLine Must ABORT Critical media failure. 18:17:24 IBM Informix Dynamic Server Version 7.31.TD8 18:17:24 Who: Thread(43, flush_sub(2), 0, 3) File: \\tristarm\\rsam\\rsmirror.c Line: 1744 18:17:30 See Also: af.4130125 18:17:30 \\tristarm\\rsam\\rsmirror.c, line 1744, thread 43, proc id 1360, INFORMIX-OnLine Must ABORT Critical media failure.. 18:17:30 PANIC: Attempting to bring system down ===============
I would check e:\\ifmxdata\\ol_ccbsrv\\datadbs_dat.002 if the engine is offline and it seems to be, try and copy it, if the os reports an error you need to fix that first. When it is repaired you may be lucky that it starts otherwise it is a restore. i would contact IBM informix TS Superboer. On 26 jan, 01:20, Omar Gassama <okgass...@gmail.com> wrote: > hi all, > one of our informix servers starting abnormally. the services on > Widows starts ok but with no access to the database. one of the chunks > seem to be offiline.. please find the errors below for your advice : > > =============== > 18:15:29 DR: DRAUTO is 0 (Off) > 18:17:01 IBM Informix Dynamic Server Version 7.31.TD8 Software > Serial Number AAC#J993468 > 18:17:05 IBM Informix Dynamic Server Initialized -- Shared Memory > Initialized. > 18:17:05 Physical Recovery Started. > 18:17:05 Physical Recovery Complete: 1 Pages Restored. > 18:17:05 Logical Recovery Started. > 18:17:08 Logical Recovery Complete. > > 1 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks > > 18:17:09 Dataskip is now OFF for all dbspaces > 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2dac706c, errno = 3 > 18:17:09 fildes = 1056 (gfd 7), buf = 2e001000, nbytes = 4096, offset > = 1903558656 > 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2d9a886c, errno = 3 > 18:17:09 fildes = 1056 (gfd 7), buf = d8e9000, nbytes = 4096, offset > = 1903587328 > 18:17:09 KAIO: error in kaio_WRITE, kaiocbp = 2d99d448, errno = 3 > 18:17:09 fildes = 1056 (gfd 7), buf = d8fb000, nbytes = 4096, offset > = 1903558656 > 18:17:09 Assert Failed: I/O error, Primary Chunk 'e:\\ifmxdata > \\ol_ccbsrv\\datadbs_dat.002' -- Offline > 18:17:09 IBM Informix Dynamic Server Version 7.31.TD8 > 18:17:09 Who: Thread(43, flush_sub(2), 0, 3) > > File: \\tristarm\\rsam\\rsbuff.c Line: 4175 > 18:17:09 Results: Chunk is now unusable > 18:17:09 Action: Repair and restore from mirror or archive > 18:17:12 Releasing server from system block > 18:17:16 See Also: af.4130125 > 18:17:16 I/O error, Primary Chunk 'e:\\ifmxdata\\ol_ccbsrv\\datadbs_dat. > 002' -- Offline > 18:17:17 Assert Failed: Chunk 6 is being taken OFFLINE. > 18:17:17 IBM Informix Dynamic Server Version 7.31.TD8 > 18:17:17 Who: Thread(43, flush_sub(2), 0, 3) > > File: \\tristarm\\rsam\\rsmirror.c Line: 1740 > 18:17:17 Results: Dynamic Server must abort > 18:17:17 Action: Reinitialize shared memory > 18:17:23 See Also: af.4130125 > 18:17:23 Chunk 6 is being taken OFFLINE. > 18:17:24 Assert Failed: INFORMIX-OnLine Must ABORT > > Critical media failure. > 18:17:24 IBM Informix Dynamic Server Version 7.31.TD8 > 18:17:24 Who: Thread(43, flush_sub(2), 0, 3) > > File: \\tristarm\\rsam\\rsmirror.c Line: 1744 > 18:17:30 See Also: af.4130125 > 18:17:30 \\tristarm\\rsam\\rsmirror.c, line 1744, thread 43, proc id > 1360, INFORMIX-OnLine Must ABORT > > Critical media failure.. > 18:17:30 PANIC: Attempting to bring system down > > ===============