Column size too large
Posted in 2004
Topics: Server Administration
Hi, all
I'm using Informix Dynamic Server Version 9.40.UC2 and when i run a
query in dbaccess, i get this error: -361 Column size too large
My query returns some fields and one is a char(4096).
When I use cast in this field for char(3000), the query works.
Someone know something about this error?
tks in advance
On Mon, 23 Aug 2004 08:30:15 -0400, Wellidy Almeida wrote:
Apparently a limitation in dbaccess. Try using Jonathan Leffler's sqlcmd,
available for download from the IIUG Software Repository.
Art S. Kagel
> Hi, all
>
> I'''m using Informix Dynamic Server Version 9.40.UC2 and when i run a query in
> dbaccess, i get this error: -361 Column size too large
>
> My query returns some fields and one is a char(4096). When I use cast in
> this field for char(3000), the query works.
>
> Someone know something about this error?
>
> tks in advance
Wellidy Almeida wrote:
> Hi, all
>
> I'm using Informix Dynamic Server Version 9.40.UC2 and when i run a
> query in dbaccess, i get this error: -361 Column size too large
>
> My query returns some fields and one is a char(4096).
> When I use cast in this field for char(3000), the query works.
>
> Someone know something about this error?
A column that large (char(4096)) works just fine with IDS 9.40.FC2 on AIX
5.2.0.0. A 'finderr 361' returns the following:
This internal error reflects a communications problem between the database
server and the application. You should not see this error. If the error
recurs, please note all circumstances and contact Technical Support at
tsmail@us.ibm.com.
Have you had a chance to contact Tech Support yet?
--
June Hunt
On Mon, 23 Aug 2004 13:09:07 -0400, June C. Hunt wrote:
Turns out the problem was the default fetch/communication buffer is only 4K.
I suggested that Wellidy set FETBUFSIZE=32767 as an initial test and that did
the trick. Now for efficiency and performance, an ideal buffer size will
have to be found.
Art S. Kagel
> Wellidy Almeida wrote:
>> Hi, all
>>
>> I'''m using Informix Dynamic Server Version 9.40.UC2 and when i run a query
>> in dbaccess, i get this error: -361 Column size too large
>>
>> My query returns some fields and one is a char(4096). When I use cast in
>> this field for char(3000), the query works.
>>
>> Someone know something about this error?
>
> A column that large (char(4096)) works just fine with IDS 9.40.FC2 on AIX
> 5.2.0.0. A 'finderr 361' returns the following:
>
> This internal error reflects a communications problem between the database
> server and the application. You should not see this error. If the error
> recurs, please note all circumstances and contact Technical Support at
> tsmail@us.ibm.com.
>
> Have you had a chance to contact Tech Support yet?
>
> --
> June Hunt
Related threads
- IDS - How to find users in a database
- Can't compile SQLCMD
- IDS 9.4 - LOAD in SPL
- SPL - passing an argument of 'DATETIME' type
- ontape