oncheck -ce
Posted in 2004
Hi guys,
Well before I would like to thanks all people who helped me. THX a
lot.
I know that it is a little bit late cause the following message -see
below- is dated from 1998 but only the result is important !!!
FYI, You should his message at the following URL
:http://groups.google.fr/groups?q=informix+%22Unable+to+check+index+for+table%22&hl=fr&lr=&selm=7128mq%24ipq%241%40nnrp1.dejanews.com&rnum=1
Ok, I had the same error than this guy today and I was unable to
explain why when I did an oncheck -ce I had the following error
message : " unable to check index for table <index name>, partnum 0 is
not accessible ".
Indeed, it is quite normal because it is due to your disabled index.
So in order to fix it you should only enable the corresponding index
like this :
SET INDEXES <nameofyourindexe1,nameofyourindexe2, and so on...>
ENABLED;
And you error messages should disapeared. Try it with oncheck -ce.
Hoping that it will help someone one day.
Anyway have a good day.
Best Regards
Fred H.
>When I run oncheck -pe and capture the output I get the following
>as the first line of output:
>Unable to check index for table msxxprc1, partnum 0 is not accessible
>I remove this (msxxprc1) index and run another oncheck -pe and this
>line goes away. I recreate this index and the line reappears with
>subsequent oncheck -pe outputs.
>The database seems to be running fine and I can successfully query
>the table that this index is built on. How do I clean up this
oncheck -pe>output with this index existing.
>Thanks for any help.
>Frank Testa
>Manager of DBA
>Columbia House