can't reuse connection after error -908 or -930?
Posted in 2003
Hi, I have been struggling for [a loooong time !] with a problem trying to get our asp code to "move on" to the "next" ODBC connection after the "previous" connection attempt fails with native error -908 or -930. Why is "z.opt.com" listed in the error code in A3,B3,and D3, below when the DSN passed to the Open() method is "optqa1", which should result in a value of 'qa1.opt.com'(see Test Cases and Existing ODBC Datasource below)? THANKS SO MUCH FOR YOUR HELP, Nate TEST CASE: A) Step ADODB.Open(?) Did DSN open? Comments ---- ------------ ------------- ------------------------ 1) bevmo Yes Try next DSN... 2) webdev No Try next DSN... 3) optqa1 *No *The caught error is: [Informix][Informix ODBC Driver][Informix]Cannot connect to database server (z.opt.com). <--WHY z.opt.com ??? TEST CASE: B) Step ADODB.Open(?) Did DSN open? Comments ------ ------------- ------------- ------------------------ 1) optqa1 Yes Try next DSN... 2) webdev No Try next DSN... 3) optqa1 *No *The caught error is: [Informix][Informix ODBC Driver][Informix]Cannot connect to database server (z.opt.com). <--WHY z.opt.com ??? TEST CASE: C) Step ADODB.Open(?) Did DSN open? Comments ---- ------------- ------------- ------------------------ 1) webdev No Try next DSN... 2) webdev No Try next DSN... 3) optqa1 Yes TEST CASE: D) Step ADODB.Open(?) Did DSN open? Comments ---- ------------ ------------- ------------------------ 1) webdev No Try next DSN... 2) optqa1 Yes Try next DSN... 3) webdev No Try next DSN... 4) optqa1 *No *The caught error is: [Informix][Informix ODBC Driver][Informix]Cannot connect to database server (z.opt.com). <--WHY z.opt.com ??? Existing INFORMIX ODBC Datasources On My System (all Using INFORMIX 3.80 32 BIT ODBC driver - I also have the 3.34 & 3.82 drivers installed, but no ODBC Datasources setup for these) --------------------------------------------------------------------------------a) webdev (incorrect ODBC connection to mimic a database or network failure) Server Name: pretend_webdev_server Host Name: z.opt.com (DELIBERATELY false to mimic Informix database failure without actually stopping Informix: other developers are also using the database !!) Service: 1234 (DELIBERATELY false) Protocol: olsoctcp Database Name: eps User ID: (not shown) Password: (not shown) b) optqa1 (1 of 2 separate database instances running on qa1.opt.com) Server Name: epsqa1 Host Name: qa1.opt.com (altered here, to protect my company!) Service: 5821 Protocol: olsoctcp Database Name: eps User ID: (not shown) Password: (not shown) c) bevmo (2 of 2 separate database instances running on qa1.opt.com) Server Name: epsqa1 Host Name: qa1.opt.com (altered here, to protect my company!) Service: 5821 Protocol: olsoctcp Database Name: bevmo User ID: (not shown) Password: (not shown)