Memory down and shared memory not initialized
Posted in 2012
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
I compiled utils2_ak. When executing printFreeB I got a message the library
libifsql.so could not be found. So I put the lines below in /etc/ld.so.conf
and exectued ldconfig.
/opt/informix/lib
/opt/informix/lib/c++
/opt/informix/lib/cli
/opt/informix/lib/csm
/opt/informix/lib/dmi
/opt/informix/lib/esql
/opt/informix/lib/client
/opt/informix/lib/client/csm
After this action, fprintFreeB ran but with the error '25588: cannot connect
to the database'.
And now when I run oncheck or other commandline utilities I get the error:
shared memory not initialized for INFORMIXSERVER 'abba6'
Error writing to network
Abnormal end !!!
onstat - gives status online:
IBM Informix Dynamic Server Version 11.10.FC3 -- On-Line -- Up 158 days
20:06:08 -- 7383472 Kbyte
Only connections through shared memory fail, the onsoctcp connections succeed.
Is this problem a consequence of the ldconfig I executed? And how could I fix
this?
You only need $INFORMIXDIR/lib/esql & $INFORMIXDIR/lib in the ld..so.conf
in that order, though I usually just place those paths into the
LD_LIBRARY_PATH environment variable instead of running ldconfig. Fixing
this should repair the shared memory connections. You are just getting the
wrong version of one of the connection libraries.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Mon, Apr 23, 2012 at 3:26 AM, RAPHAëL GODART <raf.godart@gmail.com>wrote:
> I compiled utils2_ak. When executing printFreeB I got a message the library
> libifsql.so could not be found. So I put the lines below in /etc/ld.so.conf
> and exectued ldconfig.
>
> /opt/informix/lib
> /opt/informix/lib/c++
> /opt/informix/lib/cli
> /opt/informix/lib/csm
> /opt/informix/lib/dmi
> /opt/informix/lib/esql
> /opt/informix/lib/client
> /opt/informix/lib/client/csm
>
> After this action, fprintFreeB ran but with the error '25588: cannot
> connect
> to the database'.
>
> And now when I run oncheck or other commandline utilities I get the error:
>
> shared memory not initialized for INFORMIXSERVER 'abba6'
> Error writing to network
> Abnormal end !!!
>
> onstat - gives status online:
>
> IBM Informix Dynamic Server Version 11.10.FC3 -- On-Line -- Up 158 days
> 20:06:08 -- 7383472 Kbyte>
> Only connections through shared memory fail, the onsoctcp connections
> succeed.
>
> Is this problem a consequence of the ldconfig I executed? And how could I
> fix
> this?
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--14dae9340661ab10e904be586170
Hello, I really appreciate your help with all my problems. Thanks a lot. I however cannot seems to fix the shared memory problem. I've configured $INFORMIXDIR/lib/esql and $INFORMIXDIR/lib in the ld.so.conf and ran ldconfig, but the problem remains. Every commandline tool returns an error (shared memory not set, of network down). What is also strange, the LD_LIBRARY_PATH environment variable was never set on this server. It seems I'm missing some other configuration parameter. I'm out of ideas :(
Open a support case with IBM. Art On Apr 23, 2012 7:36 AM, "RAPHAëL GODART" <raf.godart@gmail.com> wrote: > Hello, > > I really appreciate your help with all my problems. Thanks a lot. I however > cannot seems to fix the shared memory problem. I've configured > $INFORMIXDIR/lib/esql and $INFORMIXDIR/lib in the ld.so.conf and ran > ldconfig, > but the problem remains. Every commandline tool returns an error (shared > memory not set, of network down). > > What is also strange, the LD_LIBRARY_PATH environment variable was never > set > on this server. It seems I'm missing some other configuration parameter. > I'm > out of ideas :( > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --e89a8f3ba75f18c0f504be5a35bf
I cant see why - but to be sure comment them out and run ldconfig again
- does that fix it?
I suspect you have just got the wrong INFORMIXSERVER set
pointing at a network only connection
--
Clive
On 23/04/2012 11:26, RAPHAëL GODART wrote:
> I compiled utils2_ak. When executing printFreeB I got a message the library
> libifsql.so could not be found. So I put the lines below in /etc/ld.so.conf
> and exectued ldconfig.
>
> /opt/informix/lib
> /opt/informix/lib/c++
> /opt/informix/lib/cli
> /opt/informix/lib/csm
> /opt/informix/lib/dmi
> /opt/informix/lib/esql
> /opt/informix/lib/client
> /opt/informix/lib/client/csm
>
> After this action, fprintFreeB ran but with the error '25588: cannot connect
> to the database'.
>
> And now when I run oncheck or other commandline utilities I get the error:
>
> shared memory not initialized for INFORMIXSERVER 'abba6'
> Error writing to network
> Abnormal end !!!
>
> onstat - gives status online:
>
> IBM Informix Dynamic Server Version 11.10.FC3 -- On-Line -- Up 158 days
> 20:06:08 -- 7383472 Kbyte>
> Only connections through shared memory fail, the onsoctcp connections
succeed.
>
> Is this problem a consequence of the ldconfig I executed? And how could I fix
> this?
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>