Re: INF4.1 -1 ERROR ?? problem
Posted in 1992
Rigby writes: > >HELP !!! >We have just started getting a new error which is described nowhere >in the INFORMIX literature (whats new): -1. This happens when we >install our package on UNIX . In one of our package-installation-scripts >we start tbinit and straight afterwards try a drop database in a 4GL >program. This gives us an error -1. > >Any ideas ?? Is it something to do with tbinit not being quite >finished ? Any error code less that 100 are Unix errors that are propagated back to the user. The reason they are undocumented in Informix literature is that they are not necessarily the same across different platforms, so we would have to have the definitions for each platform we support, which could wind up being a lot of dead trees ;-0. Generally, a -1 error means "Not owner." Is the 4gl program executable by the id running the install (presumably root)? Do the permissions on the database allow this user to access it (actually, this user would need dba permission to drop the database)? Dave -- Disclaimer: These opinions are not those of Informix Software, Inc. ************************************************************************** "I look back with some satisfaction on what an idiot I was when I was 25, but when I do that, I'm assuming I'm no longer an idiot." - Andy Rooney