RE: Problem with IDS 11 DataBlades
Posted in 2007
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration, Security, Permissions & Auditing, Platform-Specific Issues
After you set the IFX_EXTEND_ROLE configuration parameter to On, a DBSA
can use the following syntax to grant and revoke privileges to and from
specific users.
GRANT extend To username
REVOKE extend From username
more details -
http://publib.boulder.ibm.com/infocenter/idshelp/v111/index.jsp?topic=/com.ibm.sec.doc/ids_da_008.html
Regards,
-Nilesh
informix-list-bounces@iiug.org wrote on 09/19/2007 03:53:29 PM:
> I ran into the exact same problem registering the spatial datablade
> today. Your answer resolved my problem; IFX_EXTEND_ROLE was set to 1.
> If you find anything more about DB users and the IFX_EXTEMD_ROLE, please
> pass it along.
>
> Thanks for your summary.
>
> Mike
>
> > -----Original Message-----
> > From: informix-list-bounces@iiug.org
> > [mailto:informix-list-bounces@iiug.org] On Behalf Of The Durster
> > Sent: Tuesday, September 18, 2007 1:51 PM
> > To: informix-list@iiug.org
> > Subject: Re: Problem with IDS 11 DataBlades
> >
> > On Sep 18, 3:09 pm, The Durster <seandur...@gmail.com> wrote:
> > > HP-UX 11.23
> > > IDS 11.10.FC1
> > >
> > > I am doing some testing on an IDS 11 instance. I wanted to try the
> > > Node DataBlade out. When I go to blademgr to register it, I have
> > > problems. If I do:
> > > list [databasename]
> > > I get: blademgr: ERROR: Prepare failed in current database.
> > > My message log also says:
> > > 15:01:19 Loading Module <$INFORMIXDIR/extend/ifxmngr/ifxmngr.bld>
> > > 15:01:19 (-9720): ERROR: Loading Module
> > <$INFORMIXDIR/extend/ifxmngr/
> > > ifxmngr.bld>> > >
> > > I have the actual $INFORMIXDIR/extend in my DB_LIBRARY_PATH in my
> > > onconfig. (I also tried using the exact string
> > "$INFORMIXDIR/extend")
> > > In all cases the errors in the message log were the same. I bounced
> > > the instance to make sure that it could notice the changes,
> > if needed.
> > >
> > > I set LD_LIBRARY_PATH and SHLIB_PATH to include
> > $INFORMIXDIR/lib and
> > > $INFORMIXDIR/lib/esql.
> > >
> > > I tried to just go ahead and register the blade, but I get this:
> > > blademgr: ERROR: Prepare failed in current database.
> > > blademgr: ERROR: Couldn't 'prep' database.
> > >
> > > Any ideas?
> >
> > I changed the new IFX_EXTEND_ROLE parameter to 0 and
> > everything was fine. Apparently, when on, it limits who can
> > install extensions (ie DataBlades). I don't know where you
> > set up the proper users, but this should point others who run
> > into this in the right direction.
> >
> > Thanks for the replies off-list. They didn't nail the
> > problem, but I appreciate the quick help.
> >
> > _______________________________________________
> > Informix-list mailing list
> > Informix-list@iiug.org
> > http://www.iiug.org/mailman/listinfo/informix-list
> >
> >
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
On Sep 19, 5:03 pm, Nilesh Ozarkar <nile...@us.ibm.com> wrote:
> After you set the IFX_EXTEND_ROLE configuration parameter to On, a DBSA
> can use the following syntax to grant and revoke privileges to and from
> specific users.
> GRANT extend To username
> REVOKE extend From username>
> more details -http://publib.boulder.ibm.com/infocenter/idshelp/v111/index.jsp?topic...
I will note for the record that blademgr should have a more helpful
response in this situation. Something like "you do not have permission
to register datablades. Check the IFX_EXTEND_ROLE onconfig parameter
and your extend permissions" would be MUCH better than "Prepare failed
in current database." Error 9720 could be updated with more
explanatory text, too.