restore with ontape
Posted in 2004
A user backed up IDS 9.30.FC2 on Solaris 8 (MachineA) to a remote tape drive on MachineB, but restoring with 'ontape -r' on MachineB (running IDS 9.40.FC4 on Solaris 9) failed with "physical restore failed - function read archive backup failed code -1 errno 0". Respondents agreed the cause is that ontape archives can't be restored across different engine versions: the restore must run on the same version. Suggested workarounds were to install 9.3 on MachineB, restore, then upgrade in place to 9.4; or move data via dbexport/dbimport, unload/load (HPL), or CDR replication. No confirmation from the poster that any option worked is recorded.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Backup & Restore
Hi to all;
MachineA 9.3 FC2 --SunOs 5.8
MachineB 9.4 FC4 --SunOs 5.9
We defined MachineA archive tape to be MachineB:/dev/rmt/0.
Although the backup operation ontape s is succeeded the restore operation
ontape r is failed with the following message physical restore failed
function read archive backup failed code -1 errno 0
Can anyone please help
You
cannot do an imported restore with ontape within different versions.
First update your MachineA to version 9.40 or swith B to 9.30.
Best way would be to replicate data using CDR
ADEL Y M AL.... wrote:
>Hi to all;
>
>MachineA 9.3 FC2 --SunOs 5.8
>
>MachineB 9.4 FC4 --SunOs 5.9
>
>We defined MachineA archive tape to be MachineB:/dev/rmt/0.
>
>Although the backup operation ontape s is succeeded the restore operation
ontape r is failed with the following message physical restore failed
function read archive backup failed code -1 errno 0
>
>
>
>Can anyone please help
>
>
>
>
>
Gerd
The IDS
versions must be the same (only small differences
in patch levels are possible sometimes).
Possible solutions:
- Install 9.3FC2 on MachineB, too. Restore. Upgrade to 9.4FC4
- Create new database on MachineB, then use dbexport/dbimport or similar tools
- Stop IDS on MachineA , copy datafiles/rawdevices to MachineB,
Start IDS on MachineB - it should do an DB-upgrade first
(probably this way isn't supported officially)
Regards,
Andreas Kutsche
> -----Ursprüngliche Nachricht-----
> Von: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org]Im
> Auftrag von ADEL Y M AL....
> Gesendet: Dienstag, 23. November 2004 13:40
> An: ids@iiug.org
> Betreff: restore with ontape [3759]
>
>
> Hi to all;
>
> MachineA 9.3 FC2 --SunOs 5.8
>
> MachineB 9.4 FC4 --SunOs 5.9
>
> We defined MachineA archive tape to be MachineB:/dev/rmt/0.
>
> Although the backup operation 'ontape -s' is succeeded the
> restore operation 'ontape -r' is failed with the following
> message "physical restore failed - function read archive
> backup failed code -1 errno 0"
>
>
>
> Can anyone please help...
>
>
>
Adel
It is not possible to take an archive from one version of the engine and
restore to another version, if you archive under 9.3 you must restore to 9.3
(you might just get away with 9.3 FC2 to 9.3 FC3 but I wouldn't risk it!!).
You have three options.
1. Install 9.3 on the second machine, restore into this and then undertake an
'in place' upgrade to 9.4.
2. Dbexport from the first machine and then dbimport into the second.
3. Produce hand-crafted scripts to create the database, tables and indexes and
then unload from the first machine and insert into the second (possibly using
the High Performance Loader).
Depends on what you are trying to do, how much data is involved and whether
you can get exclusive access.
Keith
-----Original Message-----
From: ADEL Y M AL.... [mailto:adel@q8petroleum.com.kw]
Sent: Tuesday, November 23, 2004 12:40
To: ids@iiug.org
Subject: restore with ontape [3759]
Hi to all;
MachineA 9.3 FC2 --SunOs 5.8
MachineB 9.4 FC4 --SunOs 5.9
We defined MachineA archive tape to be MachineB:/dev/rmt/0.
Although the backup operation 'ontape -s' is succeeded the restore operation
'ontape -r' is failed with the following message "physical restore failed -
function read archive backup failed code -1 errno 0"
Can anyone please help...
********************************************************************************
**
This message is sent in strict confidence for the addressee only. It may
contain legally privileged information. The contents are not to be disclosed
to anyone other than the addressee. Unauthorised recipients are requested
to preserve this confidentiality and to advise the sender immediately of any
error in transmission.
This footnote also confirms that this email message has been swept for the
presence of computer viruses, however we cannot guarantee that this message
is free from such problems.
********************************************************************************
**
Folks,
I know that this is going to sound naïve, and I'm probably wrong, but I
don't think that Adel is using the remote machine to back up the database;
rather just to mount the tape drive remotely. If that's the case, the
Informix differences shouldn't matter; but the O/S level differences might
make things interesting...
Adel, can you verify that you're doing what I think you're doing?
Thanks.
Dan Michaelis
Database Administrator/Developer
eOriginal
351 West Camden Street
Suite 800
Baltimore, MD 21201
410.625.5187 (phone)
410.659.9799 (fax)
-----Original Message-----
From: Simmons, Keith [mailto:keith.simmons@office2office.biz]
Sent: Tuesday, November 23, 2004 10:08 AM
To: ids@iiug.org
Subject: RE: restore with ontape [3762]
Adel
It is not possible to take an archive from one version of the engine and
restore to another version, if you archive under 9.3 you must restore to 9.3
(you might just get away with 9.3 FC2 to 9.3 FC3 but I wouldn't risk it!!).
You have three options.
1. Install 9.3 on the second machine, restore into this and then
undertake an 'in place' upgrade to 9.4.
2. Dbexport from the first machine and then dbimport into the second.
3. Produce hand-crafted scripts to create the database, tables and
indexes and then unload from the first machine and insert into the second
(possibly using the High Performance Loader).
Depends on what you are trying to do, how much data is involved and whether
you can get exclusive access.
Keith
-----Original Message-----
From: ADEL Y M AL.... [mailto:adel@q8petroleum.com.kw]
Sent: Tuesday, November 23, 2004 12:40
To: ids@iiug.org
Subject: restore with ontape [3759]
Hi to all;
MachineA 9.3 FC2 --SunOs 5.8
MachineB 9.4 FC4 --SunOs 5.9
We defined MachineA archive tape to be MachineB:/dev/rmt/0.
Although the backup operation 'ontape -s' is succeeded the restore operation
'ontape -r' is failed with the following message "physical restore failed -
function read archive backup failed code -1 errno 0"
Can anyone please help...
****************************************************************************
******
This message is sent in strict confidence for the addressee only. It may
contain legally privileged information. The contents are not to be disclosed
to anyone other than the addressee. Unauthorised recipients are requested
to preserve this confidentiality and to advise the sender immediately of any
error in transmission.
This footnote also confirms that this email message has been swept for the
presence of computer viruses, however we cannot guarantee that this message
is free from such problems.
****************************************************************************
******
Dan,
I don't really understand your point, but what is on the tape is for 9.3
server because when I issue ontape -r from 9.3 server it is explicitly stated
Online version: Informix Dynamic Server Version 9.30.FC2 and I belive this
refer to backup tape.
And as stated in the manual remote backup is allowed in Informix.
Regards...