EVEN MORE URGENT: assertion failure during logical recovery
Posted in 1999
My 3rd attempt to restore ! This time, after successful physical restore, I
allowed the engine to recover its disks from 'I' state to 'O' and then go
into quiescent mode before starting the logical restore (onbar -r -l -t
1999-03-12 15:56:00). The result was "ERROR: Unable to start the logical
restore: There are no DBspaces or BLOBspaces to recover." error in the
onbar logfile. An onstat -d looks ok (see end of this email).
Geoff Poole
Oxford GlycoSciences
geoffrey.poole@ogs.co.uk
INFORMIX-Universal Server Version 9.14.UC2
UNIX Solaris 2.5.1
onbar logfile
1999-03-13 10:24:40 8796 2273 Completed cold level 1 restore sbspace2.
1999-03-13 10:33:50 9047 13821 onbar -r -l -t 1999-03-12 15:56:00
1999-03-13 10:33:51 9047 13821 Begin backup logical log 146.
1999-03-13 10:34:10 9047 13821 Successfully connected to Storage Manager.
1999-03-13 10:35:36 9047 13821 Completed backup logical log 146.
1999-03-13 10:35:36 9047 13821 ERROR: Unable to start the logical restore:
There are no DBspaces or BLOBspaces to recover.
Check the status by using onstat -d..
Informix logfile
10:24:42 Physical Restore of rootdbs, logdbs... Completed.
10:24:42 Checkpoint Completed: duration was 0 seconds.
10:31:55 Physical Recovery Started.
10:31:55 Physical Recovery Complete: 0 Pages Restored.
10:31:55 Logical Recovery Started.
10:31:58 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
10:31:58 Dropping temporary TBLspace 1000c8, recovering 8 pages.
10:31:58 Bringing system to Quiescent Mode with no Logical Restore.
10:31:59 Quiescent Mode
onstat -d
INFORMIX-Universal Server Version 9.14.UC2 -- Quiescent -- Up 02:01:48 --
229928 Kbytes
Dbspaces
address number flags fchunk nchunks flags owner name
10bfc108 1 2 1 1 M informix rootdbs
10bfd980 2 2001 2 1 N T informix tempdbs1
10bfd9f8 3 2001 3 1 N T informix tempdbs2
10bfda70 4 2001 4 1 N T informix tempdbs3
10bfdae8 5 8002 5 1 M S informix sbspace1
10bfdb60 6 8002 6 1 M S informix sbspace2
10bfdbd8 7 1 7 1 N informix livedbs1
10bfdc50 8 1 9 2 N informix livedbs2
10bfdcc8 9 1 11 3 N informix livedbs3
10bfdd40 10 1 13 1 N informix livedbs4
10bfddb8 14 2 18 1 M informix logdbs
10bfde30 15 2 19 1 M informix controldbs
12 active, 2047 maximum
Chunks
address chk/dbs offset size free bpages flags pathname
10bfc180 1 1 0 100000 82926 PO- /ondata/chunk010
10bfc258 1 1 912000 100000 0 MO- /ondata/chunk310
10bfc6f0 2 2 512000 512000 511947 PO- /ondata/chunk211
10bfc7c8 3 3 512000 512000 511947 PO- /ondata/chunk321
10bfc8a0 4 4 0 1024000 1023947 PO- /ondata/chunk021
10bfc978 5 5 0 512000 510697 510697 POS /ondata/chunk320
10bfd620 5 5 0 512000 0 MOS /ondata/chunk011
10bfca50 6 6 512000 512000 503710 510697 POS /ondata/chunk320
10bfd6f8 6 6 512000 512000 0 MOS /ondata/chunk011
10bfcb28 7 7 0 1024000 53 PO- /ondata/chunk020
10bfcc00 8 7 512000 512000 270393 PO- /ondata/chunk210
10bfccd8 9 8 0 1024000 162 PO- /ondata/chunk030
10bfcdb0 10 8 0 512000 87984 PO- /ondata/chunk211
10bfce88 11 9 0 1024000 17 PO- /ondata/chunk220
10bfcf60 12 9 512000 512000 125954 PO- /ondata/chunk230
10bfd038 13 10 0 1024000 34271 PO- /ondata/chunk330
10bfd110 14 10 0 512000 511997 PO- /ondata/chunk210
10bfd1e8 15 8 0 1024000 1023997 PO- /ondata/chunk031
10bfd2c0 16 10 0 1024000 1023997 PO- /ondata/chunk311
10bfd398 18 14 100000 912000 11947 PO- /ondata/chunk010
10bfd7d0 18 14 0 912000 0 MO- /ondata/chunk310
10bfd470 19 15 0 512000 326434 PO- /ondata/chunk230
10bfd8a8 19 15 0 512000 0 MO- /ondata/chunk321
10bfd548 21 9 0 1024000 1023997 PO- /ondata/chunk221
19 active, 2047 maximum