Re: what will happened ?
Posted in 1998
Wu wrote: > > Hi everyone, > > I am running INFORMIX 7.24UC1 on LINUX. > > Appreciate if anyone can help me on guessing this (or probably you > have experience b4). > > My informix server has configured for 150,000 for the maximum number > of locks, what will happened If I still proceed to run a transaction > which required more than 150,000 ? Will the transaction still be > successful or failed ? The maximum number of locks in an IDS instance is 8 Million (8,000,000) See the release notes file: $INFORMIXDIR/release/en_us/0333/SERVERS_7.2 The Standard Engine (SE) on Linux uses OS locks and this is a kernel configurable. If you exceed the number of available locks the transaction will fail. If the database has logging the transaction will be rolled back. Art S. Kagel