UW7 and ontape: File size still limit with 2GB :-(
Posted in 1999
Topics: Backup & Restore
Hi all,
I tried to do a informix backup with ontape command but It always fail after
2GB even though I set ulimit to unlimited.
It doesn't matter backup to tape or to disk (on FS create with Volume
Manager)....both of them failed after 2GB.
I'm curious if UW7 can over come the limit 2GB of File size or not?
Thanks in advance for any help.
H.V
I have a 15 GByte database on Os5.05
and backup with ontape with no problem.
DBexport is limited to 2Gbytes on a tape.
It's fixed in version 8 on unixware I believe.
Huy Vu wrote:
>
> Hi all,
>
> I tried to do a informix backup with ontape command but It always fail after
> 2GB even though I set ulimit to unlimited.
>
> It doesn't matter backup to tape or to disk (on FS create with Volume
> Manager)....both of them failed after 2GB.
>
> I'm curious if UW7 can over come the limit 2GB of File size or not?
>
> Thanks in advance for any help.
>
> H.V
--
Clive Eisen
email ceisen@travel2.com voice (+44) 171 561 3000
ceisen@deepthwt.demon.co.uk (+44+ 7801 323 210
Huy Vu wrote:
>
> Hi all,
>
> I tried to do a informix backup with ontape command but It always fail after
> 2GB even though I set ulimit to unlimited.
>
> It doesn't matter backup to tape or to disk (on FS create with Volume
> Manager)....both of them failed after 2GB.
Ontape archives are NOT limited to 2GB, neither to tape not to disk,
unless the OS prevents appending to a file over 2GB. I archive, using
ontape, to a 5 drive DLT7000 RAID5 tape array with a single volume
capacity of 160GB compressed (80GB native 4 x 20GB). I have TAPESIZE
set to 120000000 (my data does not compress to 50%) and use the entire
120GB configured. What IDS version and what OS and tape device and
version?
> I'm curious if UW7 can over come the limit 2GB of File size or not?
>
> Thanks in advance for any help.
>
> H.V
Art S. Kagel
It's IDS 7.30UC2 on Unixware 7.0.1
The TAPESIZE set to 4000000 and ontape will fail after go to 30%
If I set TAPESIZE to 2000000, it will ask me to put the 2nd and 3rd
tape....
DH.
Art S. Kagel <kagel@bloomberg.net> wrote in message
news:37D918DF.F51F8595@bloomberg.net...
> Huy Vu wrote:
> >
> > Hi all,
> >
> > I tried to do a informix backup with ontape command but It always fail
after
> > 2GB even though I set ulimit to unlimited.
> >
> > It doesn't matter backup to tape or to disk (on FS create with Volume
> > Manager)....both of them failed after 2GB.
>
> Ontape archives are NOT limited to 2GB, neither to tape not to disk,
> unless the OS prevents appending to a file over 2GB. I archive, using
> ontape, to a 5 drive DLT7000 RAID5 tape array with a single volume
> capacity of 160GB compressed (80GB native 4 x 20GB). I have TAPESIZE
> set to 120000000 (my data does not compress to 50%) and use the entire
> 120GB configured. What IDS version and what OS and tape device and
> version?
>
> > I'm curious if UW7 can over come the limit 2GB of File size or not?
> >
> > Thanks in advance for any help.
> >
> > H.V
>
> Art S. Kagel
Hi,
here is a fast help :
Thinking you write the archive to a disk file called tape
Start a second terminal, cd to the backup dir
mv tape arcXXXX
touch tape
chmod 660 tape
now go back to the first terminal and press return, ontape will conuinue now.
when you have to restore the database copy the files one by one to the file
tape.
Some Informix versions are not compiled with the large file support.
I have this problem under IUS 9.14 and Solaris 2.6
Michael
Huy Vu schrieb:
> Hi all,
>
> I tried to do a informix backup with ontape command but It always fail after
> 2GB even though I set ulimit to unlimited.
>
> It doesn't matter backup to tape or to disk (on FS create with Volume
> Manager)....both of them failed after 2GB.
>
> I'm curious if UW7 can over come the limit 2GB of File size or not?
>
> Thanks in advance for any help.
>
> H.V