Re: unable to connect to DB server
Posted in 1999
Hello,
I assume you are running this on UNIX.
You server engine has crashed, but the shared memory segments have not been
removed. You can:
1. Use the 'ipcs -a' to look for shared memory segments and semaphores
owned by "informix" and remove them using ipcrm.
OR
2. Reboot the operating system.
You should look in your online.log file for messages regarding the
server crash and to find some /tmp/af.* files for more information.
Hope it helps,
Octav
On Thu, Feb 11, 1999 at 01:24:20PM +0530, Anil Khanna wrote:
> Hi all,
> I am a beginner in the Informix field.
> I hope you would be able to help me out.
> The problem I'm facing is that I'm not able to connect to the database
> server. The message I receive is
> "Attempt to connect to database server (????) failed."
> When I do "onstat -" it says
>
> *** WARNING: INFORMIX-OnLine server is no longer running. ***
>
>
> INFORMIX-OnLine Version 7.22.UC2 -- On-Line -- Up 23:26:38 -- 17808
> Kbytes
>
> *** WARNING: INFORMIX-OnLine server is no longer running. ***
>
> I'm using the above written version.
> Even I'm unable to do "onmonitor" for changing the mode.
> Please help me.
>
> Anil Khanna
>
> If opportunity doesn't knock, build a door.
>
--
Octav Chiriac Phone: (373) 2 21 20 96
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 24 00 83
Moldova, Republic of mailto:com@netinfo-moldova.com