Error on IWA initialization:Assert SEND_QUEUE_SIZE
Posted in 2012
A user installing Informix Warehouse Accelerator 11.70.FC4 got an assertion failure at ./ondwa start: "str.tellg() > 0 ... Invalid size definition '0' for SEND_QUEUE_SIZE". Fernando Nunes identified it as a known bug (PMR/APAR open) apparently triggered by a tellg() change in gcc 4.6 on newer/uncertified OSes. Workaround: explicitly set the values with units in the node*.conf files, i.e. SEND_QUEUE_SIZE=0b, and later also MAXIMUM_TASK_TERMINATION_LOG_AGE=60min after a similar error appeared in the Studio. The user confirmed this fixed it on his gcc-4.6-upgraded box, while an untouched SLES 11 worked fine.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Installation, Setup & Upgrades
Trying to create a Demo Informix Warehouse Accelerator (IWA) environment. Installation was fine but when trying to execute the ./ondwa start command, Error occurs when starting DWA_CM_node0 and DWA_CM_node1 on QueueHub initialization with error: An assertion 'str.tellg() > 0' failed. Additional info: Invalid size definition '0' encountered for parameter SEND_QUEUE_SIZE I've tried to find some help on docs and internet, but without success. IWA Version: 11.70.FC4 No IDS instance present on server. Somebody knows about this error?
you've to run this first before you start: ./ondwa setup Was the setup successful? Here's the info for installation and configuration. http://publib.boulder.ibm.com/infocenter/idshelp/v117/topic/com.ibm.acc.doc/ids_ acc_031.htm
I've seen this on Ubuntu... At the time I didn't have time to follow up... I moved to RH or CentOS... What OS and version are you using? I should have the same environment... I can try to replicate. At the time I tried to define that parameter in the configuration and it changed the message (the zero changed to the value I defined)... I can try to ask internally... Regards. On Tue, May 1, 2012 at 7:14 PM, VICENTE SALVADOR <vsalvador@deister.es>wrote: > Trying to create a Demo Informix Warehouse Accelerator (IWA) environment. > > Installation was fine but when trying to execute the ./ondwa start command, > > Error occurs when starting DWA_CM_node0 and DWA_CM_node1 > > on QueueHub initialization with error: > > An assertion 'str.tellg() > 0' failed. Additional info: Invalid size > definition '0' encountered for parameter SEND_QUEUE_SIZE > > I've tried to find some help on docs and internet, but without success. > > IWA Version: 11.70.FC4 > No IDS instance present on server. > > Somebody knows about this error? > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently... --20cf3005dc10cb146804beffd98f
Don't bother... apparently it can happen with several (new) OS. find the node*.conf files and add this: SEND_QUEUE_SIZE=0b We have a very recent PMR opened on this, and a new bug is already opened. Apparently, but this is not official information, some change in tellg() introduced in gcc 4.6 may be the cause of this. I'd appreciate if you could confirm that you're using a non-certified OS version...? Regards. On Tue, May 1, 2012 at 9:59 PM, Fernando Nunes <domusonline@gmail.com>wrote: > I've seen this on Ubuntu... At the time I didn't have time to follow up... > I moved to RH or CentOS... > What OS and version are you using? I should have the same environment... I > can try to replicate. > At the time I tried to define that parameter in the configuration and it > changed the message (the zero changed to the value I defined)... > I can try to ask internally... > > Regards. > > On Tue, May 1, 2012 at 7:14 PM, VICENTE SALVADOR <vsalvador@deister.es > >wrote: > > > Trying to create a Demo Informix Warehouse Accelerator (IWA) environment. > > > > Installation was fine but when trying to execute the ./ondwa start > command, > > > > Error occurs when starting DWA_CM_node0 and DWA_CM_node1 > > > > on QueueHub initialization with error: > > > > An assertion 'str.tellg() > 0' failed. Additional info: Invalid size > > definition '0' encountered for parameter SEND_QUEUE_SIZE > > > > I've tried to find some help on docs and internet, but without success. > > > > IWA Version: 11.70.FC4 > > No IDS instance present on server. > > > > Somebody knows about this error? > > > > > > > > > > ******************************************************************************* > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > > > -- > Fernando Nunes > Portugal > > http://informix-technology.blogspot.com > My email works... but I don't check it frequently... > > --20cf3005dc10cb146804beffd98f > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently... --20cf300fb319f3346704bf003f51
Hi Fernando, Thank you very much for your help. You catch it. It's a test computer and gcc and glib was upgraded to gcc 4.6. Tried on unmodified installed OS SuSe Enterprise 11 and it works flawlessly. Also for your information, adding SEND_QUEUE_SIZE=0b on node*.conf makes IWA work also on "touched" system. And also, I've tried also in Mandriva 2011 and adding "SEND_QUEUE_SIZE=0b" makes IWA work also on this uncertified OS. Sorry for the noise, but I cannot imagine how other team-mate has upgraded gcc on our test computer. This is the last think I would look for. Vicente Salvador
Good. But credits should go to our internal problem tracking system and our support staff :) Oh... And to the person who reported it to us (actually a very well known member of the Informix community, possibly reading this ;) ) Regards On Wed, May 2, 2012 at 1:30 AM, VICENTE SALVADOR <vsalvador@deister.es>wrote: > Hi Fernando, > > Thank you very much for your help. You catch it. It's a test computer and > gcc > and glib was upgraded to gcc 4.6. > > Tried on unmodified installed OS SuSe Enterprise 11 and it works > flawlessly. > > Also for your information, adding > > SEND_QUEUE_SIZE=0b > > on node*.conf makes IWA work also on "touched" system. And also, I've tried > also in Mandriva 2011 and adding "SEND_QUEUE_SIZE=0b" makes IWA work also > on > this uncertified OS. > > Sorry for the noise, but I cannot imagine how other team-mate has upgraded > gcc > on our test computer. This is the last think I would look for. > > Vicente Salvador > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently... --20cf300faeab9c4a5a04bf030013
FYI With gcc 4.6 and corresponding glib, other problems arraises. Trying to define a new Warehouse Accelerator with IBM Smart Analytics Optimizer Studio raises a new error: An assertion 'false' failed. Additional info: An invalid configuration setting was found in condition 'str.tellg() > 0': Invalid time/timeout definition '30000' encountered for parameter MAXIMUM_TASK_TERMINATION_LOG_AGE (AQT10050I).
Other config parameter should be added to node*.conf to IWA work properlly on gcc 4.6 systems. SEND_QUEUE_SIZE=0b MAXIMUM_TASK_TERMINATION_LOG_AGE=60min