onload questions
Posted in 2017
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion
IDS 11.50.FC5
Solaris 10
I sent this in a couple of days ago, but I never saw it posted.
---
I created an onunload copy of a database on a server. The original database is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
I don't have access to the source code any more, so can't code chase any
replies. However the restrictions for onload/onunload is found on page 13-1 of
the Migration Guide...
The onload/onunload is in binary format and is a page dump. That would imply
that a 2K page source needs to go into a 2K page target, also that an 8K page
source needs to go into an 8K page target. The documentation states that if
the source/target page sizes are different, then onload will fail.
Beca Madison Pruet
Retired and Loving it
On Wednesday, February 15, 2017 2:42 PM, LARRY SORENSEN <LSORENSEN25@msn.com>
wrote:
IDS 11.50.FC5
Solaris 10
I sent this in a couple of days ago, but I never saw it posted.
---
I created an onunload copy of a database on a server. The original database is
housed in two difference dbspaces, a 2k and an 8k.
Questions
Does the unload contain any dbspace information? How does it know to send the
tables to the different dbspaces?
If I specify a dbspace with -d that is 2k pages, it appears to want to put
everything there.
If I specify the dbspace that is 8k pages, I receive an error message after a
while.
If I do not specify a dbspace, it appears to fill up the rootdbs.
Larry
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.