Re: Strange happening with onmonitor
Posted in 1999
Hi, Malcolm,
Sounds like one of the shared libs got overwritten, and you re-install
fixed it.
Nota bene: while installing 7.30 on an IBM Aix 4.2 RS6000 system, I read
somewhere that install order doesn't matter. Hallelujah! Guess what? It
does.
Informix tech confirmed this and told me that this was the direction
development was working in, and somehow the wires got crossed; hence, the
reason for the misleading info in the documentation (or at least
contradictory, since other docs say otherwise).
If it continues to happen, you can give support a copy of the
coredump ;-? (wry smiley).
Yours,
Nick
On Sat, 21 Aug 1999, Malcolm Weallans wrote:
> Yesterday I observed something really strange and wondered if any of you
> had ever seen anything similar. We had been running 7.30 UC6?(it may have
> been 7 - i'm not on site any more to check it out) on a number of SGI
> boxes. We used onmonitor successfully in the morning but towards the
> middle of the afternoon we kept getting memory-fault core dumped, and bus
> error core dumped messages from nearly every facility of onmonitor
> including displays. The system had been installed for a long time with no
> problems and the instance we were running had been up for 57 days. The
> normal user uses onmonitor quite a lot. We tried out 2 other machines, one
> with the same hardware and one with a different processor. All 3 systems
> had the same problem. Everything else worked normally and onstat was
> running OK. We tried shutting down an instance and bringing it up again.
> Still no joy. Eventually we decided to re-install the software from the
> distribution media. The problem went away on one of the machines. As the
> other machines are in "pseudo production" we are unable to confirm that the
> same solution would work elsewhere.
>
> Your views would be much appreciated.
>
> regards
>
> Malcolm
>