Problems with Online DSA Ver. 6.00 on Solaris 2.3
Posted in 1995
One of our clients is having following problems with Informix Online Dynamic
Server Ver. 6.00.UE2 on Solaris 2.3 on a Sun Sparc Server 20.
1) This has got the case number 26287
By executing ondatartr he gets the error message
Error occured during salvage log processing
Informix told him that this is due to a bug in Ver. 6.0 in archiving the logicallogs and that he should update to Ver. 7.x.
The client is not able to update to Ver. 7.x. at this time so is there a
work around possible in order to have safe archiving and retrieving ?
2) This has got the case number 26261
An execution of a stored procedure in a select statement like
echo "select nvl_varchar(dummy,'a') from dual" | isql fais
results in the following error messages:
25587: Network receive failed
25588: The appl process cannot connect to Online server faisdb
The stored procedure nvl_varchar looks like:
create procedure nvl_varchar(wert varchar(255),
ersatz varchar(255)
)
returning varchar(255); if (wert is null) then
return ersatz;
else
return wert;
end if
end procedure;
The Logfile protocols the following messages:
10:56:09 Assert Failed: Internal Error - Segmentation Violation
10:56:09 Who: Session(25, cgnfais ac 459, 13260, 4)
Thread(43,sqlexec, a02b680, 1)
10:56:09 Results: Online must abort
10:56:09 Action: Reinitialize shared memory
10:56:09 See Also: /tmp/af.1042ba, shmem.1042ba.0
10:56:21 rsdebug.c, line 3255, thread 43, proc id 9323, Segmentationviolation
10:56:21 PANIC: Attempting to bring system down
If you have any suggestions please directly email me as my newsgroup provider
is not so reliable
TIA
Tolis Varnas
+----------------------------------------------------------------------------+
| Tolis Varnas email: tvarnas@compulink.gr |
| Deligiorgi 26 Voice: (30) 31 820270 |
| 546 42 Thessaloniki Fax: (30) 31 865463 |
| Greece |
+----------------------------------------------------------------------------+