Re: Help Loading table from flat file.
Posted in 1997
Beside the main point you've raised, why don't you avoid the flat file
totally by using a single statement as follows :
insert into dbase2:table
select * from dbase1:table
where ....
In article <5knte3$gqb$1@news1.exit109.com>,
ernieg@hiway1.exit109.com (Ernie Graeler) wrote:
>I am currently trying to move the contents of a table from one database
>to another. The way I am doing this is I've created a duplicate of the table
>in database1 in database2 then I unloaded the table from database1 into a
>flat file. Then I plan on loading the flat file into the table in
database2.
>The problem I am having is this: The load from the flat file into the table
>on database2 fails with the following error:
> 847: Error in load file line 862.>The line number changes every time I try. I looked at the file, but don't
see
>any problems. The table has 1852 rows and is over 5MB in size. I split the
file
>up into 4 flat files. When I loaded from the 4 flat files, everything worked
>and loaded OK. I see this as a problem. Informix should be able to handle a
>5MB file of 1852 rows. Could it be a configuration setting? I'm running
>On-Line Dynamic Server Version 7.2. Any Ideas out there?
>
>Thanks in advance,
>Ernst Graeler egraeler@commvault.com
>
-----------------------
Rudy Fernandes
GIC, Kuwait
OL 7.20UC4, 4GL 6.04UC1
-----------------------