Enterprise Replication no start or stop
Posted in 2004
Topics: High Availability & Replication, Server Administration
Hello everybody,
I have a problem with enterprice replication.
Informix version is 9.30.UC2W8
I delete server from replication and now i can't do anything.
When I run command: "cdr start"
the answer is that it's already active (63)
when I run command: "cdr stop"
the message is not active (62)
What must I do ?
The value of "status" in table "cdrstate" in database "syscdr" is 7.
some messages from online.log:
12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/1431/0x39680/0x0) dberror=-7420 thread 62 queue trg_send
12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/0/0x271/0x0) dberror=-7420 thread 62 queue control_send
12:01:22 CDR queuer initialization complete
12:01:22 DDR Log Snooping - Snooping started in log 1451
12:22:59 CDR GC: operation catalog purge (drop) failed (error -214).
12:22:59 CDR shutdown failed
11:25:54 CDR Initialization failed (illegal CDR state, aborting).
11:26:10 CDR Initialization failed (illegal CDR state, aborting).
onstat -g ath:
Threads:
tid tcb rstcb prty status vp-class name
2 f58ba00 0 2 sleeping forever 3lio lio vp 0
3 f626148 0 2 sleeping forever 4pio pio vp 0
4 f63b148 0 2 sleeping forever 5aio aio vp 0
5 f650148 0 2 sleeping forever 6msc msc vp 0
6 f67d148 0 2 sleeping forever 7aio aio vp 1
7 f6922a8 f124018 4 sleeping secs: 1 1cpu
main_loop()
8 f692e58 0 2 running 1cpu
tlitcppoll
9 f6264f8 0 2 running 8shm sm_poll
10 f6c7860 0 3 sleeping forever 1cpu
tlitcplst
11 f650290 0 3 sleeping forever 1cpu
sm_listen
12 f67dd10 0 2 sleeping secs: 1 1cpu
sm_discon
13 f67de58 f124618 2 sleeping forever 1cpu
flush_sub(0)
14 f720018 0 4 sleeping forever 1cpu kaio
15 f720d50 f124c18 3 sleeping forever 1cpu
aslogflush
16 f7d42d8 f125218 2 sleeping secs: 31 1cpu btclean
32 fae11f8 f126418 4 sleeping secs: 1 1cpu
onmode_mon
39 f94e1b0 0 2 sleeping forever 9lio lio vp 1
40 fae1068 0 2 sleeping forever 10pio pio vp 1
42 f7fb318 f125818 2 cond wait netnorm 1cpu sqlexec
Are the times of the two servers within 5 mintues of one another? As far as
I can tell almost every ER problem is caused by this!
"Darek" <darek_usunto@supra.com.pl> wrote in message
news:chuk81$bah$1@nemesis.news.tpi.pl...
> Hello everybody,
>
> I have a problem with enterprice replication.
> Informix version is 9.30.UC2W8
>
> I delete server from replication and now i can't do anything.
>
> When I run command: "cdr start"
> the answer is that it's already active (63)
> when I run command: "cdr stop"
> the message is not active (62)
> What must I do ?
>
> The value of "status" in table "cdrstate" in database "syscdr" is 7.
>
> some messages from online.log:
> 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/1431/0x39680/0x0)> dberror=-7420 thread 62 queue trg_send
> 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/0/0x271/0x0)> dberror=-7420 thread 62 queue control_send
> 12:01:22 CDR queuer initialization complete
> 12:01:22 DDR Log Snooping - Snooping started in log 1451
>
> 12:22:59 CDR GC: operation catalog purge (drop) failed (error -214).
> 12:22:59 CDR shutdown failed
>
> 11:25:54 CDR Initialization failed (illegal CDR state, aborting).
> 11:26:10 CDR Initialization failed (illegal CDR state, aborting).>
>
>
> onstat -g ath:>
> Threads:
> tid tcb rstcb prty status vp-class name
> 2 f58ba00 0 2 sleeping forever 3lio lio vp
0
> 3 f626148 0 2 sleeping forever 4pio pio vp
0
> 4 f63b148 0 2 sleeping forever 5aio aio vp
0
> 5 f650148 0 2 sleeping forever 6msc msc vp
0
> 6 f67d148 0 2 sleeping forever 7aio aio vp
1
> 7 f6922a8 f124018 4 sleeping secs: 1 1cpu
> main_loop()
> 8 f692e58 0 2 running 1cpu
> tlitcppoll
> 9 f6264f8 0 2 running 8shm
sm_poll
> 10 f6c7860 0 3 sleeping forever 1cpu
> tlitcplst
> 11 f650290 0 3 sleeping forever 1cpu
> sm_listen
> 12 f67dd10 0 2 sleeping secs: 1 1cpu
> sm_discon
> 13 f67de58 f124618 2 sleeping forever 1cpu
> flush_sub(0)
> 14 f720018 0 4 sleeping forever 1cpu kaio
> 15 f720d50 f124c18 3 sleeping forever 1cpu
> aslogflush
> 16 f7d42d8 f125218 2 sleeping secs: 31 1cpu
btclean
> 32 fae11f8 f126418 4 sleeping secs: 1 1cpu
> onmode_mon
> 39 f94e1b0 0 2 sleeping forever 9lio lio vp
1
> 40 fae1068 0 2 sleeping forever 10pio pio vp
1
> 42 f7fb318 f125818 2 cond wait netnorm 1cpu
sqlexec
>
>
>
>
Time is differ from 130 to 150 seconds:
11:41:29 CDR NIF site: 1 <grp_master> clocks differ by 150 seconds
U'ytkownik "Neil Truby" <neil.truby@ardenta.com> napisa' w wiadomo'ci
news:2qg36eFurkquU1@uni-berlin.de...
> Are the times of the two servers within 5 mintues of one another? As far
as
> I can tell almost every ER problem is caused by this!
>
> "Darek" <darek_usunto@supra.com.pl> wrote in message
> news:chuk81$bah$1@nemesis.news.tpi.pl...
> > Hello everybody,
> >
> > I have a problem with enterprice replication.
> > Informix version is 9.30.UC2W8
> >
> > I delete server from replication and now i can't do anything.
> >
> > When I run command: "cdr start"
> > the answer is that it's already active (63)
> > when I run command: "cdr stop"
> > the message is not active (62)
> > What must I do ?
> >
> > The value of "status" in table "cdrstate" in database "syscdr" is 7.
> >
> > some messages from online.log:
> > 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/1431/0x39680/0x0)> > dberror=-7420 thread 62 queue trg_send
> > 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/0/0x271/0x0)> > dberror=-7420 thread 62 queue control_send
> > 12:01:22 CDR queuer initialization complete
> > 12:01:22 DDR Log Snooping - Snooping started in log 1451
> >
> > 12:22:59 CDR GC: operation catalog purge (drop) failed (error -214).
> > 12:22:59 CDR shutdown failed
> >
> > 11:25:54 CDR Initialization failed (illegal CDR state, aborting).
> > 11:26:10 CDR Initialization failed (illegal CDR state, aborting).> >
> >
> >
> > onstat -g ath:> >
> > Threads:
> > tid tcb rstcb prty status vp-class name
> > 2 f58ba00 0 2 sleeping forever 3lio lio
vp
> 0
> > 3 f626148 0 2 sleeping forever 4pio pio
vp
> 0
> > 4 f63b148 0 2 sleeping forever 5aio aio
vp
> 0
> > 5 f650148 0 2 sleeping forever 6msc msc
vp
> 0
> > 6 f67d148 0 2 sleeping forever 7aio aio
vp
> 1
> > 7 f6922a8 f124018 4 sleeping secs: 1 1cpu
> > main_loop()
> > 8 f692e58 0 2 running 1cpu
> > tlitcppoll
> > 9 f6264f8 0 2 running 8shm
> sm_poll
> > 10 f6c7860 0 3 sleeping forever 1cpu
> > tlitcplst
> > 11 f650290 0 3 sleeping forever 1cpu
> > sm_listen
> > 12 f67dd10 0 2 sleeping secs: 1 1cpu
> > sm_discon
> > 13 f67de58 f124618 2 sleeping forever 1cpu
> > flush_sub(0)
> > 14 f720018 0 4 sleeping forever 1cpu kaio
> > 15 f720d50 f124c18 3 sleeping forever 1cpu
> > aslogflush
> > 16 f7d42d8 f125218 2 sleeping secs: 31 1cpu
> btclean
> > 32 fae11f8 f126418 4 sleeping secs: 1 1cpu
> > onmode_mon
> > 39 f94e1b0 0 2 sleeping forever 9lio lio
vp
> 1
> > 40 fae1068 0 2 sleeping forever 10pio pio
vp
> 1
> > 42 f7fb318 f125818 2 cond wait netnorm 1cpu
> sqlexec
> >
> >
> >
> >
>
>
I'm assuming that you tried to issue the delete server for some reason the
delete server failed.
Did you also issue the delete server on one of the other nodes? It's
necessary to ensure that the rest of the replication domain is aware that
the server has been removed.
In older versions of the engine, we did have a problem in that if the state
was dropped, we weren't always dropping the syscdr database prior to
initializing the server. State '7' indicates that a delete server was run.
Are the ER threads running? If not, then you may be able to manually drop
the syscdr database and then redefine the server. I don't know why you got
the -214 error, but it does indicate that the drop database command was
unsuccessful.
Don't forget, however, you need to ensure that the rest of the system is
aware that the server has been dropped.
"Darek" <darek_usunto@supra.com.pl> wrote in message
news:chuk81$bah$1@nemesis.news.tpi.pl...
> Hello everybody,
>
> I have a problem with enterprice replication.
> Informix version is 9.30.UC2W8
>
> I delete server from replication and now i can't do anything.
>
> When I run command: "cdr start"
> the answer is that it's already active (63)
> when I run command: "cdr stop"
> the message is not active (62)
> What must I do ?
>
> The value of "status" in table "cdrstate" in database "syscdr" is 7.
>
> some messages from online.log:
> 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/1431/0x39680/0x0)> dberror=-7420 thread 62 queue trg_send
> 12:01:22 CDR RQM: rqmPurgeSpool() failed for KEY (1/0/0x271/0x0)> dberror=-7420 thread 62 queue control_send
> 12:01:22 CDR queuer initialization complete
> 12:01:22 DDR Log Snooping - Snooping started in log 1451
>
> 12:22:59 CDR GC: operation catalog purge (drop) failed (error -214).
> 12:22:59 CDR shutdown failed
>
> 11:25:54 CDR Initialization failed (illegal CDR state, aborting).
> 11:26:10 CDR Initialization failed (illegal CDR state, aborting).>
>
>
> onstat -g ath:>
> Threads:
> tid tcb rstcb prty status vp-class name
> 2 f58ba00 0 2 sleeping forever 3lio lio vp
0
> 3 f626148 0 2 sleeping forever 4pio pio vp
0
> 4 f63b148 0 2 sleeping forever 5aio aio vp
0
> 5 f650148 0 2 sleeping forever 6msc msc vp
0
> 6 f67d148 0 2 sleeping forever 7aio aio vp
1
> 7 f6922a8 f124018 4 sleeping secs: 1 1cpu
> main_loop()
> 8 f692e58 0 2 running 1cpu
> tlitcppoll
> 9 f6264f8 0 2 running 8shm
sm_poll
> 10 f6c7860 0 3 sleeping forever 1cpu
> tlitcplst
> 11 f650290 0 3 sleeping forever 1cpu
> sm_listen
> 12 f67dd10 0 2 sleeping secs: 1 1cpu
> sm_discon
> 13 f67de58 f124618 2 sleeping forever 1cpu
> flush_sub(0)
> 14 f720018 0 4 sleeping forever 1cpu kaio
> 15 f720d50 f124c18 3 sleeping forever 1cpu
> aslogflush
> 16 f7d42d8 f125218 2 sleeping secs: 31 1cpu
btclean
> 32 fae11f8 f126418 4 sleeping secs: 1 1cpu
> onmode_mon
> 39 f94e1b0 0 2 sleeping forever 9lio lio vp
1
> 40 fae1068 0 2 sleeping forever 10pio pio vp
1
> 42 f7fb318 f125818 2 cond wait netnorm 1cpu
sqlexec
>
>
>
>
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g