Re: dbimport question
Posted in 1997
On 10 Dec 97 at 17:16, Jason Berryhill wrote:
> Hello all:
>
> We are running Inf. Online Dyn. Server 7.x on NT Server 4.0 (four
> way 200 pentium pro processors with 2GB RAM). I am trying to load a
> database from a set of tapes we received that was created with a
> dbexport from the exact same version of informix but was off a UNIX
> box.
>
> The error I am receiving is that the dbimport is unable to connect
> to the tape device with a return code of 22.
>
> Can anyone help in the following:
>
> 1. Does anyone know what the return code of 22 in dbimport means?
In SCO UNIX, error -22 means:
-22 Invalid argument.
An operating system error code with the meaning shown was
unexpectedly returned to the database server. Look for operating
system error messages that may give more information. If the error
recurs, please note all circumstances and contact the Informix
Technical Support Department.
> 2. Can anyone think of a reason an NT box would not be able to
> read tapes cut on a UNIX machine?
OTTOMH, your tape driver versions could be incompatible .... I'm sure
there are others.
It may, however, be something as "simple" as a bad config of your
tape. Can you access the tape via Informix for anything else?
Can you not dbexport to disk and either mount drives across the
network with NFS or SAMBA or FTP the data files to the new machine?
HTH.
--
Ciao,
Billy
Back at the gold-face in sunny Gauteng...
Informix FAQ @ http://www.iiug.org/techinfo/faq/faq_top.html
Drivel @ http://www.west.co.za/tasteless/