HDR Secondary Server stuck in fast recovery
Posted in 2003
Topics: High Availability & Replication, Backup & Restore, Storage & Space Management, Server Administration, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi,
I am running the HDR feature with IDS 9.40 UC2 on Sun Solaris.
I'm having the following problem when I try starting HDR
for the first time on a busy system.
Here are the steps I carry out:
On the Primary Server ( starts off in online standard mode):
1. Run a full Backup of the database -
ontape -s -L 0
2. Switch the server mode from standard to primary
onmode -d primary fvh
where fvh = secondary servername
3. Copy across the database from the Primary to the Backup Server
On the Backup Server ( starts off in offline standard mode)
4. Run a Full Restore of the database in HDR mode -
ontape -p
5. Switch the server mode from standard to secondary
onmode -d secondary fv
where fv = primary servername
The problem is that after step 5, I get the following message in the IDS
logfile on the primary server and the secondary server remains in fast
recovery mode.
16:50:05 DR: Receive error
16:50:05 DR: Type exchange failed
The only way I can get out of the fast recovery mode is to stop and start
the IDS on the secondary server.
Primary Server Logfile:
16:43:20 Level 0 Archive started on rootdbs, ext, fault, fusion_events
16:45:40 Logical Log 24 Complete, timestamp:646449.
16:45:44 Logical Log 24 - Backup Started
16:45:45 Logical Log 24 - Backup Completed
16:46:37 Archive on rootdbs, ext, fault, fusion_events Completed.
16:46:38 DR: new type = primary, secondary server name = fvh
16:46:38 DR: Trying to connect to secondary server = fvh
16:46:39 DR: Cannot connect to secondary server
16:46:39 DR: Turned off on primary server
16:50:05 DR: Receive error
16:50:05 DR: Type exchange failed
Secondary Server Logfile:
16:48:34 Recovery Mode
16:49:47 Physical Restore of rootdbs, ext, fault, fusion_events started.
16:50:02 Checkpoint Completed: duration was 0 seconds.
16:50:02 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595295
16:50:02 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595302
16:50:20 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595309
16:50:20 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595316
16:50:20 Maximum server connections 0
16:50:21 Physical Restore of rootdbs, ext, fault, fusion_events Completed.
16:50:21 Checkpoint Completed: duration was 0 seconds.
16:50:21 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595321
16:50:21 Maximum server connections 0
16:50:22 DR: Reservation of the last logical log for log backup turned off
16:50:22 DR: new type = secondary, primary server name = fv
16:50:22 DR: Trying to connect to primary server = fv
Any ideas on why I'm getting these errors?
This problem happens occasionally when the primary server is busy.
When the system is not busy, HDR works fine. I've set DRTIMEOUT to 5
seconds. Is there any rule of thumb when setting this parameter?
Thanks,
John
is fvh
the hostname or the databaseserver name?
you must use database server name.
-----Ursprüngliche Nachricht-----
Von: WHELAN JOHN [mailto:john.whelan@marconi.com]
Gesendet: Mittwoch, 10. Dezember 2003 13:30
An: ids@iiug.org
Betreff: HDR Secondary Server stuck in fast recovery [2331]
Hi,
I am running the HDR feature with IDS 9.40 UC2 on Sun Solaris.
I'm having the following problem when I try starting HDR
for the first time on a busy system.
Here are the steps I carry out:
On the Primary Server ( starts off in online standard mode):
1. Run a full Backup of the database -
ontape -s -L 0
2. Switch the server mode from standard to primary
onmode -d primary fvh
where fvh = secondary servername
3. Copy across the database from the Primary to the Backup Server
On the Backup Server ( starts off in offline standard mode)
4. Run a Full Restore of the database in HDR mode -
ontape -p
5. Switch the server mode from standard to secondary
onmode -d secondary fv
where fv = primary servername
The problem is that after step 5, I get the following message in the IDS
logfile on the primary server and the secondary server remains in fast
recovery mode.
16:50:05 DR: Receive error
16:50:05 DR: Type exchange failed
The only way I can get out of the fast recovery mode is to stop and start
the IDS on the secondary server.
Primary Server Logfile:
16:43:20 Level 0 Archive started on rootdbs, ext, fault, fusion_events
16:45:40 Logical Log 24 Complete, timestamp:646449.
16:45:44 Logical Log 24 - Backup Started
16:45:45 Logical Log 24 - Backup Completed
16:46:37 Archive on rootdbs, ext, fault, fusion_events Completed.
16:46:38 DR: new type = primary, secondary server name = fvh
16:46:38 DR: Trying to connect to secondary server = fvh
16:46:39 DR: Cannot connect to secondary server
16:46:39 DR: Turned off on primary server
16:50:05 DR: Receive error
16:50:05 DR: Type exchange failed
Secondary Server Logfile:
16:48:34 Recovery Mode
16:49:47 Physical Restore of rootdbs, ext, fault, fusion_events started.
16:50:02 Checkpoint Completed: duration was 0 seconds.
16:50:02 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595295
16:50:02 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595302
16:50:20 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595309
16:50:20 Maximum server connections 0
16:50:20 Checkpoint Completed: duration was 0 seconds.
16:50:20 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595316
16:50:20 Maximum server connections 0
16:50:21 Physical Restore of rootdbs, ext, fault, fusion_events Completed.
16:50:21 Checkpoint Completed: duration was 0 seconds.
16:50:21 Checkpoint loguniq 24, logpos 0x15a018, timestamp: 595321
16:50:21 Maximum server connections 0
16:50:22 DR: Reservation of the last logical log for log backup turned off
16:50:22 DR: new type = secondary, primary server name = fv
16:50:22 DR: Trying to connect to primary server = fv
Any ideas on why I'm getting these errors?
This problem happens occasionally when the primary server is busy.
When the system is not busy, HDR works fine. I've set DRTIMEOUT to 5
seconds. Is there any rule of thumb when setting this parameter?
Thanks,
John